Page 1 of 2

Not supported in FF 6.0.1

PostPosted: Thu Sep 01, 2011 4:56 pm
by lsilva
My OPIE icon disappeared :( I checked my add ons and saw OPIE was disabled because it does not run in FF 6.0.1. Will this get fixed soon?

Re: Not supported in FF 6.0.1

PostPosted: Fri Sep 02, 2011 11:53 am
by cbaker_admin
Try re-installing from the AMO page. It should be compatible up to Fx 8.*

Re: Not supported in FF 6.0.1

PostPosted: Fri Sep 02, 2011 2:19 pm
by lsilva
Thanks. Works now.

Re: Not supported in FF 6.0.1

PostPosted: Sun Sep 04, 2011 4:19 pm
by moocan
Hi,

I Have the same problem on MacOSX 10.6 and FF 6.0.1.
Have tried to uninstall and reinstall (from firefox addon page) but no OPIE menu appears under firefox tools menu and no OPIE icon appear in front of the extension.

Do you have any advices ?

Kind Regards

Re: Not supported in FF 6.0.1

PostPosted: Sun Sep 04, 2011 6:11 pm
by cbaker_admin
Please post any OPIE related errors in the error console (Tools > Error Console) using the ConsoleĀ² extension for error checking. (type opie in the "Search:" box and make sure only the "Errors" tab is selected ... not "All", "Warnings", or "Messages"). Copy/paste them here.

Re: Not supported in FF 6.0.1

PostPosted: Mon Sep 05, 2011 12:18 am
by moocan
Hi,
I have upgraded to 3.0.1 from your web site but always the same things
I have tried to remove OPIE and then reinstall too.

I have restarted FF and here are the two errors I get:
Code: Select all
Error: gBrowser.addProgressListener was called with a second argument, which is not supported. See bug 608628.
Source File: chrome://browser/content/tabbrowser.xml
Line: 1846


Code: Select all
Error: aNode is null
Source File: chrome://browser/content/nsContextMenu.js
Line: 364


I don't have any errors related to OPIE as if OPIE was not loaded but OPIE extension is well enabled.

I return back to 3.0 from FF addon page
Have found these messages under warning:
Code: Select all
Warning: XUL box for span element contained an inline #text child, forcing all its children to be wrapped in a block.
Source File: https://addons.mozilla.org/en-US/firefox/addon/opie/
Line: 0

Warning: Error in parsing value for 'filter'.  Declaration dropped.
Source File: https://addons.mozilla.org/en-US/firefox/addon/opie/
Line: 0

Warning: Unknown property 'text-overflow'.  Declaration dropped.
Source File: https://addons.mozilla.org/en-US/firefox/addon/opie/
Line: 0


Kind Regards

Re: Not supported in FF 6.0.1

PostPosted: Mon Sep 05, 2011 6:44 am
by cbaker_admin
Please install the ConsoleĀ² extension for error checking. It is more comprehensive.

Try this: Close all tabs and restart Firefox. Open and clear the Error console. Leave it open and click Tools > OPIE. Examine the error console for any OPIE related error messages (type opie in the "Search:" box). Copy/paste them here.

Re: Not supported in FF 6.0.1

PostPosted: Mon Sep 05, 2011 2:08 pm
by moocan
Hi many thanks for your answer.

I will install console2 addon and follow all your steps but I don't have any OPIE Menu in FF Tools menu.
I can only access preference menu using the right menu on OPIE extension in FF extension store but nothing happens.

I will post results using preference menu hopping some results.

Kind Regards

Re: Not supported in FF 6.0.1

PostPosted: Mon Sep 05, 2011 2:31 pm
by moocan
The only error message that i can get using preference menu under right menu on OPIE extension is this one :

Error: aWindow.document.commandDispatcher is undefined
Source file: chrome://global/content/macWindowMenu.js
Line: 25

But i don't have any OPIE menu under FF Tools menu. I have installed FEBE and CLEO extension too and these extension appears well under FF Tool Menu.
I have checked extension folder using FEBE and all are reported as OK (including OPIE).

Kind Reagrds and many thanks for your help.

Re: Not supported in FF 6.0.1

PostPosted: Tue Sep 13, 2011 5:48 pm
by thorn
hi, i'm on fedora linux ff 6.0.2

if i download opie (3.0 & 3.0.1) from your site or from the mozilla (3.0) site or in addon manager (3.0) it seems to be inactive.

i can't see opie in my customize toolbar option but it's listed in my extension list (with no icon) (preferences has no result)(3.0.1 has no preferences option)

error console2:

XML: failed to load overlay from chrome://opie/content/opieOverlay.xul.
chrome://browser/content/browser.xul


thanks for the good work.

Re: Not supported in FF 6.0.1

PostPosted: Wed Sep 14, 2011 2:47 pm
by cbaker_admin
I encountered the same problem exactly once during development of v3.0.1 but it mysteriously fixed itself in a subsequent install. Can you try installing only OPIE in a new profile? I'm curious if it is a possible timing issue with some other extension.

Re: Not supported in FF 6.0.1

PostPosted: Fri Sep 16, 2011 5:58 pm
by thorn
i created a fresh profile and got the same results as before

Re: Not supported in FF 6.* & 7.*

PostPosted: Thu Sep 29, 2011 5:37 pm
by akwala
I haven't been able to get OPIE to work in FF 6 or 7. I just installed it in a new profile of FF 7 and saw the same thing I've seen in other profiles: after installation, clicking on OPIE's Preferences button (in Addon Manager) does nothing; I didn't seen any related errors in the Error Console. OPIE does not appear in the Tools menu either.

I have it installed and enabled in another profile, where the Preferences button doesn't appear anymore in OPIE's listing in the Addon Manager.

Re: Not supported in FF 6.0.1

PostPosted: Thu Sep 29, 2011 7:07 pm
by cbaker_admin
Actually, OPIE does not have an options window as there are no options to set. In older versions there was an options button in the Addons Manager, but it did not really do anything. I'm not sure why OPIE is not appearing in the Tools menu. Do you have an icon displayed in the Customize... window that you can drag/drop into a toolbar (right-click on a toolbar > Customize...)?

There should also be a link in the orange Firefox button:

Image

What version of OPIE are you using? The latest is v3.0.1.

Re: Not supported in FF 6.0.1

PostPosted: Sat Oct 08, 2011 4:25 pm
by david6
(REPOST, from: OPIE 3.0 not working at all in FF 5 (Ubuntu 11, Gnome 2. )

My OPIE also stopped working at update to FF 5 (Ubuntu 11.04).

I still have no OPIE (neither icon, or tool menu), even after removing, restart, etc. and re-installing from author's site. So, I now have OPIE 3.01 on the Add-Ons list, and it now shows NO preferences (the only change I have noticed.).

I am currently on Ubuntu 11.04, Gnome 2.32.1, FF 7.01. I have FEBE 7.0.2 and CLEO 5.0.1 installed, and still working ..


Is there ANY progress on this?

(I'm am trying to copy my settings / add-ons to a friend's new PC.)