Configure problem when changing add-ons

"Ordered Preference Import/Export" discussion and bug reporting.

Configure problem when changing add-ons

Postby anon42 » Wed Nov 07, 2012 7:46 pm

One of the add-ons I have been using is Restartless Restart (v8). I discovered a small "quirk" with it so I decided to use Restart Firefox (v0.6b2) instead. After doing that I found out that OPIE's Configure would no longer populate its Extension pane when I clicked the "Get extension info" pane.

I assumed that since the saved configuration info in OPIEedits.json still referenced Restartless Restart, and that Restartless Restart is no longer installed, OPIE's Configure is tripping up on the missing add-on*. I pretty much confirmed this by removing OPIEedits.json and then OPIE's Configure was able to repopulate the Extensions pane. Of course then I had to redo my few special case Preference root's (Tab Mix Plus, etc.).

I assume the generalization of this problem is that if the set of installed add-ons changes such that OPIEedits.json references a uninstalled add-on OPIE's Configuration's "Get extension info" fails. If this is indeed the proper specification of the problem then it would be nice if OPIE would "fail" more gracefully, i.e., ignore the missing add-ons (or associated prefs.js info) it cannot find and attempt to fill in the Extension pane with the valid info it does have. That, or at least give some appropriate warning message.

----

* I don't recall the exact sequence of events but I removed the Restartless Restart preferences from prefs.js. It's possible that the fact that these were now missing was the reason Configure tripped up. But I am pretty sure I've encountered this problem before experimenting with add-ons and didn't delete the associated prefs.js items.
anon42
 
Posts: 25
Joined: Wed Oct 24, 2012 2:17 pm

Re: Configure problem when changing add-ons

Postby cbaker_admin » Mon Nov 12, 2012 10:08 am

I've added this problem to my OPIE todo list. I should have a fix for the next release.
cbaker_admin
Site Admin
 
Posts: 4522
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Configure problem when changing add-ons

Postby anon42 » Mon Nov 12, 2012 10:06 pm

Thank you yet again!
anon42
 
Posts: 25
Joined: Wed Oct 24, 2012 2:17 pm


Return to OPIE

Who is online

Users browsing this forum: No registered users and 3 guests

cron