addon not listed

"Ordered Preference Import/Export" discussion and bug reporting.

addon not listed

Postby Bito » Wed Apr 30, 2014 5:30 am

Hi Chuck,

using the last official version of Firefox (v. 29.0, German version), OPIE 4.2 does not show the installed addon "ClassicThemeRestorer (Customize Australis)" https://addons.mozilla.org/de/firefox/addon/classicthemerestorer/?src=ss on "Get-List" in the "Export" panel:

OPIE_get_list_crop.jpg
OPIE_get_list_crop.jpg (35.78 KiB) Viewed 2460 times


On the coniguration panel, though, OPIE finds the according information when I press Get extension info. "preference root" and "preference count" are declared as "unknown":

OPIE_config.jpg
OPIE_config.jpg (45.81 KiB) Viewed 2460 times


When I use the "verify extension directory" function within FEBE (http://www.customsoftwareconsult.com/forum/viewtopic.php?f=10&t=1731), FEBE returns that it has found this addon:

...
ClassicThemeRestorer@ArisT2Noia4dev Classic Theme Restorer (Customize Australis) - OK
...

On about:config I find several lines beginning with extensions.classicthemerestorer.
In the error console there are no OPIE-related items.

What do I have to do that OPIE finds this extension's preferences?

Greetings from Munich, Germany
Bito
 
Posts: 10
Joined: Tue Jan 28, 2014 3:34 am

Re: addon not listed

Postby cbaker_admin » Wed Apr 30, 2014 3:47 pm

You just need to tell OPIE what the extension root is. Open OPIE > Configure (as shown in your second image in the above post). Double-click on the "Preference root" line (or, in your case, the Einstellungsbasis line) to edit. Enter extensions.classicthemerestorer as the new root and click save.

If OPIE finds the new extension root, it should be displayed in green.
cbaker_admin
Site Admin
 
Posts: 4525
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA


Return to OPIE

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron