TEBE beta available for testing

Thunderbird Environment Backup Extension

Tbird not Firefox in Info text

Postby killjay » Sun Jan 04, 2009 12:18 am

Among the Options tab Info items the Firefox name appears in several instances. Needs some edits.
Global
Verify Backups
Save Results Page

Same with Schedule tab, Backup Reminder info.
Also the Debug tab, Clear Preferences info.
Box,net info has TEBR being Version 6.0, not beta.
killjay
 

Verify Extensions fuction not clearing its window properly

Postby killjay » Sun Jan 04, 2009 12:22 am

On using the Debug tab > Verify Extensions, the popup works OK, but on close it leaves a minimized window on the taskbar of Windows Vista.
killjay
 

Addons Mgr. TEBE Options button page load error

Postby killjay » Sun Jan 04, 2009 12:26 am

The Options button for TEBE is still trowing a tiny window with Page Open Error in it's title bar. Windows Vista and Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090103 Shredder/3.0b2pre
killjay
 

Postby cbaker_admin » Mon Jan 05, 2009 12:40 pm

The Options button for TEBE is still trowing a tiny window with Page Open Error in it's title bar
Fixed


On using the Debug tab > Verify Extensions, the popup works OK, but on close it leaves a minimized window on the taskbar of Windows Vista.
This problem is dependent on the resolution of Bug 469203.

Among the Options tab Info items the Firefox name appears in several instances.
I think I got all those ...

Fixes in TEBEbeta(20090105_115843).xpi

Thanks for the report!
Chuck
cbaker_admin
Site Admin
 
Posts: 4357
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Postby killjay » Mon Jan 05, 2009 5:06 pm

cbaker_admin wrote:
The Options button for TEBE is still trowing a tiny window with Page Open Error in it's title bar
Fixed

Confirmed, now works like the TEBE menu item.

cbaker_admin wrote:
Among the Options tab Info items the Firefox name appears in several instances.
I think I got all those ...

Fixes in TEBEbeta(20090105_115843).xpi

Thanks for the report!


My quick review did not find any lingering Fx references.


What I wonder about is the validity of the Box.net tab. Is this a future feature? Or rather a leftover from the Fx version?
killjay
 

Postby cbaker_admin » Mon Jan 05, 2009 5:12 pm

The Box.net feature will definitely be incorporated into TEBE. If fact, it actually works now but is disabled awaiting the resolution of Bug 469203.
Chuck
cbaker_admin
Site Admin
 
Posts: 4357
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Postby killjay » Mon Jan 05, 2009 5:21 pm

cbaker_admin wrote:The Box.net feature will definitely be incorporated into TEBE. If fact, it actually works now but is disabled awaiting the resolution of Bug 469203.


That bug states it has been fixed. With todays build of Shredder the behavior of the Debug > Verify Extensions has changed. The leftover on the Vista Taskbar is no longer seen when the push-up dialog is closed.

However there is a new behavior. Focus is locked on something and the only way to close TEBE is to close Shredder and do a restart.
killjay
 

Postby cbaker_admin » Mon Jan 05, 2009 5:56 pm

I'm still getting the bug behavior with the 01/05 Shredder nightly. The Verify Extension window opens but is transparent with no contents. It cannot be closed by clicking the "X" in the widow frame. The only way to close it seems to be right-clicking the taskbar and clicking "Close" (or using Alt-F4).
Chuck
cbaker_admin
Site Admin
 
Posts: 4357
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Postby killjay » Mon Jan 05, 2009 7:50 pm

cbaker_admin wrote:I'm still getting the bug behavior with the 01/05 Shredder nightly. The Verify Extension window opens but is transparent with no contents. It cannot be closed by clicking the "X" in the widow frame. The only way to close it seems to be right-clicking the taskbar and clicking "Close" (or using Alt-F4).


I am beginning to wonder if the 1.9.1 patch landing was trunk or the 1.9.1 branch. Tb is building off trunk 1.9.1 for a while yet. FWIW, the bug hints of a workaround by explicitly setting a background color to avoid the transparency bug.
killjay
 

Postby jlyst » Mon Jan 05, 2009 8:46 pm

No response/qns RE my post? I will test the latest build asap...

jlyst wrote:But as previously stated as much as Id like to provide ample feedback..
I don't think this is the solution for me as scheduling only works when tbird is launched. Unless I'm mistaken?

Backup upon launch or shut-down is okay but often i may forget to do this and ensure a recent backup etc...
Plus it quickly become annoying when you're trying to get work done etc...

Seems to be working pretty well so far for what it's designed to do...
Results from a Scheduled backup:

01/04/2009 15:06:20
Items processed: 1 total (Created in: /Volumes/Backup d0s1/Thunderbird/Latest unstable/TEBE 2009 01-04 15.06.00)
Profile backed up to: profileTb{test-tube}.tbu
User agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b3pre) Gecko/20090103 Lightning/1.0pre Shredder/3.0b2pre


Manual:

01/04/2009 15:14:33
Items processed: 1 total (Created in: /Volumes/Backup d0s1/Thunderbird/Latest unstable/TEBE 2009 01-04 15.14.14)
Profile backed up to: profileTb{test-tube}.tbu
User agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b3pre) Gecko/20090103 Lightning/1.0pre Shredder/3.0b2pre


And on Shut-down:

01/04/2009 15:16:43
Items processed: 1 total (Created in: /Volumes/Backup d0s1/Thunderbird/Latest unstable/TEBE 2009 01-04 15.16.24)
Profile backed up to: profileTb{test-tube}.tbu
User agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b3pre) Gecko/20090103 Lightning/1.0pre Shredder/3.0b2pre


But I guess output from the results report isn't necessarily the most definitive way to determine if a backup was 100% successful?
Behaviour of the pop up boxes is still a little weird, they don't gain auto-focus etc..

Also I noticed in the schedule where you chose minutes that they're not appearing. You have to guess where the next increment of 5-min is...
Plus it would prolly be better if people could just type in the minutes they want, instead of having to chose from 5-min increments in a dd list...
:lol:
jlyst
 

Postby jlyst » Tue Jan 06, 2009 1:41 am

tried to restore a profile I backed-up but got the following...

Image
By jlyst at 2009-01-06

Tried 3 others but same deal...
jlyst
 

Postby jlyst » Tue Jan 06, 2009 1:50 am

Same deal with latest build of TEBE...
Maybe it's the naming i chose for the profile? The "-" perhaps?

Cheers
jlyst
 

Postby cbaker_admin » Tue Jan 06, 2009 5:59 pm

First let me apologize for not replying to your post sooner. Your original post was at the bottom of page 1 with other posts after it which went on page 2. I often just click the little icon next to the username to go directly to the latest post. When I did that, I went to the top of page 2 and completely missed your post. I wonder how many other posts I've missed by doing that ... going to have to try to break that habit :wink:

Anyway,

I don't think this is the solution for me as scheduling only works when tbird is launched. Unless I'm mistaken?

If you mean will the scheduled backup only occur when Tb is running, then no, you are not mistaken. Since TEBE is an integral part of Tb, it cannot run as a stand-alone app. Is that what you meant?

But I guess output from the results report isn't necessarily the most definitive way to determine if a backup was 100% successful?

The result report is created immediately after the backup process completes. If you do not get the report, chances are something went wrong with the backup.

Behaviour of the pop up boxes is still a little weird, they don't gain auto-focus etc..

I haven't noticed this. I'll check it out.

Also I noticed in the schedule where you chose minutes that they're not appearing. You have to guess where the next increment of 5-min is...

Some themes cause the drop-down lists to shrink. You should be able to re-size the window by dragging the right edge out (unless you are accessing the options window via Tools > Add-ons in which case the window is not re-sizable - an old bug in Firefox.)

tried to restore a profile I backed-up but got the following...

That looks pretty serious ... I'll research it more.
Chuck
cbaker_admin
Site Admin
 
Posts: 4357
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Postby jlyst » Tue Jan 06, 2009 10:29 pm

cbaker_admin wrote:First let me apologize for not replying to your post sooner. Your original post was at the bottom of page 1 with other posts after it which went on page 2. I often just click the little icon next to the username to go directly to the latest post. When I did that, I went to the top of page 2 and completely missed your post. I wonder how many other posts I've missed by doing that ... going to have to try to break that habit :wink:

Not to worry mate I've got a pretty thick skin, it was mainly just a friendly reminder post ;-)


If you mean will the scheduled backup only occur when Tb is running, then no, you are not mistaken. Since TEBE is an integral part of Tb, it cannot run as a stand-alone app. Is that what you meant?

Yeah as I suspected so I'll prolly be going with another solution, but I'm sure TEBE will still be helpful in combination with CLEO etc...


The result report is created immediately after the backup process completes. If you do not get the report, chances are something went wrong with the backup.

I've always gotten nice looking result reports (pretty sure), but so far I've not been able to do a full profile restore, so not sure if the "verify" feature is working.


Some themes cause the drop-down lists to shrink. You should be able to re-size the window by dragging the right edge out (unless you are accessing the options window via Tools > Add-ons in which case the window is not re-sizable - an old bug in Firefox.)

Thanks, I simply widened the window a little and "presto"! I'm only using the default theme for shredder on OS X, so you may want to check this out?


I haven't noticed this. I'll check it out.

If there was an easier way to send images I'd send a bunch that'd explain it better... Perhaps it's to do with the default theme again?


That looks pretty serious ... I'll research it more.

Yeah "show stopper" I'd say, good luck with it!
People on the net like you truly are precious jewels, giving so much and expecting so little in return!

All the best
jlyst
 

Postby jlyst » Fri Jan 09, 2009 9:42 am

How's it goin, u get to the bottom of anything we found?
See my response? Cheers :D
jlyst
 

PreviousNext

Return to TEBE

Who is online

Users browsing this forum: No registered users and 2 guests