Page 1 of 1

TEBE not quite right

PostPosted: Thu Dec 24, 2009 10:43 pm
by Richard snr
First off to register for this Forum has a problem, the CAPTCHA does not work properly and only after some 20 tries did it accept the input.

I am really happy to see TEBE being developed as FEBE is fantastic and works very well.

I Like to have my Profiles in specific directories and FEBE works very well in this regard, TEBE however does not even see these Profiles in Thunderbird, is this intentional or will this be added/fixed in the future?

Re: TEBE not quite right

PostPosted: Fri Dec 25, 2009 11:32 am
by cbaker_admin
TEBE should be attempting to backup whatever the current profile location contains. It should not matter where the profile is located. (Restoring is a different matter. TEBE beta expects the profiles to be in the default location. This will be fixed before the final release.)

To see where TEBE is looking, open Tools > Error Console in Thunderbird and paste the following line into the textbox just to the left of the "Evaluate" button:

alert(Components.classes["@mozilla.org/file/directory_service;1"].getService(Components.interfaces.nsIProperties).get("ProfD", Components.interfaces.nsIFile).path);


and click "Evaluate". An alert box will appear listing the full path to the profile. (Note that the above code should be pasted as one, single line.)

For instance, my Tb profile is located in C:\Users\CBaker\AppData\Roaming\Thunderbird\Profiles\9fh66jdx.TEBE which is the default location.


BTW, I hate CAPTCHAs. Unfortunately, it's what came with the forum software so I'm stuck with it :? )