INVALID DATE - Daddy please don't take my t'bird away

Thunderbird Environment Backup Extension

INVALID DATE - Daddy please don't take my t'bird away

Postby ss3e55 » Mon Apr 19, 2010 11:18 am

Newbie to this forum...please treat with some latitude I hope I am not starting a thread unnecessarily - I have checked FAQ and searched but I could be just unfamiliar with nomenclature and have searched incorrectly - so forgive in advance if I am out of order.

I am a Tbird user (v3.0.4) and have OpenPGP installed - other than that pretty normal setup. I do have large folders on IMAP accounts (6K items for instance) but surely not the largest :-) I installed both TEBE and FEBE (in my FF of course :-) and love the idea of them both. However my Tbird is running on only 4 cylinders these days.

After installation (TEBEbeta(20090111_192528)) and setting a weekly backup (to a remote drive over the network) I thought I was all set...ran a backup...seemed good. But on the next restart I got a warning about the backup in a small pop up...

ScreenHunter_01 Apr. 19 13.44.gif
error box shot
ScreenHunter_01 Apr. 19 13.44.gif (7 KiB) Viewed 12440 times



On checking the CANCEL I get extremely unresponsive app...cannot even quit it....When I did get a chance (after force quit and re-open) - I had a chance to try the other choices - same results.
I do have what look to be valid backups at the remote drive - I checked preferences and dates - everything seems fine...ARGH could it be the date on the remote machine !!??

last directory created reads TEBE 2010 04-19 13.18.50 looks okay (had no chance to try a restore yet) - Profile is there (2GB), "results" and dot XPI - hmm - I did go ahead and disable the TEBE so I could work in tbird....AFTER these attempts and even earlier outputs (results) show 1 disabled extension...??


TEBE Results Report
Version: beta(20090111_192528)
by: Chuck Baker
Monday, April 19, 2010 1:43:49 PM-Philip

Items processed: 2 total (Created in: \\Ibm-514bf934267\g\TEBE 2010 04-19 13.18.50)

Extensions processed: (1 total) - indicates a user disabled extension.
1. TEBE

Profile backed up to: profileTb{default}.tbu

User agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

For the latest information, see the TEBE homepage.


--------- So what am I doing wrong??? Where does the INVALID date come in (what is an INVALID date??) ---------- help ------------

and THANKS - these both FEBE & TEBE look to be great pieces of work - sorry if I'm using them all wrong - help me help myself :roll:
ss3e55
 

Re: INVALID DATE - Daddy please don't take my t'bird away

Postby cbaker_admin » Wed Apr 21, 2010 5:53 am

You did nothing wrong ... it is a bug. The current TEBE beta is based on FEBE v6.1 code where the bug was introduced. While it's now fixed in FEBE, TEBE still suffers from it. It is only a display error and should not affect the functionality of the backup itself.
Chuck
cbaker_admin
Site Admin
 
Posts: 4385
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: INVALID DATE - Daddy please don't take my t'bird away

Postby ss3e55 » Wed Apr 21, 2010 10:21 am

Thanks for the clarification

So the unresponsiveness might be caused by normal over the network backup....except I also tried "Cancel" and still it was extremely unresponsive....any suggestions?

Secondly - is there a version I could load without that bug?

thanks
ss3e55
 

Re: INVALID DATE - Daddy please don't take my t'bird away

Postby cbaker_admin » Wed Apr 21, 2010 4:45 pm

Actually, the bug I was talking about refers to the "Invalid Date" appearing in the TEBE message, not about TEBE being unresponsive. You said that the unresponsiveness appeared after you click "Cancel"? That shouldn't be. Are you getting any TEBE related errors in the error console (Tools > Error Console)? You may also want try the Console² extension for error checking. It is more comprehensive.

Also try running "Clear TEBE preferences" and "Verify extension directory" in Tools > TEBE > TEBE Options > Debug.

If you are still experiencing problems, try this: Open and clear the Error console. Leave it open and perform a backup. When (or if) the backup completes, examine the error console for any error messages. Copy/paste them here.

If TEBE is timing out with a "Script is busy" or "Unresponsive script" message, you should increase the wait time in Tb preferences. To do this, go to Tools > Options > Advanced > General > Config Editor. Paste dom.max_chrome_script_run_time into the filter box. If the value of this preference non-zero but less than 60, change it to 60. This is number seconds Tb will wait before declaring a script is not working (zero means wait forever). If your backup is around 2GB (which is HUGE!), you may have to set the preference to zero.

The TEBE results report will list disabled extensions only when running a selective backup. The disabled extensions are marked with special icon (as in the DOM Inspector extension here):

Image

Of course, Tb will always be unresponsive when a backup is occuring. Since your backups will tend to be very large (and hence take quite awhile to complete) you may want to consider not using a scheduled backup. Instead, you could perform a manual backup once a week when you won't be actively using Tb. You could set a reminder for 7 days in TEBE Options > Schedule > Backup reminder.
Chuck
cbaker_admin
Site Admin
 
Posts: 4385
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: INVALID DATE - Daddy please don't take my t'bird away

Postby Nick222 » Fri Dec 31, 2010 9:15 am

I see same message many times - Thunderbird 3.1.8pre, TEBE beta 20100727_12000 - and I don`t know how prevent it appearing.

I use FEBE 6.3.3.2 on FF 3.6.14pre - same message appeared one time - but after I scheduled backup day and time - it don`t appear anytime.

In Thunderbird schedule don`t change anything.

Message:
Scheduled backup was skipped!
The backup that was scheduled to be performed on
Invalid Date Invalid Date
was skipped. Do you wish to perform a backup now?
Click 'OK' to backup now, 'Cancel' to continue normally.
Nick222
 

Re: INVALID DATE - Daddy please don't take my t'bird away

Postby cbaker_admin » Fri Dec 31, 2010 9:33 am

What locale are you using? (en-US, es-ES, etc.)

Do you have Mr. Tech's Toolkit installed? If so, go to Tools > My Config > about:config and filter for "extensions.tebe". What is the value of "extensions.tebe.lastbackup"? Try clearing the value (double-click) and see if that makes a difference.
Chuck
cbaker_admin
Site Admin
 
Posts: 4385
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: INVALID DATE - Daddy please don't take my t'bird away

Postby benjamin » Sun Mar 13, 2011 1:01 pm

Hi Chuck,

i've got exactly the same error message "Invalid Date Invalid Date" as ss3e55 posted above.

I installed TEBE and did the first backup without any problems. Backup size is 180MB. After restarting TB with the first backup done the error message appeared. I clicked Cancel and TB froze completely. I had to kill the process through task manager. The behaviour is reproducible. I had to start TB in safe mode and manually reset the following preferences:
user_pref("extensions.tebe.schedule.description", "Mittwoch, 16. März 2011 19:00:00");
user_pref("extensions.tebe.schedule.frequency", "weekly");
user_pref("extensions.tebe.schedule.weekly.day", 3);
user_pref("extensions.tebe.schedule.weekly.hour", 19);

After this the error is gone. When I reconfigure these settings the error returns on the next TB start. I've included a screenshot of the schedule preferences tab. Maybe you see something I don't.
I already checked the error console with no luck. I suppose it's nothing in there, because I had to kill the process and restart TB before I could open it.

OS: Win 7 SP1 Professional. Locale de-DE (German-Germany). TB 3.1.9. TEBE beta20100727.

If you need anything else just let me know.

Thanks for the good work with your addons.

Best regards
Benjamin
Attachments
tebe error.png
tebe error.png (64.87 KiB) Viewed 12073 times
benjamin
 

Re: INVALID DATE - Daddy please don't take my t'bird away

Postby cbaker_admin » Mon Mar 14, 2011 9:34 am

This is undoubtedly a localization issue. What is your current setting for the preference extensions.tebe.schedule.description? Try clearing it by editing about:config (you can use the "Mr Tech's Toolkit" extension through Tools > Edit My Config).
Chuck
cbaker_admin
Site Admin
 
Posts: 4385
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: INVALID DATE - Daddy please don't take my t'bird away

Postby benjamin » Mon Mar 14, 2011 1:58 pm

This is the current setting (looked up with TB built in about:config):
extensions.tebe.schedule.description;Mittwoch, 16. März 2011 19:00:00

I'm a little bit surprised. As stated in my last post, I've already emptied this preference. My current TEBE settings dialog looks like the following, although the property is still filled. :?
tebe error3.png
tebe error3.png (57.12 KiB) Viewed 12068 times


The error message does not appear any more since I've started TB in safe mode and emptied the extensions.tebe.schedule.* preferences. I just can't schedule weekly backups (monthly and daily not tested), because the error will occur again with weekly backups scheduled.

Best regards
Benjamin
benjamin
 

Re: INVALID DATE - Daddy please don't take my t'bird away

Postby cbaker_admin » Tue Mar 15, 2011 7:24 am

I know the problem is associated with the localized date, but I was hoping that clearing those preferences would fix the error. Have you tried resetting all TEBE preferences (TEBE Options > Debug > Clear TEBE preferences)?
Chuck
cbaker_admin
Site Admin
 
Posts: 4385
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: INVALID DATE - Daddy please don't take my t'bird away

Postby benjamin » Sun Mar 20, 2011 5:51 am

I've resetted all TEBE preferences. The invalid date message can be reproduced after setting up a weekly scheduled backup (message appears at TB startup). Compared to the situation before resetting all TEBE preferences the only difference is TB does not hang any more on startup when a weekly backup is scheduled. When I set the schedule to "no scheduled backup" the message disappears as before.

I've checked the error console. There is no message related to TEBE. Just 2 errors one for Silvermel theme and one for Lightning Button.

At the moment I can use TEBE except the scheduled backup. If you want me to try a TEBE version with debug code and hopefully some invalid date error related log output, I would be happy to do so.

Best regards
Benjamin
benjamin
 

Re: INVALID DATE - Daddy please don't take my t'bird away

Postby cbaker_admin » Mon Mar 21, 2011 12:19 pm

Thanks for the offer to help debug, Benjamin. I just may take you up on that offer. Unfortunately, with school still in session (where my real job is) and the immanent release of Firefox 4 (major coding changes in virtually all my extensions) there just isn't any available time to address TEBE issues. Perhaps in June (after school lets out and Firefox 4 is more stable) I can jump back on it. If you are still interested in helping then, would you drop me a note? It would be nice to graduate TEBE from its long beta-development phase to a real release.
Chuck
cbaker_admin
Site Admin
 
Posts: 4385
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: INVALID DATE - Daddy please don't take my t'bird away

Postby benjamin » Sat Mar 26, 2011 11:55 am

The least I can do is help finding bugs. Send me a message through the board or answer this topic whenever you've something ready for testing. I'm in the software development branch myself (JEE, ABAP). Hence I understand only too well: Time's always short :roll:

Best regards
Benjamin
benjamin
 


Return to TEBE

Who is online

Users browsing this forum: No registered users and 3 guests