TEBE Beta(20120323_REJIG) Hangs after first Extension/Theme

Thunderbird Environment Backup Extension

TEBE Beta(20120323_REJIG) Hangs after first Extension/Theme

Postby The_Boojum » Thu May 03, 2012 4:43 am

I just installed TEBE Beta(20120323_REJIG)as this was the only Download I could find. I changed the Dom.Max Parameter to 0 and then tried backing up various items, but always with either the extensions or themes or both checked. The backup starts and I can see the disk recording the data, but once the backup has processed the first theme or extension it hangs. :(
The_Boojum
 
Posts: 19
Joined: Wed May 02, 2012 8:49 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby spaceShot9 » Fri May 04, 2012 2:24 pm

Hi,

If you found that one you should have found the others, they're all in that same thread. The latest is here. I haven't seen that behaviour from the version you tried. Please let us know if you have problems with the latest and, if so, provide full details of the version of Thunderbird you're using, which extensions are installed and the exact steps necessary to replicate the problem.

Thanks for trying it,

Gary.
spaceShot9
Contributor
 
Posts: 56
Joined: Fri Mar 23, 2012 11:16 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby The_Boojum » Sun May 06, 2012 12:13 pm

Hi Gary,
installed the latest version. No change. Still hangs on the first thing it backs up.
Hugo
The_Boojum
 
Posts: 19
Joined: Wed May 02, 2012 8:49 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby spaceShot9 » Mon May 07, 2012 2:31 am

The_Boojum wrote:Hi Gary,
installed the latest version. No change. Still hangs on the first thing it backs up.
Hugo


Well, unless you supply the requested details there's nothing we can do. No-one else has reported this so it's likely to be something at your end.
spaceShot9
Contributor
 
Posts: 56
Joined: Fri Mar 23, 2012 11:16 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby The_Boojum » Mon May 07, 2012 12:08 pm

Hi Gary,
please tell me what you need and how to trace it.
Hugo
The_Boojum
 
Posts: 19
Joined: Wed May 02, 2012 8:49 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby The_Boojum » Tue May 08, 2012 12:10 am

Hi Gary,
checked the destination directory and there are .xpi, .jar, .js, .tbu and .mab files there. Obviously it is hanging somewhere near the end. Have set the script timeout to 0 and let it run with Debug mode switched on and left it for 2 hours. The event log shows no TEBE entries. I switched on all address books and personal and collected, but only Personal and Collected are backed up. If I switch off personal and collected there is only an "allAdressbooks.tbu" which is far too small to contain all the address book entries. I have now looked through all the options and cannot find a way to get any trace or debug information further to the ones already tried to no effect.
Hugo
The_Boojum
 
Posts: 19
Joined: Wed May 02, 2012 8:49 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby spaceShot9 » Wed May 09, 2012 12:45 am

The_Boojum wrote:Hi Gary,
please tell me what you need and how to trace it.
Hugo


Hi Hugo,

Please refer to my first response above. That information will be a good start.

Gary.
spaceShot9
Contributor
 
Posts: 56
Joined: Fri Mar 23, 2012 11:16 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby spaceShot9 » Wed May 09, 2012 1:02 am

The_Boojum wrote:Hi Gary,
checked the destination directory and there are .xpi, .jar, .js, .tbu and .mab files there. Obviously it is hanging somewhere near the end. Have set the script timeout to 0 and let it run with Debug mode switched on and left it for 2 hours. The event log shows no TEBE entries. I switched on all address books and personal and collected, but only Personal and Collected are backed up. If I switch off personal and collected there is only an "allAdressbooks.tbu" which is far too small to contain all the address book entries. I have now looked through all the options and cannot find a way to get any trace or debug information further to the ones already tried to no effect.
Hugo


There shouldn't be any ending with '.js', that I'm aware of. Can you confirm that it's actually '.json'?

One of the good things Chuck did in the code was to use exception handling. What he didn't do was ask it to report anything when an exception is caught, so I will add some logging and ask you to update and see if we can trap anything useful. I'll try and do that today.

allAdressbooks.tbu is a zip file. You could tack '.zip' on the end and open it with your zip manager and see what it contains. It should contain all of the '.mab' files from your profile directory. If it doesn't that could be the issue, although why is a different matter and I only added it with the latest release and you reported problems prior to that. It could be small as plain text compresses very well, but we'll see. The '.mab's are just text, although the contents are cryptic, and you should be able to identify the text strings from your addresses.

There are some extensions that are known to cause problems with FEBE and will cause the same problems with TEBE, so we need to see if you're running one of those. Here's the list.

There is a lot of other information in the FEBE forum that applies equally to TEBE so you might like to browse around and see if anything relates to your situation.

Another thing you could try is to use the selective backup and run a backup with no optional items selected and see how it behaves, then add one item at a time and re-run and see if it fails on any given item.

I'm sorry you're having problems but we appreciate you persisting and taking the time to report your findings. Without that it's difficult to progress. I'm sure we'll be able to get you going with a little investigation. If needs be I'll set up a VM with TB installed to replicate your setup and try and make it misbehave, so I can see what it's doing.

Cheers,

Gary.
spaceShot9
Contributor
 
Posts: 56
Joined: Fri Mar 23, 2012 11:16 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby The_Boojum » Wed May 09, 2012 1:50 pm

Hi Gary,
I find both TEBE and FEBE worth investing time in, as they are both excellent products and I appreciate the time you are taking to help me.
1. The AllAddressbooks.tbu contains Abook.mab, Abook-1.mab and Abook-2.mab, so the address books part seems to be working fine.
2. The .js file is the PrefsTB.js as I turned on the option to backup the TEBE Settings.
3. I took a look at the known extensions that cause problems, but have none of these.
4. I checked what extension/themes had been backed up and found some disabled ones that had not been backed up and removed these and then restarted thunderbird. The only one now not being backed up is the "Default theme for thunderbird" which I cannot remove.
5. I changed the backup options to selective and,
a) Selective with nothing, ends correctly with a report saying nothing was selected
b) Selective with themes, ends correctly backing up one theme and providing a report
c) Selective with extensions, backs up all the extension but hangs and has to be aborted. There are no extensions that were not backed up and all have a positive size.
It appears that there is a problem once it has backed up all the extensions and then cannot proceed. Perhaps I have an error in my About:config. I had a look at this and the entries for extensions and TEBE but could not identify anything that could be causing the problem.
Regards,
Hugo
The_Boojum
 
Posts: 19
Joined: Wed May 02, 2012 8:49 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby spaceShot9 » Thu May 10, 2012 12:26 pm

The_Boojum wrote:Hi Gary,
I find both TEBE and FEBE worth investing time in, as they are both excellent products and I appreciate the time you are taking to help me.


Thank you. No problem.

The_Boojum wrote:1. The AllAddressbooks.tbu contains Abook.mab, Abook-1.mab and Abook-2.mab, so the address books part seems to be working fine.


OK, that sounds correct.

The_Boojum wrote:2. The .js file is the PrefsTB.js as I turned on the option to backup the TEBE Settings.


Right your are, I missed that.

The_Boojum wrote:4. I checked what extension/themes had been backed up and found some disabled ones that had not been backed up and removed these and then restarted thunderbird. The only one now not being backed up is the "Default theme for thunderbird" which I cannot remove.


Yes, TEBE skips the default theme by, erm, default.

The_Boojum wrote:5. I changed the backup options to selective and,
a) Selective with nothing, ends correctly with a report saying nothing was selected
b) Selective with themes, ends correctly backing up one theme and providing a report
c) Selective with extensions, backs up all the extension but hangs and has to be aborted. There are no extensions that were not backed up and all have a positive size.
It appears that there is a problem once it has backed up all the extensions and then cannot proceed. Perhaps I have an error in my About:config. I had a look at this and the entries for extensions and TEBE but could not identify anything that could be causing the problem.


You still haven't told me what OS you're running, what version of Thunderbird and what extensions you have installed. Without that we aren't going anywhere.

It sounds like it's having problems with a particular extension, perhaps. I will create a new version with more debug output shortly and we'll see what that tells us.

Thanks.
spaceShot9
Contributor
 
Posts: 56
Joined: Fri Mar 23, 2012 11:16 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby The_Boojum » Thu May 10, 2012 1:36 pm

Hi Gary,
- Operating System is: Win 7
- Thunderbird is: 12.0.1
- Extensions are:
AdblockPlus(2.0.3)
BritishEnglishDictionary(1.19.1)
DictionairefrancaisClassique&ampReforme1990 4.3
Dizionarioitaliano(3.3.2)
ExtraFolderColumns(1.1.4)
GermanDictionary(2.0.2)
ImportExportTools(2.7.0.3)
Lightning(1.4)
OpenAttachmentByExtension(0.3.5)
TEBE(beta(20120504_REJIG))
TestPilotforThunderbird(1.3.9)

Regards,
Hugo
The_Boojum
 
Posts: 19
Joined: Wed May 02, 2012 8:49 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby spaceShot9 » Thu May 10, 2012 2:22 pm

Hi,

Please try this version and let me know if you see any output in the error console (Tools/Error Console). I have released another version since the one you're using but I'm hard to keep up with, I know. :P

Thanks.
spaceShot9
Contributor
 
Posts: 56
Joined: Fri Mar 23, 2012 11:16 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby The_Boojum » Thu May 10, 2012 11:13 pm

Hi Gary,
that produced some results.

Could not read chrome manifest 'file:///C:/Users/Hugo/AppData/Roaming/Thunderbird/Profiles/ioam0wce.default/extensions/it-IT@dictionaries.addons.mozilla.org/chrome.manifest'.
Could not read chrome manifest 'file:///C:/Users/Hugo/AppData/Roaming/Thunderbird/Profiles/ioam0wce.default/extensions/fr-classique-reforme1990@dictionaries.addons.mozilla.org/chrome.manifest'.

Let me know if you want me to remove these?
Regards,
Hugo
The_Boojum
 
Posts: 19
Joined: Wed May 02, 2012 8:49 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby spaceShot9 » Fri May 11, 2012 2:52 am

The_Boojum wrote:that produced some results.

Could not read chrome manifest 'file:///C:/Users/Hugo/AppData/Roaming/Thunderbird/Profiles/ioam0wce.default/extensions/it-IT@dictionaries.addons.mozilla.org/chrome.manifest'.
Could not read chrome manifest 'file:///C:/Users/Hugo/AppData/Roaming/Thunderbird/Profiles/ioam0wce.default/extensions/fr-classique-reforme1990@dictionaries.addons.mozilla.org/chrome.manifest'.


Were these in the Error Console? They don't look like TEBE errors. Messages from TEBE will be prefixed "Error: TEBE debug:". I can't see any reason why it would be trying to read that specific file and complaining about it, either. It should just be zipping the entire directory. I'm assuming you DID install Beta(21020510_REJIG).

I installed the only French and Italian dictionaries available on AMO and had no problem backing those up. However, I'm not certain that they're the same as yours. Can you advise where you downloaded them, if elsewhere, and I'll try again?

My setup is almost identical to yours. We only differ by a few extensions, so it does seem that it might be these particular extensions. We both have other dictionaries installed that aren't causing trouble, though, which is odd. It could be that the errors above are precipitating the problem within TEBE. If files are being held by the system and somehow preventing the compression process from completing it could hang, although there is an exception in that code that should trap errors adding files to the zip file and there's also a timeout for the operation.

The_Boojum wrote:Let me know if you want me to remove these?


The first thing I suggest you try is to add them to the ignore list and run a backup and see how that goes. It should succeed. You could try adding one or the other and running again to see if either will back up without the other.

You could also try running a Quick Backup and selecting one or the other by itself and seeing if it's backed up that way.

You could also try removing them and seeing if the backup succeeds without them, as it seems it should, then reinstalling one and seeing if that makes any difference to the success of the backup. It's remotely possible that something has become messed up but, frankly, I can't see how that would stop TEBE backing up the folder.

Please report anything that appears in the Error Console, TEBE-related or otherwise.

If nothing else ignoring them should allow you to backup everything else but I would like to know why these are causing issues.

Press on. :D
spaceShot9
Contributor
 
Posts: 56
Joined: Fri Mar 23, 2012 11:16 am

Re: TEBE Beta(20120323_REJIG) Hangs after first Extension/Th

Postby The_Boojum » Fri May 11, 2012 9:50 am

Hi Gary,

restarted Thnderbird in case there was some other problem. Checked that the new version was in - it was. Did Quick Backups of all extensions - No problems.
Then did Backup of all extensions and got the following messages in the Log:
Timestamp: 11.05.2012 18:45:22
Error: TEBE debug: tebeCopyFile(): Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsILocalFile.remove]
Source File: chrome://tebe/content/tebeCommon.js
Line: 159
Timestamp: 11.05.2012 18:45:22
Error: TEBE debug: tebeCopyFile(): Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsILocalFile.remove]
Source File: chrome://tebe/content/tebeCommon.js
Line: 159
Timestamp: 11.05.2012 18:45:22
Error: TEBE debug: tebeCopyFile(): Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsILocalFile.remove]
Source File: chrome://tebe/content/tebeCommon.js
Line: 159
Timestamp: 11.05.2012 18:45:22
Error: TEBE debug: tebeCopyFile(): Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsILocalFile.remove]
Source File: chrome://tebe/content/tebeCommon.js
Line: 159
Timestamp: 11.05.2012 18:45:22
Error: TEBE debug: tebeCopyFile(): Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsILocalFile.remove]
Source File: chrome://tebe/content/tebeCommon.js
Line: 159
Timestamp: 11.05.2012 18:45:22
Error: TEBE debug: tebeCopyFile(): Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsILocalFile.remove]
Source File: chrome://tebe/content/tebeCommon.js
Line: 159
Timestamp: 11.05.2012 18:45:23
Error: tebeBuItemVerifiedList is not defined
Source File: chrome://tebe/content/tebe.js
Line: 805

Regards

Hugo
The_Boojum
 
Posts: 19
Joined: Wed May 02, 2012 8:49 am

Next

Return to TEBE

Who is online

Users browsing this forum: No registered users and 2 guests

cron