Issue with a restore

Thunderbird Environment Backup Extension

Issue with a restore

Postby Jota » Mon Aug 19, 2013 2:34 am

Hi.

Been a FEBE and TEBE user for a few years now and it's been a hassle free few years at that. :)

However, yesterday after a reinstall of Windows 7 I tried to restore my Thunderbird backup and when I browse to the TEBE folder, the folder looks empty. If I browse to the folder via windows explorer I see lots of files.

I'll post a screen shot of the files...

Image

Going by the files in the screenshot, did the back up not work properly or have I missed some option while doing the back up? More importantly, can I save my emails and settings?

Thanks in advance.
Jota
 
Posts: 5
Joined: Mon Aug 19, 2013 2:21 am

Re: Issue with a restore

Postby cbaker_admin » Mon Aug 19, 2013 4:59 pm

Perhaps a directory permissions problem after the Win 7 install? See this post (just substitute 'TEBE' for 'FEBE').
cbaker_admin
Site Admin
 
Posts: 4389
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Issue with a restore

Postby Jota » Tue Aug 20, 2013 3:22 am

Ah! Semi success doing that Chuck! :)

I basically gave the folder the permissions set out in your link, then copied the contents of that folder into a newly created profile in Thunderbird. I then dragged the TEBE .xpi file into the extensions/add ons part of Thunderbird, restarted and was then prompted to enter my GMail and Hotmail passwords. So far so great. :)

Thunderbird now sees all my email accounts.

Strangely however, the AOL email has returned with all it's sub folders and old emails intact however the GMail and Hotmail have downloaded the latest emails but I don't see the sub-folders I used to have where I saved emails in my hotmail account. This is probably the most important issue for me to resolve as I've saved lots of receipts, software licences/keys and other important emails there.

When TEBE looks for the 'local backup to restore' it looks for this type of file -

Image

But there seems to be none of these files in my backup folder.

Thanks again for your help with my issue.

A Wood
Jota
 
Posts: 5
Joined: Mon Aug 19, 2013 2:21 am

Re: Issue with a restore

Postby cbaker_admin » Tue Aug 20, 2013 4:56 pm

In that particular instance, TEBE is looking for a full profile backup to restore. There doesn't appear to be one in the file listing you provided. How are your options set in TEBE Options > What to backup? If I have mine set to 'Both' for 'Backup type' and 'Selective' has all items except Extensions or Themes checked, the following appears in my backup directory:

Code: Select all
allAddressBooks{cbaker}.tbu
collectedAddresses{cbaker}.mab
mailMessages{cbaker}.tbu
personalAddressBook{cbaker}.mab
prefsTb{cbaker}.js
profileTb{cbaker}.tbu
Results - TEBE 2013 08-20 16.13.20.html
TEBE data{cbaker}-tebeUserDefinedBuData.json


In this case, the file profileTb{cbaker}.tbu is my full profile backup and the file mailMessages{cbaker}.tbu contains all my mail message folders.
cbaker_admin
Site Admin
 
Posts: 4389
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Issue with a restore

Postby Jota » Wed Aug 21, 2013 9:49 am

I have 'selective backup' checked and all but 'user-defined backups' are checked in that particular window. Plus, I have everything that you have in the example you posted.

Edit. Wow! I went to 'restore' - 'restore POP-mail folder', TEBE opened a window that browsed straight to this window...

Image

and I couldn't see the file I needed so I browsed to my TEBE back up folder in Windows explorer, grabbed the popMail{default}.tbu file and dragged it into the window TEBE had opened. I then selected that file and it restored all my old emails!! :)

Yaas! One happy dude!

Thanks again Chuck, firstly for two very useful extensions and secondly for your support here.

In recognition of this I've sent a donation via Paypal.

A. Wood
Jota
 
Posts: 5
Joined: Mon Aug 19, 2013 2:21 am

Re: Issue with a restore

Postby cbaker_admin » Wed Aug 21, 2013 5:46 pm

You're welcome, and thank you!
cbaker_admin
Site Admin
 
Posts: 4389
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA


Return to TEBE

Who is online

Users browsing this forum: No registered users and 1 guest

cron