FEBE runs very long while the browser is unresponsive

Problems and experiences with my extensions on the Windows 7 platform.

FEBE runs very long while the browser is unresponsive

Postby ysu » Wed Jul 19, 2017 12:07 am

I love FEBE, but...when FEBE runs, lately, it renders the browser inoperable for quite a bit of time.
I've got a decent computer (6700 intel cpu at 4.6GHz, nvme SSD).

But not just that; it always raises the "Unresponsive script" warning from firefox.

I'm wondering if it can be sped up a bit and the script warning disabled?


Latest results:

19/07/2017 5:00:02 pm
Item count: 32 total backed up — 22 extensions, 0 themes, 10 additional items.
Backup type: Both (Selective & Full profile), Scheduled, Mode: Synchronous
Total processing time: 103.498 seconds
....
8 items skipped/ignored
....
Extensions processed: 22 total
...
Themes processed: 0 total
Additional items: 10


Thanks!
ysu
 
Posts: 26
Joined: Thu Nov 07, 2013 5:34 pm

Re: FEBE runs very long while the browser is unresponsive

Postby cbaker_admin » Wed Jul 19, 2017 9:07 am

Is it possible that you have some very large files in your profile? For instance, browsing history can get very large over time.

You are currently running FEBE synchronously. If you check the box FEBE Options > How to backp > Run asynchronously the backup will be much faster.
Chuck
cbaker_admin
Site Admin
 
Posts: 4427
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE runs very long while the browser is unresponsive

Postby ysu » Wed Jul 26, 2017 12:05 am

Shoot, sorry I was as bit busy. Thanks for the response.

I don't know how big my files are...
Edit:
Actually; the size of the backup itself is ~340MB. The culprit is the "profileFx54.0.1(FEBE8.9.3.1){user}.fbu" being ~300MB alone.

WRT running it async; does that affect the result in any way?
The info says it may not correctly back up - I'd rather avoid that.
ysu
 
Posts: 26
Joined: Thu Nov 07, 2013 5:34 pm

Re: FEBE runs very long while the browser is unresponsive

Postby cbaker_admin » Wed Jul 26, 2017 2:09 pm

Examine the contents of "profileFx54.0.1(FEBE8.9.3.1){user}.fbu" to see what the large files are. You can open it with any zip program (like 7zip). List them here and I can probably tell you what the problem may be.

Running FEBE asynchronously merely forces the backup to run in the background. The only caveat is that closing the browser before the backup finishes will result in an incomplete and/or corrupt backup.

Is the box in FEBE Options > How to backup > Ignore cache and phishing DB checked?

If your profile was created in a non-standard location, it will contain the Firefox cache and phishing database. These files tend to be very large and can substantially increase the backup time and file size of a FEBE full profile backup. These files are not really required when a profile is restored as they will be created as needed.

If this option is disabled, your cache and phishing database are not located in the profile directory. This is normal as they are usually located in the Firefox install folder (which is not included in a full profile backup).
Chuck
cbaker_admin
Site Admin
 
Posts: 4427
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE runs very long while the browser is unresponsive

Postby ysu » Wed Jul 26, 2017 11:34 pm

cbaker_admin wrote:Is the box in FEBE Options > How to backup > Ignore cache and phishing DB checked?

Yes, and it cannot be un-checked either :)
ysu
 
Posts: 26
Joined: Thu Nov 07, 2013 5:34 pm

Re: FEBE runs very long while the browser is unresponsive

Postby ysu » Wed Jul 26, 2017 11:37 pm

It seems there is plenty of garbage here...
I've deleted the biggest culprits, will see how it goes, thanks for the help!

Edit:
hm...down to 8s, nice :)
ysu
 
Posts: 26
Joined: Thu Nov 07, 2013 5:34 pm


Return to Windows 7 issues

Who is online

Users browsing this forum: No registered users and 5 guests

cron