Page 1 of 1

FEBE 8 Welcome Page remains

PostPosted: Mon Dec 05, 2016 10:09 am
by mbs2753
Ever since my automatic update to FEBE 8, the welcome page activates in a new tab at every startup of Firefox.
Running Windows 7 Pro and Firefox 50.0.2, FEBE 8.9.3.1
Backup appears to run normally. No errors in JS debug screen.
Any suggestions?

Image

Re: FEBE 8 Welcome Page remains

PostPosted: Mon Dec 05, 2016 5:00 pm
by cbaker_admin
It is most likely a preference that is set incorrectly.

Type about:config in the Fx location bar to open up Fx preferences. Type (or paste) extensions.febe.currentversion in the search field near the top of the screen. The value of the preference should be set to 8.9.3.1
If it is not, right-click on the preference and select "Modify". Change the value to 8.9.3.1

Do the same for the preference extensions.febe.previousversion

Re: FEBE 8 Welcome Page remains

PostPosted: Mon Dec 05, 2016 8:33 pm
by mbs2753
Chuck:
both settings were correct in config.
I have also removed and re-installed FEBE- no joy.

-Mike-

Re: FEBE 8 Welcome Page remains

PostPosted: Tue Dec 06, 2016 2:26 pm
by cbaker_admin
Maybe there is something in those preferences that is not visible. Try right-clicking and selecting "Reset". That should set them to blank. Restarting Fx will then have FEBE set them to the correct value. The welcome screen will appear once after resetting, but should not after that.

If that still doesn't fix it, try FEBE Options > Advanced > Clear FEBE preferences. (You will have to re-enter your backup destination directory as well as any other non-default options.)

Re: FEBE 8 Welcome Page remains

PostPosted: Tue Dec 06, 2016 6:51 pm
by mbs2753
cbaker_admin wrote:Maybe there is something in those preferences that is not visible. Try right-clicking and selecting "Reset". That should set them to blank. Restarting Fx will then have FEBE set them to the correct value. The welcome screen will appear once after resetting, but should not after that.

If that still doesn't fix it, try FEBE Options > Advanced > Clear FEBE preferences. (You will have to re-enter your backup destination directory as well as any other non-default options.)


NO Joy in either case. The interesting thing is: After Clear FEBE preferences, I discovered that when I went back into "Options > Where to backup" to re-enter the destination data, the backup destination directory did not reset (it had retained the destination data).

I found this while searching program files for the keyword"febe":
4 / 117.52 KB / Defragmented / C:\Users\Mike\AppData\Roaming\Mozilla\Firefox\Profiles\79yxo1jn.New 9-26-15\febeExtensionData.json
It was in a defragment report issued on 11-6-2016
The same file appears in five other defraf reports dating back to 10-15-16
It was also found in ikernel.rgs at location: C:\Program Files (x86)\Common Files\InstallShield\Professional\RunTime Created: ‎Wednesday, ‎April ‎27, ‎2011, ‏‎11:24:11 PM.
The code segment is:
-------------------------------------------
{FEBEC920-1849-11D3-A8FE-00105A088FAC} = s 'ISetupWindowText'
{
ProxyStubClsid = s '{00020424-0000-0000-C000-000000000046}'
ProxyStubClsid32 = s '{00020424-0000-0000-C000-000000000046}'
TypeLib = s '{94636247-BC39-4B8B-A728-2D1FBEBFA76A}'
{
val Version = s '1.0'
}
}
}
-------------------------------------------
I did not think your program used Install Shield. Is this just a coincidence?


-Mike-

Re: FEBE 8 Welcome Page remains

PostPosted: Wed Dec 07, 2016 12:57 pm
by cbaker_admin
NO Joy in either case. The interesting thing is: After Clear FEBE preferences, I discovered that when I went back into "Options > Where to backup" to re-enter the destination data, the backup destination directory did not reset (it had retained the destination data).


As Alice in Wonderland once said, this is getting curiouser and curiouser. When you reset FEBE preferences, did the Fx preference extensions.febe.extBUdir get cleared in about:config?

Try this:
  1. Open FEBE Options.
  2. Open and clear the Fx browser console (CTRL-SHIFT-J). Click the little trash can in the upper left to clear.
  3. Click the FEBE Options > Advanced > Clear FEBE preferences button again.
  4. Look in the browser console for any messages.
  5. Copy/paste them here (Click once in the console body to focus, CTRL-A to select all, CTRL-C to copy, CTRL-V to paste)

I don't believe the defrag messages are relevant in this case.

Re: FEBE 8 Welcome Page remains

PostPosted: Wed Dec 07, 2016 6:58 pm
by mbs2753
cbaker_admin wrote:As Alice in Wonderland once said, this is getting curiouser and curiouser. When you reset FEBE preferences, did the Fx preference extensions.febe.extBUdir get cleared in about:config?

Try this:

Open FEBE Options.
Open and clear the Fx browser console (CTRL-SHIFT-J). Click the little trash can in the upper left to clear.
Click the FEBE Options > Advanced > Clear FEBE preferences button again.
Look in the browser console for any messages.
Copy/paste them here (Click once in the console body to focus, CTRL-A to select all, CTRL-C to copy, CTRL-V to paste)


Curiouser and curiouser is right.

Results from Console (after re-boot. Nothing in console before):

Error: Could not establish connection. Receiving end does not exist. (unknown)
Use of getPreventDefault() is deprecated. Use defaultPrevented instead. jquery.min.js:3:7108
"CORS request timed out for https://wsimap0.weather.com/201205/en-u ... 784&meta=1" wx.js:13:15142
TypeError: favoritesCallback94102199999 is not a function[Learn More] zmw:94102.1.99999.json:2:1
TypeError: favoritesCallback77001199999 is not a function[Learn More] zmw:77001.1.99999.json:2:1
Key event not available on some keyboard layouts: key=“c” modifiers=“accel,alt” browser.xul
Key event not available on some keyboard layouts: key=“r” modifiers=“accel,alt” browser.xul
Key event not available on some keyboard layouts: key=“f” modifiers=“accel alt shift” browser.xul
Key event not available on some keyboard layouts: key=“b” modifiers=“accel alt shift” browser.xul
Key event not available on some keyboard layouts: key=“i” modifiers=“accel,alt,shift” browser.xul
TypeError: jQuery17206332757552081372_1481161963793 is not a function[Learn More] json:1:1
TypeError: jQuery17206332757552081372_1481161963794 is not a function[Learn More] callback=jQuery17206332757552081372_1481161963794:1:1
‘mozHidden’ and ‘mozVisibilityState’ are deprecated. Please use the unprefixed ‘hidden’ and ‘visibilityState’ instead. pubads_impl_107.js:51:288

-Mike-

Re: FEBE 8 Welcome Page remains

PostPosted: Thu Dec 08, 2016 3:59 pm
by cbaker_admin
None of those messages mentions FEBE explicitly, so I doubt they are the problem.

When you manually reset the two FEBE version preferences, did they actually clear? The values of each after resetting should be blank.

Perhaps it is a permissions problem. Using Windows Explorer, go to C:\Users\Mike\AppData\Roaming\Mozilla\Firefox\Profiles\79yxo1jn.New 9-26-15\, find the file prefs.js, right-click on it and select Properties > Security. The file should have Full control checked for all users. If not, change it so they do.

Re: FEBE 8 Welcome Page remains

PostPosted: Fri Dec 09, 2016 5:52 am
by mbs2753
All Permissions were already set to "Allow".

-Mike-

Re: FEBE 8 Welcome Page remains

PostPosted: Fri Dec 09, 2016 8:24 am
by cbaker_admin
When you manually reset the two FEBE version preferences, did they actually clear? The values of each after resetting should be blank.

When you reset FEBE preferences, did the Fx preference extensions.febe.extBUdir get cleared in about:config?

Re: FEBE 8 Welcome Page remains

PostPosted: Fri Dec 09, 2016 4:04 pm
by mbs2753
cbaker_admin wrote:When you manually reset the two FEBE version preferences, did they actually clear? The values of each after resetting should be blank.


I reset them again as I did not record the results the first time.

extensions.febe.currentversion;reset to 0.0
extensions.febe.previousversion; reset to -blank-

cbaker_admin wrote:When you reset FEBE preferences, did the Fx preference extensions.febe.extBUdir get cleared in about:config?


extensions.febe.extBUdir; reset to -blank-

-Mike-

Re: FEBE 8 Welcome Page remains

PostPosted: Fri Dec 09, 2016 5:33 pm
by cbaker_admin
Ok ... just so I understand correctly, running Clear FEBE preferences sets extensions.febe.extBUdir in about:config to blank but going back into FEBE Options shows Where to backup > Backup destination directory as still being set?

Re: FEBE 8 Welcome Page remains

PostPosted: Fri Dec 09, 2016 7:11 pm
by mbs2753
Chuck:

No. When you were asking me about the Fx preference extensions.febe.extBUdir getting cleared in about:config, I was somehow associating that with clearing it manually as we did with extensions.febe.currentversion and extensions.febe.previousversion.

I retested by clearing FEBE preferences in FEBE Options > Advanced > Clear FEBE preferences, rebooted and checked extensions.febe.extBUdir in about:config. The destination drive/folder remains and did not clear.

-Mike-

Re: FEBE 8 Welcome Page remains

PostPosted: Sat Dec 10, 2016 3:55 pm
by cbaker_admin
Let's see if the problem is somehow related to your profile.

  1. Create a new profile by going to FEBE > Restore profile > Create new profile
  2. Enter a profile name (perhaps FEBE test) and check the box Create desktop shortcut to this profile
  3. Close the Restore Profile window and close Fx
  4. Find the desktop icon and double-click
  5. Install FEBE and try to duplicate the problems

Re: FEBE 8 Welcome Page remains

PostPosted: Sun Dec 11, 2016 2:12 pm
by mbs2753
Chuck:

Success!

It appears to be something in my profile. Creating a new profile and installing FEBE eliminated the reoccurring welcome screen. I am now in the process of restoring extensions one at a time to see if I can identify the offending program, When/if I do, I will post it here FYI.

-Mike-