"Cannot paste encrypted data in non-password field"

Discuss all "Paste Email" issues or request new features.

"Cannot paste encrypted data in non-password field"

Postby MsTaken » Wed Feb 13, 2013 6:42 am

Hello!

I'm having a some problems with PEP I hope you can help with. I don't quite know how to explain this, but I'll do the best I can...

When trying to copy some encrypted info from PEP (to paste in a field manually), the entries don't show up consistently in the context menu, so to speak. As a made-up example, sometimes the exact same entry will for example say;

Paste Email Plus > Name > Pastetext: <Encrypted>


And at other times the same entry will say something like;

Paste Email Plus > Name > Pastetext: ef7364ojk357567bg63960jrh (<- Those are randomly made up characters, just to illustrate what it looks like)

No matter what "version" the encrypted entry is shown in though, I couldn't be allowed copy it to the clipboard. After a few tries on different sites, I instead suddenly got an error message from PEP saying;

Universal Connect was refused, cannot copy to clipboard. Go to about:config and set signed.applets.codebase_principal_support to true enable clipboard support.

I did that, I set it to true but it just changed the problem. Now, when trying to enter encrypted info, the context menu's "Paste" option isn't greyed out anymore so I am able to paste into the fields, BUT, the info pasted is just whatever random info I happen to have in the clipboard, instead of the PEP entry. (Non-encrypted entries all work fine, though. I have had no problems with them whatsoever at any time. It's only encrypted entries that are mischievous.)

After reading another post on the forum, I went to the error console, cleared it and entered, as suggested;

netscape.security.PrivilegeManager.enablePrivilege("UniversalXPConnect");

I clicked "Evaluate" and this is what it said;

Timestamp: 13-02-2013 13:18:27
Error: TypeError: netscape.security.PrivilegeManager is undefined
Source File: javascript:%20netscape.security.PrivilegeManager.enablePrivilege("UniversalXPConnect");
Line: 1


I don't know if that helps any. I have the PasteEmailPlus v4.0beta installed. I've also tried resetting PEP and re-entering all the info, but that hasn't helped either.

Later, on a different random webpage, I tried again to use PEP and then I got THIS error message;

Cannot paste encrypted data in non-password field

Now that message was a bit of a bummer, because there's other info I'd like to keep as encrypted entries that aren't necessarily passwords, such as my name, address, tlf nr and other things, BUT... when I then went to a designated password input field to see if I there could be allowed to enter encrypted info, well, none of the PEP entries looked as if they were encrypted at all, all of a sudden. That is, none of ANY of the entries I have in PEP show up greyed out in the context menu anymore like they were before and none of them require me to paste them manually anymore. They all allow themselves to be pasted away with just a click! All entries work just like regular non-encrypted entries, whether they are encrypted or not, but ONLY in password fields. In all other fields, encrypted entries don't work and won't paste any which way. (I hope that made sense.)

(PS) I did have some Swedish characters (f.ex. ö) in some PEP entries and the non-encrypted ones work just fine. I have tried deleting all entries I have with Swedish characters in them to see it that would help, but no. Even if I'm using only characters a-z, A-Z and 0-9, I still can't use any encrypted entries anywhere but in password fields and then, they don't demand I manually paste them anymore. :(

I hope I explained all that well enough. Are my problems at all fixable? I really like this addon and would love to be able to use encrypted entries in other fields besides password fields. Thank you in advance for any help you can offer. :)
MsTaken
 
Posts: 2
Joined: Wed Feb 13, 2013 4:50 am

Re: "Cannot paste encrypted data in non-password field"

Postby cbaker_admin » Wed Feb 13, 2013 5:36 pm

Are you using the en-US (English) locale, or the sv-SE (Swedish)? In other words, does the PEP user interface display in English or Swedish?

Also, I'm a little confused by what you mean when you say:
When trying to copy some encrypted info from PEP (to paste in a field manually), the entries don't show up consistently in the context menu, so to speak. As a made-up example, sometimes the exact same entry will for example say;

Paste Email Plus > Name > Pastetext: <Encrypted>

And at other times the same entry will say something like;

Paste Email Plus > Name > Pastetext: ef7364ojk357567bg63960jrh (<- Those are randomly made up characters, just to illustrate what it looks like)


Is the text that is pasted literally "Pastetext: <Encrypted>"?

Do you have the box Paste Email Plus Options > Advanced > Compatibility mode checked? If so, PEP's behavior is different on different types of pages (you can click the "i" help icon there for an explanation).

Please try using the Paste Email Plus test page to paste encrypted and non-encrypted pastetext and let me know the results (screen shots would be helpful, if you have that ability). Encrypted items should only be allowed on the "Password" fields. Non-encrypted items can be pasted in any of the fields.
cbaker_admin
Site Admin
 
Posts: 4427
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: "Cannot paste encrypted data in non-password field"

Postby MsTaken » Thu Feb 14, 2013 7:25 am

Hello again! Thanks for replying! :)

I am using the English PEP interface and my whole Win7 is with English language install, too. My keyboard has a Danish layout though, because I write a lot in Swedish and Danish though, so I do use a lot of "odd" characters. (æ, ø, å, ö, ä, etc)

I don't have "Compatibility mode" checked.

Is the text that is pasted literally "Pastetext: <Encrypted>"?


No, that was only what the context menu itself showed when right-clicking on an encrypted entry. At first, nothing at all got copy/pasted, then after the about:config pref was set to true, PEP pasted whatever random content just happened to be in the clipboard, instead of the content of the entry. I haven't changed any settings since yesterday (except for installing some Windows Updates) but today I can't seem to be able to reproduce either of those pastetext version thingies to show you. This is what's happening now;

When I now right-click on any encrypted entry, (when in a password field) neither context menu pastetext "version" appears anymore, but PEP simply enters the (now correct) info into the password field straight away, without having to manually copy/paste anything at all. The same happens if I left-click. (Hidden behind "dots" of course, but the correct info.) Not having to manually copy/paste the encrypted entries isn't all that bad actually, LOL, it makes things easier, but I don't think it's supposed to work that way? Hovering over an encrypted entry will however show a long sequence of characters. That doesn't bother me and I don't even know if it's an issue, but I just seem to remember it used to just say; <Encrypted> there as well. All right-clicking does now is immediately insert the entry.

After reading your reply, I am now beginning to understand that it's perhaps by default and not an error at all like I thought it was, that encrypted info can't be used in non-password fields. If so, I do apologize for experiencing and "turning it in" as one. My bad. :( I would have liked to have the option to encrypt all entries, passwords or not, if I chose to though, as things like for example one's address and phone number and such are things I would like to have "locked down" and kept inaccessible to malware, identity thieves, etc.

In closing, I do apologize for being so long-winded and for my mistake. In short though, the only issue today seems to be the lack of having to manually copy/paste encrypted entries at all anymore, but unless it's a direct security issue, I reckon I can live with that. :)

Oh and the test page worked just fine. No copy/pasting encrypted info into password fields was necessary there either, though. I just click on whatever entry I want and voila! It's inserted. (Both left and clicking will do that.)

Thanks for your time and your patience. :)
MsTaken
 
Posts: 2
Joined: Wed Feb 13, 2013 4:50 am


Return to Paste Email (Original) and Paste Email Plus

Who is online

Users browsing this forum: No registered users and 4 guests

cron