[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4781: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4783: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4784: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4785: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
Chuck Baker's Firefox Extension Forum • View topic - PEP Problem with data after upgrade to v4.0

PEP Problem with data after upgrade to v4.0

Discuss all "Paste Email" issues or request new features.

PEP Problem with data after upgrade to v4.0

Postby ZuGro » Wed Aug 14, 2013 4:22 pm

Hi

OS: Win 7 (x64)
Fx: 21.0
(Tests in a clean profile)

1. copy file "pasteemailplus.json" from another profile to the new one (clean profile)
2. install Paste Email Plus v4.0 from AMO
3. all my categories and entries are there, and are working fine (can be pasted), however when i want to "change" any of the entries, all the fields are empty (Label, Category & PasteText)
4. When i want to set a entry as "Default", the popup says the "CATEGORY" as been set as default (I guess this is because the fields are empty)
5. when i backup (export) this data, apparently is successful, but when the backup is imported, all the entries are "skipped" (because the data fields are empty)
6. i have to get back the PEP v3.3 in order to avoid this ugly behavior of the v4.0
7. in another test, i just installed PEP v3.3, then upgrade to v4.0, but the problem is still there (only v3.3 is working fine in my system)...

PS: Other small bugs:
1. when i want to place the PEP button (not statusbar button) on any toolbar, the icon is correct when the button is dragged and dropped from the "Customize Toolbar" window to the toolbar, however when I click the "Done" button in the "Customize Toolbar" window, the icon becomes so BIG (as a 24px icon), this happens in both versions (v3.3 & v4.0)...
2. clicking the button (statusbar and/or toolbar button) nothing happens, the "default" or "Last used" pastetext is not pasted (I have to use the popup menu to select what to paste always) (also this problem is present in both versions, 3.3 & 4.0)...

OK, that's all, this is my report for feedback
(Currently i can work very fine with PEP v3.3)

Note: I'm a Spanish speaker, sorry for bad English write :shifty:
ZuGro
 
Posts: 3
Joined: Wed Aug 14, 2013 3:32 pm

Re: PEP Problem with data after upgrade to v4.0

Postby cbaker_admin » Wed Aug 14, 2013 6:06 pm

Thanks for the information. I will try to duplicate the issues to see what is going wrong. Are you getting any PEP related errors in the error console (Tools > Web Developer > Error Console)? Please install the extension for error checking. It is more comprehensive.

Open and clear the Error console. Leave it open and try to add/change some PEP items. Examine the error console for any PEP related error messages (type pasteemail in the "Search:" box). Copy/paste them here.
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: PEP Problem with data after upgrade to v4.0

Postby ZuGro » Wed Aug 14, 2013 7:57 pm

ZuGro
 
Posts: 3
Joined: Wed Aug 14, 2013 3:32 pm

Re: PEP Problem with data after upgrade to v4.0

Postby cbaker_admin » Thu Aug 15, 2013 3:41 pm

Ok ... It appears that PEP v4.0 is not compatible with Fx 21. It appeared to work with the 21 betas when I was testing it, but it certainly does not work with the 21 final release. I will change the compatibility release info on and the .

You should continue to use PEP v3.3 until you upgrade Fx.

Sorry about the inconvenience. :problem:
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: PEP Problem with data after upgrade to v4.0

Postby ZuGro » Thu Aug 15, 2013 6:25 pm

ZuGro
 
Posts: 3
Joined: Wed Aug 14, 2013 3:32 pm


Return to Paste Email (Original) and Paste Email Plus

Who is online

Users browsing this forum: No registered users and 2 guests

cron