Fixing invalid extension entries

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

Fixing invalid extension entries

Postby cbaker_admin » Mon Apr 21, 2008 3:40 pm

Sometimes Firefox leaves pieces of newly installed or partially installed extensions laying around in the profile/extensions folder. This often happens when upgrading to a new Fx version. Usually this doesn't present a big problem, but it can cause Firefox to take longer to load on startup and keep FEBE from completing a backup. FEBE checks for this condition prior to each backup to alert you in case you intended a newly installed extension to be included in the backup. (You may have forgotten to restart Firefox after the install.) FEBE just displays a warning and should continue performing the backup.

Fx2 and Fx3 users - If you are getting a message "You have X extension(s) pending installation that will not be included in the backup. -- skipped":

To get rid of this warning, you need to clean up the install folder. See if you have a directory named profile folder/extensions/staged-xpis.

If you do, complete the following steps (with Firefox closed):
  1. Remove profile folder/extensions/staged-xpis (and all its contents).
  2. Remove the three files in your profile named extensions.ini, extensions.cache, and extensions.rdf.
  3. Restart Firefox (Note: Any disabled extensions will be enabled after this process and will be have to be disabled manually.)
Step 1 will get rid of the "You have X extensions(s) pending..." message. Step 2 will clear the addon-manager window of uninstalled extensions.


FEBE 6 and Fx3 users - If you are getting a message "Could not process extension/theme with GUID xxx -- skipped":

Run Tools > FEBE > FEBE Options > Misc (Debug) > Verify extension directory. If you have any invalid items you will get a message:
Verify complete with errors ... see log.
Do you want FEBE to attempt repairs? (OK for yes, Cancel for no)


Click OK and let FEBE repair the damage.
Chuck
cbaker_admin
Site Admin
 
Posts: 4323
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Return to FEBE/CLEO

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron