Page 1 of 2

FEBE backup Fails 'Wrong Input XML'

PostPosted: Tue Nov 10, 2009 9:18 pm
by eriji
In about the last week, FEBE has stopped being able to backup to for me. I get an error (FEBE 'copytoclipboard' type message):
Code: Select all
Cannot create folder Wrong input XML

The backup window shows:

Code: Select all login OK
User ID: 863515 capacity: 15360 MB
Space used: 9962.88 MB
Space available: 5397.120000000001 MB
Max upload size: 2048 MB

Uploading all files in: W:\Backups\Firefox\FEBE 2009 11-10 22.40.25

MAYBE IMPORTANT: This is similar to an error I have been getting from Fireuploader (which is a FTP style interface to upload/download files to, picasa, rapidshare and other file storage utilities.) The problem with Fireuploader started all of a sudden also about 2-3 months ago. I reported this to Fireuploader developers several times, but never heard any reply, and they are on a updatefrequency=wheneverbutnotsoon schedule. The exact error they give is:
Code: Select all
Failed getting token! Wrong input XML

I have two systems side by side, one WinXP mature and stable. One Vista, fairly new, as unstable as Vista is.
The FEBE problem occurs only on the Vista system, the Fireuploader problem consistently occurs on both systems. Actually I would have sworn that the FEBE problem occurred on both systems, but it worked tonight on the WinXP as I was going through double checking before submitting this thread.

Ok, so after looking at all that, I figured that the problem was probably had changed something, so I contacted them first. Well after multiple interactions with a first line support typist who could not read and comprehend, I finally explained it with color coding back to the original email and they finally said:
"Ok we passed this on to the developers and they will contact FEBE and Fireuploader"

So this is a forewarning they might contact you about the problem. Tell me what info you need or if you want me to try it with the debug extension and I'll be happy to do that. Hopefully the email forum notification is working with phpbb3 ;)

And finally, if you do know what the problem is, suggestions are welcome. :lol:

Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Wed Nov 11, 2009 10:25 am
by cbaker_admin contacted me last night. I will be working on it today. When I have something to test, I'll post a note here.

Thanks for the offer to help with debug :)

Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Wed Nov 11, 2009 11:51 am
by cbaker_admin
Update: now uses https protocol instead of http. I can get it to upload, but not download due to an invalid security certificate. I've contacted and am awaiting a response.

Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Wed Nov 11, 2009 6:06 pm
by eriji
I was fairly certain they had changed something. Thanks for looking into it. I'll keep an eye on to see the status, and don't hesitate to ask if you need testing or anything.


Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Sun Nov 15, 2009 9:11 pm
by eriji
Just installed FEBE v6.3.2 and is working.

Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Sun Jan 24, 2010 5:52 am
by eriji
Hello, I am sorry to report that the upload is not working again.

When the upload starts it logs in ok, then gets the following message:

Code: Select all
! FEBE message ...

Cannot create folder Wrong input XML 

And just as an additional note, in the FEBE Options, the 'Test Login' works ok, the 'View Folder' works ok, the 'Upload ... last backup...' gives the above message, and the ' info page' gives a 'Page not found' from the web side. (never had tried that one before)

Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Sun Jan 24, 2010 7:18 am
by cbaker_admin
What do you have in FEBE Options > > backup root directory?

Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Sun Jan 24, 2010 8:30 am
by eriji
Same as it has always been...

'FEBE Backups'

and, yes the directory exists, its still there from the last backup (I don't ever delete it.)

was a bit weird on the options window, the field for this directory is squished, so you only see the top half of it... like its displaying and then something overlays it... i've see this infrequently before in some window displays in different programs, but never knew quite what was causing it. seemed to be some programming issue on window creation.

Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Sun Jan 24, 2010 8:44 am
by cbaker_admin
Hmm ... I get the same error. It was working fine just a couple of days ago. must have changed something. I will look into it and post my findings here.

Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Sun Jan 24, 2010 10:12 am
by cbaker_admin
It looks like only allows https for paid accounts. Free accounts work with both http and https. Try this fix and let me know.

Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Wed Mar 17, 2010 12:22 pm
by eriji
I apologize, I missed your reply, so I never answered it.

Status as of this moment:
Two computers running FEBE.
#1 XP,FF3.5.8, FEBE - uploads ok, everything worked until a few minutes ago when I upgraded a number of OTHER extensions... then the upload stopped working with 'wrong input xml'. weird. loaded 6.3.3 and works now.
#2 Vista,FF3.6, FEBE 6.3.3 - was not working (wrong input xml) until I updated to 6.3.3. Now its working, kinda. It logs on ok, it seems to upload ok, but the upload window never finishes and got this error:
Code: Select all
Starting profileFx3{default}.fbu
Uploading: profileFx3{default}.fbu 29844kb
Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIXMLHttpRequest.send]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://febe/content/boxnet.js :: febeUpload :: line 392" data: no]

Now, this message which is from the log is different from the 'error popup' msg I got when it finally timed out after about 20 minutes. I didn't copy that one, because I was wrong thinking it would put it in the log (which its always done in the past.)
It was something about the MAC code having an error or mismatch, but that's all I can remember now.

Now I switched to doing fool profile backups instead of selected backups, which I'm not sure was a wise choice or not.

But there's the status. Looks like 6.3.3 fixed the 'wrong input xml' problem, but there may be some issue still not handling an exception in the upload process.

Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Thu Mar 18, 2010 1:37 pm
by eriji
I just signed up for a second account that is free.

That account works fine.

So, the problems I'm having are because I'm a paying subscriber to the service, not because of some anomaly in the FEBE software.

I am really unhappy about this, and will pursue it with for a resolution.

If you know how you can fix it so it works with both types of accounts, then awesome. Otherwise, I'll let you know what I find out from


Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Thu Mar 18, 2010 2:28 pm
by eriji
Here is the response from Embedded in this is a response from the manager of OpenBox, which is the third-party interface.


Thank you for your message.

The message below is from our OpenBox Manager:

The issue is that FEBE still uploads through HTTP and not HTTPs. Neither FEBE nore FireUploader took my warnings that they need to use HTTPs. This is why I haven't added either of these apps to our OpenBox directory, as they did not pass our QA tests.

These are third party applications that are not supported by, but we are working with them to try to get these issues resolved.

This customer could actually choose to disable SSL from Settings, and then these applications will work. But that would sacrifice the security benefits of SSL.

You can try this recommendation, but that would mean you would lose the data encryption of your files in transit to our servers.

We hope this helps. Please contact us if you have further questions.

The Team

Apparently they added the SSL option somewhere along the way and forgot to tell anyone. I searched through all the announcements of service upgrades, etc. and there is no mention of this "feature."

They could have mentioned this during the previous interactions I had with them about the problem, and maybe a faster resolution for me would have occurred.

I'm turning it off. I don't use for any secret or subversive activities and don't anticipate that requirement in the future. If someone really wants to spy on me they are welcome to be bored. It's their life.

You can take the above information and use it how you wish.

Best Regards,
--eric powell

Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Thu Mar 18, 2010 4:05 pm
by cbaker_admin
I thought I had the http/https issue resolved awhile ago. Anyway, it worked for me with both free and paid accounts. I've uploaded FEBE with some changes. Can you try it with SSL both on and off?


Re: FEBE backup Fails 'Wrong Input XML'

PostPosted: Thu Mar 18, 2010 6:53 pm
by eriji
I've got more testing on both machines to do, but on the first backup, the version listed as, not or 6.3.3 which was the other "test" version you had sent.

Just checking to make sure this is correct. I am confident I downloaded the one that says and installed it and restarted Firefox immediately before that backup.