[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4781: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4783: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4784: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4785: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
Chuck Baker's Firefox Extension Forum • View topic - "Unresponsive script" post thread

"Unresponsive script" post thread

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

Re: "Unresponsive script" post thread

Postby cbaker_admin » Sat Jun 16, 2012 3:48 pm

I'm glad the problem disappeared for you. It still affects other users (not me, though ... that makes it hard to debug). I'm currently developing FEBE v8.0 which will be a major overhaul/re-write of all the code. Mozilla and javascript have come a long way since the first FEBE release and there are some things that can be re-done to make things more efficient. I'm just hoping that that will not introduce a whole new set of problems ... :wink:
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: "Unresponsive script" post thread

Postby cyrix » Sat Jun 16, 2012 5:59 pm

Thanks for all you do. I don't know of any other Firefox extension that has such support.
cyrix
 
Posts: 17
Joined: Thu Jan 08, 2009 11:18 am

Re: "Unresponsive script" post thread

Postby SpottedDog » Fri Jun 22, 2012 10:32 am

I am trying to transfer my profile from my Linux machine (Ubuntu 12.04 64 bit) to a Win 7 (64) laptop and get the Unresponsive script error. If I chose option of continue or stop script it usually comes up with a window that says the profile has been restored but there are no changes to firefox so I don't think anything happened and there is no report page generated.
I have tried setting the about config setting to 60 , clearing preferences and verifying extension directory to no avail.I was able to do this the other way around from Win XP to Ubuntu but that was several versions of FEBE ago
SpottedDog
 
Posts: 6
Joined: Sun Sep 05, 2010 11:35 am

Re: "Unresponsive script" post thread

Postby cbaker_admin » Fri Jun 22, 2012 11:32 am

cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: "Unresponsive script" post thread

Postby SpottedDog » Fri Jun 22, 2012 12:34 pm

I am afraid it didn't work: bookmarks, history & plugins etc haven't changed. I am not overly concerned as I can probably transfer bookmarks manually, I was mainly after restoring plugins like my Ubuntu machine had but I would think there is likely some compatibility issues
SpottedDog
 
Posts: 6
Joined: Sun Sep 05, 2010 11:35 am

Re: "Unresponsive script" post thread

Postby SpottedDog » Fri Jun 22, 2012 6:58 pm

OK
On reboot Firefox has most of the old plugins (a few were incompatible) and it was just a matter of enabling them. My passwords, bookmarks and history have not been transferred. I am satisfied at this point

EDIT: I tried restoring my profile again because I realized after reading the tutorial on using FEBE that I was missing a step ; I didn't click on Firefox Start Options
Sorry this was entirely due to my misunderstanding, everything works great now (bookmarks, passwords, plugins,history etc)


FEBE is an excellent plugin :D :D
SpottedDog
 
Posts: 6
Joined: Sun Sep 05, 2010 11:35 am

Re: "Unresponsive script" post thread

Postby minderasr » Sun Jul 22, 2012 12:43 pm

I had the same problem, using FF 14.01 on a Win XP Pro (SP3) machine. Turned out my FEBE backup folder permissions were read only. Changing that permission solved the issue.

Thanks for a great add-on!
minderasr
 
Posts: 2
Joined: Sun Jul 15, 2012 9:09 am

Re: "Unresponsive script" post thread

Postby Votapardo » Sun Oct 21, 2012 7:08 am

HI everyone

I have the problem "FEBE still "hangs" (and the progress bar moves continuously)". I did what the post said but the problem persists. The error console says:

Fecha y hora: 21/10/2012 16:04:13
Error: NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFile.isDirectory]
Archivo de origen: chrome://febe/content/febeZip.js
Línea: 94

I'm using 7.0.35 in Windows XP Professional 2002.

Thanks!
Votapardo
 

Re: "Unresponsive script" post thread

Postby cbaker_admin » Sun Oct 21, 2012 4:00 pm

I can't seem to find the "FEBE still "hangs" (and the progress bar moves continuously)" thread. What steps did you take to fix the problem?

At that point in the code, FEBE is trying to determine if an entry in the folder is a directory or not. What is the full pathname to your backup destination directory? Are there any entries in that directory that have names with "strange" characters in them? Provide a list if you can.
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: "Unresponsive script" post thread

Postby khms » Sun Nov 29, 2015 7:50 am

I've a number of different browser instances (all Linux, all should be fairly new versions). On most, FEBE runs just fine.

Two, however, have problems. It doesn't seem to be connected to the numb er of open tabs - one of the two has the most of any instance (several hundred), the other is almost but not quite the lowest number at maybe a dozen.

On the big one, symptoms are repeated script-unresponsive prompts (though the time-out should already be a minute), usually followed by an error like the attached - in this case, it's clearly session manager doing a clean up of its backups, but I think I've seen similar complaints about other extensions as well).

The other sometimes gives a similar error message, but often, the backup just seems to freeze most of the browser - that is, I can click on things (for example), the user interface reacts, but the browser doesn't take whatever action it was supposed to, which is fairly typical for a running backup; the same is true for the backup window itself. I've found no better option than to abort and restart the browser.

In either case, there's an aborted, incomplete backup.

The big one is FEBE 8.8, FF 39.0, profile 1.2 GB (presumably that includes cache). (The small one is at work, I can't look it up from here, but apart from being smaller it shouldn't be very different. Also, all instances - including the ones working fine - should have exactly the same extensions running, thanks to FF Sync.)

While I'm here, here's another thing that probably isn't related: on every instance, FEBE takes an incredibly long time to open any window.
Attachments
FEBE-Bug.png
Error message
khms
 
Posts: 4
Joined: Sat Nov 28, 2015 10:00 pm

Re: "Unresponsive script" post thread

Postby khms » Sun Nov 29, 2015 7:55 am

Another smallish thing. It would be rather useful if any box displayed allowed you to copy the text shown, so we don't need to either take screen shots or copy the text manually (which is rather error-prone).
khms
 
Posts: 4
Joined: Sat Nov 28, 2015 10:00 pm

Re: "Unresponsive script" post thread

Postby cbaker_admin » Sun Nov 29, 2015 12:41 pm

Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: "Unresponsive script" post thread

Postby Kloppstock » Sun Sep 11, 2016 12:32 pm

I have followed this steps
viewtopic.php?f=11&t=1707
Febe 6.3 Debug wasn't allow to operate by Firefox 48.02 and i can see nothing to do about it, i klicked yes on grant it special approval, but then i got a second rejection :).
Anyway i couldn't even find the value "dom.max_chrome_script_run_time" so i created a new boolean and then inserted value 0.

However i stil get this message (im not sure its 100 % the same as this thread describe, so i will give you the whole picture)
all 3 klick alternatives doesn't lead anywhere

Edit: When i think about it, the message really doesnt say "Unresponsive" in my language, it actually says "Warning: Uninfluential script"
However can i get help in this thread anyway?
Attachments
Namnlös1.jpg
Kloppstock
 
Posts: 6
Joined: Sat Sep 10, 2016 1:20 pm

Re: "Unresponsive script" post thread

Postby cbaker_admin » Sun Sep 11, 2016 3:52 pm

FEBE 6.3 Debug is over six years old and I'm sure would not work correctly with Fx 48. The most current version is . Are you having script problems with that version?

Another user and an extension or program named "Thunar". Are you using it also?
Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: "Unresponsive script" post thread

Postby Kloppstock » Tue Sep 13, 2016 3:33 pm

Kloppstock
 
Posts: 6
Joined: Sat Sep 10, 2016 1:20 pm

PreviousNext

Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 4 guests

cron