Page 8 of 10

Re: "Unresponsive script" post thread

PostPosted: Fri Jul 15, 2011 1:30 pm
by JAP1st
Yes, I have restored the profile manually on a Firefox 5.0 profile in Ubuntu 11.04.

Re: "Unresponsive script" post thread

PostPosted: Thu Oct 20, 2011 12:04 pm
by davidfooty
Hi,


Recently upgraded to:
FF 7.0.1
FEBE 7.0.2

Attempting a Full Profile backup

Backup appears to work, but display remains on 'Preparing Report' with status bar moving. Abort does not give 'Script busy' message, just the 'backup aborted' slide-up.

I have tried most things suggested ie:
Clear FEBE preferences
Verify extension directory - all fixed
Check AddonManager functionality
which gives:
Addon with GUID of {3f963a5b-e555-4543-90e2-c3908898db71} is reported by AddonManager but does not have an entry in the extensions directory
Addon with GUID of {23fcfd51-4958-4f00-80a3-ae97e717ed8b} is reported by AddonManager but does not have an entry in the extensions directory
Addon with GUID of {6904342A-8307-11DF-A508-4AE2DFD72085} is reported by AddonManager but does not have an entry in the extensions directory
Addon with GUID of {22119944-ED35-4ab1-910B-E619EA06A115} is reported by AddonManager but does not have an entry in the extensions directory


My registry shows:
FirefoxFEBE01.jpg
FirefoxFEBE01.jpg (82.13 KiB) Viewed 16514 times

I have added these and any other 'imcompatible' items to my ignore list.

Error console:
Error: attempt to run compile-and-go script on a cleared scope
Source File: chrome://febe/content/febeObserver.js
Line: 10
Error: febeBuItemVerifiedList[key] is undefined
Source File: chrome://febe/content/febe.js
Line: 844

Any help would be appreciated.

Thanfs & regards
David

Re: "Unresponsive script" post thread

PostPosted: Thu Oct 20, 2011 4:07 pm
by cbaker_admin
  • {3f963a5b-e555-4543-90e2-c3908898db71} - AVG
  • {23fcfd51-4958-4f00-80a3-ae97e717ed8b} - DivX Plus Web Player HTML5
  • {6904342A-8307-11DF-A508-4AE2DFD72085} - DivX HiQ
  • {22119944-ED35-4ab1-910B-E619EA06A115} - AI RoboForm
All the above are either proxy extensions or plugins masquerading as extensions. FEBE cannot back them up and it is appropriate to include them in the ignore list.

The "attempt to run compile-and-go script on a cleared scope" error is a known Firefox bug.

The "febeBuItemVerifiedList[key] is undefined" error should disappear after running "Clear FEBE preferences" in FEBE Options > Advanced.

Re: "Unresponsive script" post thread

PostPosted: Fri Oct 21, 2011 12:46 am
by davidfooty
Thanks. Running Clear FEBE preferences again fixed it.

Re: "Unresponsive script" post thread

PostPosted: Sun Jan 15, 2012 9:50 am
by xqsloc
I cannot see this particular error reported in this thread previously...

FEBE works perfectly -- in just a few seconds on my 5-year-old
4-core desktop with 4GB of RAM, writing out an 8.0MB FEBE backup directory --
if and only if "Play Sounds" is OFF.

It "never" terminates if "Play Sounds" is ON, with the following
error reported in the Error Console:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsISound.play]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: chrome://febe/content/febeCommon.js :: febePlaySound :: line 1145" data: no]

This is with FEBE version 7.0.2 installed in Firefox 10.0b4 on Linux Fedora 14
(fully updated).

I believe this has been happening as long as I have had FEBE installed,
which means back to FF 8.0 and 9.0 betas. (But I could be wrong.)

I had not worried about it since I found that the FEBE backup was fine
even if I aborted after a few minutes. But I got curious and found this
error reported in the Error Console.

(I did not miss the missing-sounds as my speakers are normally off.
I do not know why "Play Sounds" was ON: perhaps it is the default...)

May I suggest that, as playing sounds need not prevent FEBE from doing
its job, any failure of this feature should be logged-and-ignored?
That seems the most robust approach. (But then I don't know javascript or
what the FF API allows you to do.)

Thanks for a very useful extension.

Re: "Unresponsive script" post thread

PostPosted: Sun Jan 15, 2012 5:30 pm
by cbaker_admin
Playing sounds on some Linux platforms has been problematical for some time (See this bug report). Although it works with some *nix installs (i.e, Ubuntu), others (like Fedora, apparently) it does not.

I will put this on my todo list for the next FEBE release. I believe the best way to handle it is to trap the error, alert the user, and disable sounds automatically.

Aborting automatically when Restoring Profile.

PostPosted: Mon Apr 23, 2012 7:46 pm
by X_Hunter
Hello Mr. Chuck. 1st off, I wanted to thank you for making such useful extension! Honestly, it saved me a lot of time when working with backing up my firefox data/preferences. I wanted to send you some feedback before, but as I could see you solved it all, there was no need to do that.

But now, it's a pity I got something which is being a harsh, since I formatted my PC and re-installed Firefox. This should be probably something personal, I guess. I'm just no so sure if this problem is being caused because I backed up this profile into a Windows 7 version and I'm trying to restore it on Windows XP again. So, if that affects on something, please warn me.

The main problem in fact, is that I'm trying to restore my whole profile with a file generated with your extension (.fbu), but it automatically aborts the task. It certainly should take a long time to restore, as I got LOADS of extensions. So my .fbu file is about, hmm... 120 MB. I'm just questioning if it's automatically aborting in fact due to the size of my profile data or if it matters on which OS I'm on.

Any advices? And... Is there a way to 'force' the extension to restore huge profiles, in case they're relatively big?

Thanks in advance.


PS: I read your FAQ, went to the error console and saw an error just once, but I didn't get it anymore. I'll try to re-install Firefox once again to get that error message and append it here, if possible.

Re: "Unresponsive script" post thread

PostPosted: Mon Apr 23, 2012 8:08 pm
by X_Hunter
Haha, it's funny to say how quick I got over this, but when I saw the thread "How to manually restore your Firefox profile", I got basically how your extension works. I didn't know it was all zipped into a file, but with your own extension, lol. :D

So, just to do not throw away the post I started... 2 little questions:

1 - Does the OS I'm currently on affects to restore a profile into another system? (If there are any known issues, troubles, etc.)

2 - Is there a way to 'force' the extension to restore huge profiles, in case they're relatively big? (If your extension does this in fact.)

Thanks again!

Re: "Unresponsive script" post thread

PostPosted: Wed Apr 25, 2012 3:46 pm
by cbaker_admin
X_Hunter wrote:1 - Does the OS I'm currently on affects to restore a profile into another system? (If there are any known issues, troubles, etc.)

Generally speaking, no. You can restore a profile created in Windows XP into a Windows 7 machine. You can even go from/to Windows/Linux/Mac. The only issues you may run into is platform specific extension preferences (i.e., in about:config, the preference extensions.febe.exportprefs.directory might be C:\FEBE backup in a Windows install, but should be /home/FEBE backup in Linux.) But usually those things fix themselves after a time.

2 - Is there a way to 'force' the extension to restore huge profiles, in case they're relatively big? (If your extension does this in fact.)

There is a preference in about:config called dom.max_chrome_script_run_time. The bigger the value, the longer Fx will wait for a function to finish before attempting to abort. I believe the default is 20 seconds. In FEBE Options > Advanced > Miscellaneous > Advanced preferences > Chrome script timeout you can change it for FEBE backups. But at this time, I don't believe it effects FEBE restores. I will add that functionality in the next version.

Re: "Unresponsive script" post thread

PostPosted: Sun May 27, 2012 2:38 am
by jfeat
I keep getting this problem, have followed advice in forum but problem persists. Running ffx 12.0. Error console returns:
Error: attempt to run compile-and-go script on a cleared scope
Source file: chrome://febe/content/febeObserver.js
Line: 10

Your advice much appreciated

jfeat

Re: "Unresponsive script" post thread

PostPosted: Sun May 27, 2012 8:42 am
by cbaker_admin
This is a bug with Firefox code that was supposedly fixed (Bug 635548). In FEBE v8, I will be re-writing the code in that error in an attempt to work around the bug.

Does the error prevent you from getting any backup at all (i.e., both selective and/or full profile)?

Re: "Unresponsive script" post thread

PostPosted: Sun May 27, 2012 1:58 pm
by jfeat
Chuck
Full profile backup works and completes in under 2 seconds! I also tried both but got same problem as if running selective backup only.
jfeat

Re: "Unresponsive script" post thread

PostPosted: Sun May 27, 2012 4:39 pm
by cbaker_admin
So if I'm understanding you correctly, the error prevents you from completing a selective backup, but a full profile backup does complete. Is this correct?

Re: "Unresponsive script" post thread

PostPosted: Sun May 27, 2012 10:30 pm
by jfeat
Correct

Re: "Unresponsive script" post thread

PostPosted: Sat Jun 16, 2012 3:33 pm
by cyrix
I've been away from FEBE for a long while, but am back now. Just bought new PC (after 8 years!) with the latest Firefox installed. For me, the 'unresponsive script' error is gone with the wind because backups and restores now take 2 seconds instead of 2 minutes. Chuck, how did things get so fast? Wow!