"Unresponsive script" post thread

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

Re: "Unresponsive script" warning with Fx 3.6

Postby Snapafun » Wed Apr 07, 2010 2:13 am

I cannot find the "aboug:config" to change the value.
Pls. advise the path.

On a new tab or window with Firefox, type " about:config " ( exclude the quotes ) and a warning will present itself. Accept that you'll not screw things up and do a search for what you want. Tread carefully.

Re: "Unresponsive script" warning with Fx 3.6

Postby migdalorguy » Mon Apr 19, 2010 5:16 pm

Here's where my debug version stopped:


Re: "Unresponsive script" warning with Fx 3.6

Postby Carl » Tue May 18, 2010 9:23 am

I have installed FEBE6.3 Debug, here is the requested data.

The last backed up item or the item currently being backed up in the log is:

C:\Documents and Settings\admin\Application Data\Mozilla\Firefox\Profiles\febeprof.new\extensions\{cd617375-6743-4ee8-bac4-fbf10f35729e}\content\rtc.js

next item on the log would be:


which contains:

{"Label":"FEBE data","Type":0,"Description":"FEBE user-defined backup data","Path":"C:\\Documents and Settings\\Administrator.HOME\\Application Data\\Mozilla\\Firefox\\Profiles\\75cgtgnx.default\\febeUserDefinedBuData.json","Include":true}

The following is a list of add-ones, only FEBE and Java were active on this test.

Adblock Plus 1.2 false {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Add-on Compatibility Reporter 0.4.2 false compatibility@addons.mozilla.org
Adobe DLM (powered by getPlus(R)) false {E2883E8F-472F-4fb0-9522-AC9BF37916A7}
Bookmark Duplicate Detector 1.0.3 false {ba243cb0-b824-4a26-9418-73ee795d9b9d}
British English Dictionary 1.19 false en-GB@dictionaries.addons.mozilla.org
CustomizeGoogle 0.76 false {fce36c1e-58d8-498a-b2a5-66ad1cedebbb}
DragNDrop Toolbars false dndtb@c-est-simple.com
Google Toolbar for Firefox 7.0.20100326W false {3112ca9c-de6d-4884-a869-9855de68056c}
Java Console 6.0.17 true {CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}
Java Quick Starter 1.0 true jqs@sun.com
Microsoft .NET Framework Assistant 0.0.0 false {20a82645-c095-46ed-80e3-08825760534b}
MultirowBookmarksToolbar 4.9 false {FBF6D7FB-F305-4445-BB3D-FEF66579A033}
myTimeZone for eBay 1.7 false myTimeZone@smartgamez.org
NoScript false {73a6fe31-595d-460b-a920-fcc0f8843232}
QuickRestart 1.1.6 false {F645A8C9-E969-42D9-B3F3-F325537222FD}
RightToClick 2.7.2 false {cd617375-6743-4ee8-bac4-fbf10f35729e}
Tabs Menu 1.4.8 false {dc5d9a10-2736-11da-8cd6-0800200c9a66}
Thinger 1.0 false Thinger@blueprintit.co.uk
Toolbar Buttons false {03B08592-E5B4-45ff-A0BE-C1D975458688}
Update Scanner 3.1.2 false {c07d1a49-9894-49ff-a594-38960ede8fb9}
ZoneAlarm Toolbar false {FFB96CC1-7EB3-449D-B827-DB661701C6BB}
BetterPrivacy 1.47.4 false {d40f5e7b-d2cf-4856-b441-cc613eeffbe3}
CS Lite 1.4 false {00084897-021a-4361-8423-083407a033e0}
Tab Saver! 1.1.4 false {7A074BE0-2326-436d-B473-029FAEBEB5C6}
FEBE 6.3.debug true {4BBDD651-70CF-4821-84F8-2B918CF89CA3}

Hope this helps


Re: "Unresponsive script" warning with Fx 3.6

Postby cbaker_admin » Tue May 18, 2010 8:20 pm

Thanks for the report, Carl. Are you still experiencing the "Unresponsive script" message? And have you change the Firefox setting as described in this post?
Site Admin
Posts: 4572
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: "Unresponsive script" warning with Fx 3.6

Postby Carl » Wed May 19, 2010 2:06 am

Thanks for the reply. I should have followed the advice in the posting first. I changed the setting to 60 which then stopped at:

C:\Documents and Settings\admin\Application Data\Mozilla\Firefox\Profiles\febeprof.new\extensions\{fce36c1e-58d8-498a-b2a5-66ad1cedebbb}\README

then changed it to 0 which then completed and now only shows error:

Can't find user-defined backup file C:\Documents and Settings\Administrator.HOME\Application Data\Mozilla\Firefox\Profiles\75cgtgnx.default\febeUserDefinedBuData.json

maybe because I do not use that function.

Thanks for help


Re: "Unresponsive script" warning with Fx 3.6

Postby cbaker_admin » Wed May 19, 2010 6:52 pm

If you run Tools > FEBE > FEBE Options > Misc > Clear FEBE preferences the file febeUserDefinedBuData.json will be re-created. You will need to re-enter your FEBE backup destination directory and other options afterward.
Site Admin
Posts: 4572
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: "Unresponsive script" warning with Fx 3.6

Postby iflow » Sun May 30, 2010 8:58 am

First, great add-on :)

I always get this "Unresponsive script" message, if an add-on or plug-in is set "disabled". Everything works perfect, if all add-ons and plug-ins are enabled.
Maybe this information helps someone.

My FF version: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv: Gecko/20100401 Firefox/3.6.3
My FEBE version:


Re: "Unresponsive script" warning with Fx 3.6

Postby 1031982 » Wed Jun 02, 2010 11:55 pm

This fixed the issue for me. I started having issues, and this was the first thing I saw fallowing the homepage for the add-on.
This was the first time I had an issue with FEBE at all, I'm glad it's an easy fix.
Just an FYI, it takes my backup 20-21 seconds, so I just set my timeout to 30 seconds.
Posts: 1
Joined: Wed Jun 02, 2010 11:52 pm

Re: "Unresponsive script" warning with Fx 3.6

Postby andries » Mon Jun 07, 2010 7:47 am

I also experienced the stalled script problem. Did the dom.max_chrome_script_run_time fix but still experienced intermittent problems, the latest one about 10 minutes ago. So I used CCleaner to wipe the cache (quite large after a couple of heavy surfing sessions) plus history and ran Febe again. It breezed through the backup in seconds.
Could large Firefox cache files be a factor?
Firefox 3.6.3

Re: "Unresponsive script" warning with Fx 3.6

Postby jmaldrich » Sun Jun 20, 2010 7:48 am

It finally worked when I set the dom.max_chrome_script_run_time to 0. Not sure why, unless it's that I have a lot of tabs open and FEBE is having problems with the scripts running on them or something.

Re: "Unresponsive script" warning with Fx 3.6

Postby PCMartin » Sun Jun 27, 2010 3:57 pm

I've had a problem with FEBE hanging for quite some time. I don't remember if it coincided with the update to Firefox 3.6, nor do I recall if it was always in conjunction with an unresponsive script. I simply stopped using FEBE.

Anticipating a migration to a larger hard drive and the addition of Linux as a second, dual-boot operating system (along with Windows XP), I decided to give FEBE another try as an additional backup/restoration/migration tool. Sure enough, it hung in Firefox 3.6.6. This time, however, I came across Chuck's suggestion to increase the script timeout. In about:config, I changed the value of dom.max_chrome_script_run_time from 20 to 120, and my FEBE backup (to a cloud storage folder) completed within seconds instead of running indefinitely.

Thanks for a great tip that makes it possible to continue using this very helpful extension!

Re: "Unresponsive script" warning with Fx 3.6

Postby gallifreyan » Sat Jul 10, 2010 4:24 pm

I ran into this issue, bumped up the script timeout to 60, and the problem went away. Went from 470 seconds (probably including waiting for me to hit "continue" on the script dialog) to 30 seconds, about 36 megabytes of backup data.

I'm backing up to a LAN server's share, Windows Server 2003 (Windows Home Server released version). Firefox 3.6.6 on Windows 7 Pro 64-bit, if it makes a difference.


Re: "Unresponsive script" warning with Fx 3.6

Postby pjmax » Sat Sep 04, 2010 9:42 pm

I changed the dom.max_chrome_script_run_time preference to 60 seconds, as you stated. After this FEBE ran okay.
Prior to this change, I got these warning messages, per Console squared add-on:

Warning: assignment to undeclared variable src
Source file: chrome://febe/content/febeZip.js
Line: 10

Warning: assignment to undeclared variable febeZipFinished
Source file: chrome://febe/content/febeZip.js
Line: 31

Warning: assignment to undeclared variable bmBackedUp
Source file: chrome://febe/content/febe.js
Line: 1233

Warning: assignment to undeclared variable pdBackedUp
Source file: chrome://febe/content/febe.js
Line: 1239

After I made the preferance change, I didn't get these warnings.
FEBE is working now. Thanks for the info, and keep up the good wook.

Re: "Unresponsive script" post thread

Postby Lupo » Fri Oct 08, 2010 7:54 am


Suggestion for a solution here (maybe :wink:) :

Chuck Baker's Firefox Extensions Support Forum • View topic - Error code febe = febeZip.js = talse =! false :

Solution for "A script on this page may be busy, or it may have stopped responding. You can stop the script now or you can continue, to see if the script will complete" :

"(...)\extensions\{4BBDD651-70CF-4821-84F8-2B918CF89CA3}\chrome\febe.jar\content\febeZip.js" line 62

Can you change the code of febe to save 5 files and then save the current position for "var entries = aFile.directoryEntries;" line 61 and then close the process "while(entries.hasMoreElements()){ (...)" line 62, then reopens the process "while(entries.hasMoreElements()){ (...)" line 62 with restoration for the last position for "var entries = aFile.directoryEntries;" line 61 and save 5 files AND REPEAT the procedure described above. Thus, the process does not freeze Firefox ... Customize this trick to what works :mrgreen: ! Thank you very much.

memo code febe = febeZip.js ; line 60 to 109 :
Code: Select all
        var entries = aFile.directoryEntries;
            var entry = entries.getNext();
            var src = entry.path;
                zip(src);    //Recurse!
                var file = src.substring(root.length+1);;
                if(absolutePath) file = src;
                file = file.replace(/\\/g,"/");
                // Ignore locked files
                if(file == "parent.lock"){continue;}
                if(file == "lock"){continue;}
                //if(file == "places.sqlite-journal"){continue;}
                if(file == "places.sqlite-stmtjrnl"){continue;}
                //if(file == "places.sqlite-journal"){continue;}
                //if(file == "cookies.sqlite-journal"){continue;}
                var jrnl = file.lastIndexOf(".sqlite-journal");
                if(jrnl > 0 && (file.length - jrnl == 15)){continue;}    // Ignore everything that ends with ".sqlite-journal"
                    zipW.addEntryFile(file, Ci.nsIZipWriter.COMPRESSION_BEST, entry, false);
                    if(e.toString().indexOf("NS_BASE_STREAM_CLOSED") != -1){continue;}
                    if(e.toString().indexOf("NS_ERROR_FILE_ALREADY_EXISTS") != -1){
                        zipW.removeEntry(file, false);
                        zipW.addEntryFile(file, Ci.nsIZipWriter.COMPRESSION_BEST, entry, false);
                    if(e.toString().indexOf("NS_ERROR_NOT_INITIALIZED") != -1){
                        var style = "<style>color: red;font-size: 10pt;</style>";
                        var tmp = style+febeMsg[276]+"\n\n";
                        style = "<style>color: black;font-size: 8pt;</style>";
                        tmp += style+src+"\n\n"
                        tmp += febeMsg[277];

                    var msg = febeMsg[53].replace(/%FILE%/,file);
                    return false;

thank you.
Posts: 20
Joined: Sun Dec 07, 2008 12:59 pm

Re: "Unresponsive script" post thread

Postby tomsoltu » Thu Nov 11, 2010 5:19 pm

Sort of "reprise" from may..
Several profiles, differently configured. I ran FEBE manually each time, identically configured in each profile (details possible, if wanted), full profile backup
Excerpts of observations are from "step1 - playing with dom.max_chrome_script_run_time"

That FF script warning here everytime sounds identically "Skript: chrome://febe/content/febeZip.js:62". (Not only "script..maybe busy.. and so on)
No errors in console.
FEBE window covers/overlaps that incrimiated FF script warning anytime
When FEBE window becomes responsive again after firing up, it is possible/necessary to move the FEBE window elsewhere to come in sight of that
FF script warning to be able to click "proceed" in order to be astonished it finishes immediately after this measure.
BUT: In several occurences, that FF script warning does NOT come in sight by moving FEBE window, but only by cancelling FEBE, thus having to hit "stop script" and having no finished backup (as a workaround without tinkering with about:config)

Now my tests:
Profile "test" 2Tabs
value20 NO
value60 YES scriptwarning visible by moving FEBE window->continue->finish immediately
(didn´t raise value further)
value60 YES without user interaction

Profile "TR_Admin_Basic_Default"
value20 YES scriptwarning NOT visible by moving FEBE window->Trick ticking "Extras" in other window->visible->continue->finish immediately
(that "trick" seems to work accidentally/not, at least in this profile)
value60 YES without user interaction

Profile "TR_Admin_TV" some 20 tabs
value20 NO scriptwarning not visible->cancel
value20 deactivated: surf&catch 1.4.7400 scriptwarning visible by moving FEBE window->continue->finish
value20 reactivated: surf&catch scriptwarning visible by moving FEBE window (-> not reproducible, was just some thought..)
value60 not tested
value20 YES scriptwarning visible by moving FEBE window->continue->finish immediately
value60 YES without user interaction

Profile "TV_Basic_solo" some 10tabs
value20 YES scriptwarning visible by moving FEBE window->continue->finish immediately
value60 YES without user interaction

Profile "TR_Admin_local_FF3" some 150tabs (I know...)
value20 NO (former, not actually tested),
value60 NO scriptwarning not visible by moving FEBE window->cancel
value60 NO scriptwarning not visible by moving FEBE window->Trick ticking "Extras" no help (even that other window/the tabs are greyed out in whole)
->cancel FEBE->warning becomes visible immediately
value 0 YES without user interaction ->showed time elapsed 350seconds(!! did not take care of the other elapsed time messages)
value420 YES without user interaction

That last profile is 150tabs actually, caching 500MB (real size at this moment 850MB, don´t know why, will investigate, but doesn´t interfere with/affect FEBE effect, I think.)
Saved profile is 800+MB, so maybe including all the cache have an effect either. Saving cache if not flushed is redundant and should be excluded, anyway.

Day1: Vista uptime 5days, "ironed out"
Day2: Fresh boot, waiting all startup stuff having finished and Microsoft patches have come to quiet state.

IF I was able to grab that ?modal dialog? script warning and to click "proceed" when hanging at line 62 of zip routine, any and every FEBE backup finished immediately (and showed elapsed time in (chosen) report)
(What´s happening at line 62, no clue, see pre-poster)
Question is: Why in some occurences is it impossible to "see" that script warning, and why is that greyed out main window/tabs. At least it would be possible to get a finished backup although that script warning (IN FLAVOUR zip.js) pops up.
(Any flavours other that zip.js:62 never happend HERE, maybe somewhere other, so you may change some content in your sticky to get more specified information from following posters)
Having it finishig manually as a working workaround sounds and is better to me ecause of raising that dom.max stuff causes any and every hanging scripts to have that chosen delay before showing up and giving ability to cancel it....

Hope this helps
(Did not read posts since my last posting, just stopped by; let me know if more testing or so is appreciated)


Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 12 guests