FEBE 7 beta releases

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

FEBE 7 beta releases

Postby cbaker_admin » Mon Aug 09, 2010 4:31 pm

Please do not enter new posts to this thread ... it is getting way too long and I'm bound to miss some entries. Please start a new thread in the FEBE/CLEO forum that describes your particular issue.

FEBE 7.0beta releases for Firefox 4.0 and 5.0 are available here. The early betas are likely to contain some bugs that I missed so I'm depending on users like yourself to help debug.
cbaker_admin
Site Admin
 
Posts: 4342
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE7.0b201008081616

Postby streetwolf » Wed Aug 11, 2010 1:16 pm

Can't seem to save user defined files. There is no post button as help says there should be.


Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100810 Minefield/4.0b4pre - Build ID: 20100811040838
streetwolf
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Wed Aug 11, 2010 1:44 pm

You're right. I'll find out where the buttons went and post an update. Thanks!
Chuck
cbaker_admin
Site Admin
 
Posts: 4342
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby fgump » Fri Aug 13, 2010 11:59 am

Hi Chuck. Thanks for the v7 beta release!

Bugs that I found so far (if you can confirm) using FF4b3
1). When I go to quick backup, there is nothing to select (Items to Backup is blank). I have plenty of addons installed, but doesn't seem to show anything. I hope the quick backup will be updated as per the wishlist forum (link posted below).
2). I started a backup and it just ran forever. Progress bar kept going and going, but it never completed. I had to abort.

Also, just wondering, as per our "wishlist" in the forum, will you be updating the quick backup feature as per

Code: Select all
http://www.customsoftwareconsult.com/phpBB2/viewtopic.php?f=5&t=1532&p=7029&hilit=fgump#p7029


Finally, it would be great to have a feature to "export" the FEBE settings and "import" them. Many addons have this capability and it sure would help migrating FEBE settings to v7 as well as from PC to PC in the past since FEBE is used/recommended to everyone I know! Please consider adding this (unless it's present and I've missed it all this time).

Thanks for all your hard work!

Best Regards,

FGump
fgump
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Fri Aug 13, 2010 2:25 pm

The Quick Backup seems to work for me. Are you getting any FEBE related error messages in the error console?

I haven't really addressed the changes listed in the FEBE 7 to-do list yet (yours is in there), but I will be looking into it now. My biggest concern was in getting version 7 "over the hump" and working at all in Firefox version 4 with all its asynchronous API changes.

As for the backup progress window running forever, did you clear FEBE preferences after installing version 7? I recommend this when upgrading any FEBE version (even though it is not always necessary, it is in this case). If that doesn't work, try looking for FEBE related errors in the error console just after a backup attempt.

While I don't have an option of export/importing FEBE preferences built in, there is another Fx extension that does just that. It's called OPIE and it can import/export nearly all your installed extension's preferences.

Thanks for helping in the debug process!
Chuck
cbaker_admin
Site Admin
 
Posts: 4342
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby fgump » Thu Aug 19, 2010 7:33 am

Thank you for the reply Chuck. This was a clean install of FF4b3 with FEBE 7 beta installed, but I went ahead and cleared the FEBE preferences. I still do not get anything to show up in the Quick Backup window. In fact under Advanced, when I select Verify Extensions directory, it comes up with a 0. Nothing found. Perhaps it's an extension I have installed that is causing the issue? Here are the add-ons I have installed.

Adblock Plus 1.22
AddBookMarkHere2 4.020100818pre
Add-on Compatibility Reporter 0.5.1 (for testing/reporting FF4b3)
Download Status Bar 0.97 (Disabled - incompatible)
FEBE 7.0b201008081616
Feedback 1.0.1 (for testing/reporting FF4b3)
Form History Control 1.2.6
IE Tab Plus 1.94.20100802
Java Quick Starter 1.0
Microsoft .NET Framework Assistant 0.0.0
Print/Print Preview 0.7 (Disabled - incompatible)
Send Link Button 0.6
Tab Mix Plus 0.3.8.5pre.100811a

I cleared the error console, ran the FEBE Perform Backup and checked the error console again and found this:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsILocalFile.initWithPath]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://febe/content/febe.js :: febeBackupBookmarksHTML :: line 1665" data: no]

Not sure if any of that helps? If there is anything else I can do to help, please let me know.

Thanks for telling me about OPIE, that is helpful. However, many extensions support exporting/importing their own settings. If you have time, it would be nice if FEBE could do it's own import/export rather than having to run yet another extension.

Best Regards,

FGump
fgump
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Fri Aug 20, 2010 2:05 pm

I'm very close to releasing the next FEBE v7 beta. It addresses some quirks I discovered in the quick backup routines as well as some other issues. Let's see if that one clears up your errors.
Chuck
cbaker_admin
Site Admin
 
Posts: 4342
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby streetwolf » Fri Aug 27, 2010 7:53 am

cbaker_admin wrote:I'm very close to releasing the next FEBE v7 beta. It addresses some quirks I discovered in the quick backup routines as well as some other issues. Let's see if that one clears up your errors.


Is there an ETA on the updated version?
streetwolf
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Fri Aug 27, 2010 1:34 pm

Since summer hiatus is over, I only really have the weekends to work on FEBE and my other extensions. But I do get a lot accomplished. I'm hoping that I'll have the next FEBE beta ready no later than the second week of September, 2010.
Chuck
cbaker_admin
Site Admin
 
Posts: 4342
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby AMG » Fri Aug 27, 2010 2:26 pm

Hi

I have Firefox-4.0b5pre and have FEBE{7.0b201008081616} installed.
When i in the FEBE setting this see:
Bild 1.jpg
Bild 1.jpg (74.34 KiB) Viewed 15836 times

then working no complette backup no end see this:
Bild 2.jpg
Bild 2.jpg (47.13 KiB) Viewed 15836 times


Then i select all then working FEBE backup complette !!! 8) 8) 8)

PS: Sorry my english is not good come from GERMANY !!! :D :D :D
AMG
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Wed Sep 01, 2010 3:45 pm

The next FEBE 7 beta should be available in a few days. Let's see how that works for you.
Chuck
cbaker_admin
Site Admin
 
Posts: 4342
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby AMG » Wed Sep 01, 2010 3:58 pm

cbaker_admin wrote:The next FEBE 7 beta should be available in a few days. Let's see how that works for you.


Thanks for Info i waiting and testing the next version !!! 8) 8) 8)
AMG
 

Re: FEBE 7 beta releases

Postby streetwolf » Sat Sep 11, 2010 6:09 pm

Well another new feature of Minefield is causing problems with FEBE 7. The latest hourly added JagerMonkey to Fx4. This feature speeds up Javascript.

There are a few new options in Prefs that control JM. One is called 'javascript.options.methodjit.chrome'. The default for this option is False. There doesn't seem to be any problems when it is set this way. However, when I set it to True Fx4 hangs when I start it up and I get this message:

A script on this page may be busy, or it may have stopped responding. You can
stop the script now, or you can continue to see if the script will complete.

Script: XStringBundle:20

I have to reply Stop in order to bring Fx4 up. If I disable FEBE 7 in my Add-Ons list there are no problems. Of all the add-ons I have FEBE 7 is the only one to cause this problem.

I suspect there is a reason the Mozilla team defaulted this option to False. But I'm sure it will be turned on in the near future so look at this as a heads up if you want.
streetwolf
 

Re: FEBE 7 beta releases

Postby kronckew » Sat Sep 18, 2010 3:10 am

using ff 4.0b7 x64, FEBE{7.0b201009171507}.xpi, win7 x64

on asking for a backup it gives me this error:

FILE NOT FOUND

febeZip: Could not find C:\Users\owner\AppData\Roaming\Mozilla\Firefox\Profiles\pedxin8a.64bit profile\extensions\{4BBDD651-70CF-4821-84F8-2B918CF89CA3}. Backup aborted.

backup does appears to complete, ie. there are the correct files in the destination folder, but the febe window never closes. tried clearing the profile. then tried checking the destination directory, it gives me errors that the xpi files in the profile on c: (as in error above) are invalid. going back into options, the 'advanced' items will not display. will have to restart firefox.

errors from check destination:

Verify complete with errors ... see log.
Do you want FEBE to attempt repairs? (OK for yes, Cancel for no)

continuing gives another error:

[Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)
[nsILocalFile.remove]" nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)" location: "JS frame
:: chrome://febe/content/febeVerifyext.js :: febeDeleteInvalidExt :: line 494" data: no]

*** UNEXPECTED ERROR ***
C:\Users\owner\AppData\Roaming\Mozilla\Firefox\Profiles\pedxin8a.64bit profile\extensions\cache@status.org.xpi
kronckew
 

Re: FEBE 7 beta releases

Postby streetwolf » Sat Sep 18, 2010 6:08 am

Correct me if I'm wrong Chuck. It is my understanding that add-ons running under Fx4 x64 require 64 bit add-ons. FEBE is 32bit.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100917 Firefox/4.0b7pre - Build ID: 20100918041933
streetwolf
 

Next

Return to FEBE/CLEO

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests

cron