FEBE 7 beta releases

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

Re: FEBE 7 beta releases

Postby tomorrow » Sun May 01, 2011 5:47 am

Beta 3 seems to work as good as the previous ones for me.Just one small thing.I noticed ( when comparing active and backed up profile ), that urlclassifierkey3.txt is not backed up.It is not in the ignore list and phising DB entry is grey because it resides in the /AppData/Local instead of main profile.But still this file could be backed up because it is in the profile folder regardless and it's a small text file that won't add time to backup completion.

When i comes to size the backup is actually bigger when extracted because it includes some files that are only in profile when firefox is running.Still compressed it is about 1/3-rd of the real size.In my case ~10MB of ~30MB .

Small question regarding this.Would it be possible or make sense to include option for the user to select the compression ratio of the backup file?
In my case i don't have much use for it so i could disable it but someone with a very big profile could enable maximum compression to get a smaller file (at the expense of backup time ofcourse).
I assume the current setting is neither no compression nor maximum copression but rather some middle-of-the-road option that provides reasonable compression without affecting backup time too much?.
tomorrow
 
Posts: 32
Joined: Wed Oct 14, 2009 9:25 am

FEBE 7 Beta3 4-29-11 Dialog Hangs

Postby Mike » Sun May 01, 2011 6:39 pm

(Post moved, by me, to what seems a more suitable location)

I updated from the latest Firefox v3.x.x, yesterday (4/29/11), to Firefox 4.0.1.
Running on Windows 7 Ultimate x64 SP-1

Installed FEBE 7 Beta3 4-29-11 over the previously installed FEBE 6.3.3.2

Problem: FEBE hangs on the Backup Progress Dialog.
Dialog Information: Backup Type Selective - Preparing Results Page...

Dialog just keeps showing the green progress indicator until the ABORT Button is pressed.
The Results Page tab is not created in the browser.
After aborting and then checking the backup Folder, the backup is there.
There is no 'Results.html" file present.

The Error Console/Debug message is:
Error: febeBuItemVerifiedList[key] is undefined
Source File: chrome://febe/content/febe.js
Line: 778
This line reads:
if(febeVerifyBackups == true) item.verified = febeBuItemVerifiedList[key].verified;

Get identical reproducible error every time no matter what I have tried.

Have tried disabling every add-on installed except for FEBE itself - no difference.

Update:
Going to FEBE OPTIONS->ADVANCED->Press "CLEAR FEBE PREFERENCES" solved my problems.
Even though previous version was not a beta. I was under the impression this only had to be done if installing a new FEBE Beta over an older Beta.
This is obviously wrong (very likely a misunderstanding on my part :idea: )
I then tried to import my old preferences, which only caused my problems all over again.
Instead, I Cleared All FEBE Preferences and just set all the preferences from scratch, saved, tried a backup and all went well.
I then exported these preferences, cleared my preferences again, and re-imported these new preferences.
Everything (that I noticed) worked like it should.
Last edited by Mike on Sun May 01, 2011 8:05 pm, edited 1 time in total.
Mike
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Sun May 01, 2011 7:09 pm

Have you tried clearing FEBE preferences (FEBE Options > Advanced)? Also make sure the preference extensions.febe.verifyBackups in about:config is set to false. (In fact, there is no Verify Extensions in FEBE 7. It is an artifact from v6.3.)
Chuck
cbaker_admin
Site Admin
 
Posts: 4568
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby brucea » Sun May 01, 2011 7:49 pm

Hi Chuck,

I've tried clearing FEBE preferences and an uninstall/reinstall of FEBE 7.0beta3 (with FF 4.0.1) but I still get "Extension data is still loading ... try again in a few seconds" and no backup. With the following in the error log

Warning: WARN addons.manager: Exception calling callback: [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIFile.append]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: chrome://febe/content/febeCommon.js :: <TOP_LEVEL> :: line 485" data: no]
Source File: chrome://febe/content/febeCommon.js
Line: 485

Any clues what I could try next?

Regards, Bruce.
brucea
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Sun May 01, 2011 8:10 pm

It looks like AddonsManager module is reporting an incorrect GUID from some extension. Tomorrow I will write some code for that function that will display what's going on. I'm thinking it's a particular extension that is causing this for many FEBE users. I haven't been able to duplicate the problem yet, but if we can figure out the root cause of why the AddonsManage stalls, I can finally get it fixed.

I'll post here when I've got the special debug version ready.
Chuck
cbaker_admin
Site Admin
 
Posts: 4568
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby brucea » Sun May 01, 2011 8:47 pm

cbaker_admin wrote:It looks like AddonsManager module is reporting an incorrect GUID from some extension....


Ah ok. With that tip I've disabled extensions until I found the one that lets FEBE work again. And in my case it's Netusage 1.2.314 (http://netusage.iau5.com/).
brucea
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Sun May 01, 2011 9:12 pm

Yep ... installed that extension and it borked FEBE. Finally something I can debug with. Thanks!
Chuck
cbaker_admin
Site Admin
 
Posts: 4568
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby brucea » Sun May 01, 2011 9:17 pm

cbaker_admin wrote:Yep ... installed that extension and it borked FEBE...


Oh good news. I've reported the issue in the Net Usage thread on Whirlpool that the Net Usage author monitors.
http://forums.whirlpool.net.au/forum-re ... &p=34#r680
brucea
 

Re: FEBE 7 beta releases

Postby lvsunz » Tue May 03, 2011 8:46 pm

I'm using FEBE 7.0beta3 under Windows 7 Pro, 64 bit. Problem I'm experiencing:

FEBE displays "preparing results page" but it never does- it just keeps going as if in an infinite loop. Error message: "could not find location of Roboform Toolbar for Firefox (7.2.5.xpi)- item skipped."

Backup Type: selective & full profile.
lvsunz
 

Re: FEBE 7 beta releases

Postby markg2 » Wed May 04, 2011 4:12 am

I confirmed that beta3 hangs on backup. I'm now using FEBE7.0b201102281630.xpi (February 28, 2011) pending a beta 4

Mark
markg2
 

Re: FEBE 7 beta releases

Postby lvsunz » Wed May 04, 2011 10:18 am

Thanks Mark.
lvsunz
 

Re: Extension "Could not find" - skipped

Postby MoxieMomma99 » Sat May 07, 2011 7:08 am

Hi:

Just installed v.7.0 beta3 on a clean profile of a clean install of FF 4.0.1 on a Win7(x86) platform.
Seems to be working fine EXCEPT:

I am getting the error message that it "cannot find the location" of the Webroot malicious URL fitering v. 1.0" extension --> skipped.

This had worked fine with FEBE 6 on FF 3.6.17 (and earlier), as recently as this morning.


What I tried:
1) turning off "run asynchronously:, which had no effect.
2) the"verify directory" trick, but no error was detected and no offer to "repair" was generated.

I will mention that Webroot ISE *did* install a minor software update (not just a definitions database update) earlier today, but I had rebooted the system several times before installing FF4 and FEBE 7. So, I don't think that is contributing to the issue.
It seems that this particular extension isn't being "found" by the new FEBE...

Any other suggestions?
Is there some sort of log file I can send to assist in troubleshooting?

Thanks!

MoxieMomma99

Update:
Polite bump for skipped extension on Win7(x86) laptop, please.
Do you need additional info or logs to assist with troubleshooting?
I think the FEBE options are configured correctly, as they are the same as with v6 on FF 3.6.x.
Everything is working fine on Win7(x64) desktop, but the particular extension in question is only installed on the laptop, as it relates to that rig's AV suite.
Thanks much.
Last edited by MoxieMomma99 on Mon May 09, 2011 3:38 am, edited 1 time in total.
MoxieMomma99
 

Re: FEBE 7 beta releases

Postby TomSoup » Sat May 07, 2011 1:18 pm

Hi,

Love this app' & couldn't wait any longer for the release proper to complement my Firefox 4, so downloaded & installed version 7.0.3 over the previous version (which had it's preferences reset to default).

My problem was immediately apparent in that when I opened the options window in order to reset my preferences the top section of the window was missing,- somewhere off screen, so could not see tabs in order to set all preferences, couldn't re-size in order to see tabs & also couldn't close the window except by using the 'OK' button at the bottom of the options window, & although the bottom of the window was visible that 'OK' button was only just visible above the border.

I tried closing & restarting Firefox several times, shutting down & re-booting, removing the app' & then re-installing, but no joy.

The only other extensions that were active were Java console 6.0.24, Babel fish 1.94 and British English Dictionary 1.19.1.

I'm a completist so if I can't set preferences I won't use the basic facility.

Had a quick skim through the prev' posts & didn't see any similar problem so presume it's something my end, any ideas out there?
Attachments
problem FEBE Options window.jpg
problem FEBE Options window.jpg (94.65 KiB) Viewed 13770 times
TomSoup
 

Re: FEBE 7 beta releases

Postby Earthlingmind » Sat May 07, 2011 1:55 pm

I've just joined this forum. I use FEBE to restore my FF profile(s) almost daily, since I'm using PCs in almost itinerant fashion. Was always having "script busy" delays with previous versions of FEBE. The notification would sometimes hide behind the FEBE progress window, until I found the solution was to maximise that and then maximise the main FF window in front of it: then the script notification would appear in front of that (no longer hidden).

Managed well with FEBE 6.3.3.2 in Firefox 3.6.15. But then FF updated to 4.0 and FEBE no longer on Mozilla's list! Thankfully found FEBE 7.0beta1 on the Homepage and no longer having that script hanging trouble. Much faster, too.

Just one bug I find with the beta1: each time I restore a profile about a third of my add-ons are disabled as being incompatible with FF 4.0 (and now 4.01) until I run the add-on update thing. Then those add-ons become rendered available to be enabled via a browser restart, along with the updated ones (if any).

Now tried FEBE 7.0beta3, which seems to do the profile backup, but the progress window never closes. So I'll rely on the beta1 for now.

Here's a list of the Firefox extensions that are disabled as being incompatible after restoring my present Firefox profile containing them:-
• Blacken 1.4.3
• ColorfulTabs 4.8.1.6.2.1
• ColorResults 3.1
• EasyAccent 0.65
• Facebook Photozoom 1.9
• Flashblock 1.5.14.2
• Groowe Search Toolbar 1.6.9
• Image Zoom 0.4.6
• Multiple Tab Handler 0.6.2011020301
• Read It Later 2.1.1
• Screengrab 0.96.3
• SmoothWheel (AMO) 0.45.6.20100202.1
• Teak Network 1.5
• YouTube Comment Snob 1.5.1
Earthlingmind
 

Re: FEBE 7 beta releases

Postby Earthlingmind » Mon May 09, 2011 1:45 pm

Chuck

I've tried the beta3 with my 2 largest FF profiles - 2 profiles in FF4.0.1 that have the largest number of extensions. I've restored both of them using FEBE7.0beta3. One has restored OK, while the other restores fully except for requiring me to click the Tools button in Add-Ons Manager and "Check for Updates", then restart to restore compatibility to about a third of my Add-Ons, regardless of whether they are actually out-of-date or not. That's the same as for the beta1, as I described yesterday (with list of the Add-Ons that don't immediately restore as compatible).

Both profiles do back-up OK with beta3, except that the Progress window won't finish in the one with the bug: it can't seem to make the Results Page file. FEBE7.0beta1 does the back-up OK, though.
Earthlingmind
 

PreviousNext

Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 5 guests

cron