Page 18 of 18

Re: FEBE 7 beta releases

PostPosted: Thu Jun 23, 2011 4:51 pm
by cbaker_admin
goldencomet wrote:I'd like to use my dear FEBE with Nightly 7.0a1. Can you help me ?


You'll need a utility like 7-zip that can edit .zip files directly. Open the archive (FEBE7.0beta6.xpi) and edit the file named "install.rdf". Change the line that reads:

Code: Select all
<em:maxVersion>5.*</em:maxVersion>
(should be line 27 or thereabouts) to

Code: Select all
<em:maxVersion>7.*</em:maxVersion>

(or whatever the allowable max version is for the nightly).

Save the changes and install the xpi through File > Open file...

Re: FEBE 7 beta releases

PostPosted: Thu Jun 23, 2011 5:38 pm
by cbaker_admin
darkeforce wrote:Could not backup extension/theme RealPlayer Browser Record Plugin - skipped
Could not backup extension/theme Java Console - skipped


This is normal. The RealPlayer program is not an extension per se, but a plugin. Same with Java Console. If the FEBE Options > What to backup > Ignore list is working for you (there are still a few bugs), you can have FEBE skip them.

Additionally, when I try clicking the "Check AddonManager compatibility", I'm getting red text at the end of the pop-up that appears. I don't know if this is a problem or not

Addon with GUID of 6329@personas.mozilla.org is reported by AddonManager but does not have an entry in the extensions directory
Addon with GUID of 362943@personas.mozilla.org is reported by AddonManager but does not have an entry in the extensions directory
Addon with GUID of {ABDE892B-13A8-4d1b-88E6-365A6E755758} is reported by AddonManager but does not have an entry in the extensions directory
Addon with GUID of 1 is reported by AddonManager but does not have an entry in the extensions directory
Addon with GUID of 2 is reported by AddonManager but does not have an entry in the extensions directory


There is a known bug with the Check AddonManager function that does not recognize personas. Tha explains the first two items. The others look like some leftover artifacts from upgrading Fx. Can you see them in Tools > Add-ons? You could also try running Verify extensions directory in FEBE Options > Advanced and let FEBE remove them.

Also, just to remind you, clicking the FEBE icon -> FEBE Options and TOOLS -> FEBE -> FEBE Options creates a non-functional, blank options window that cannot be closed by clicking "OK". The only way to get a functional options window is to open it from the Addons Manager window/sidebar.


I've been unable to duplicate this, but I'll keep looking for possible reasons.

Re: FEBE 7 beta releases

PostPosted: Fri Jun 24, 2011 6:43 am
by TXGuy
darkeforce:

It is possible that your extensions files have been corrupted. See the following link from Firefox Support. The procedure will not affect/delete your extensions. The 3 files mentioned will be re-built from your installed extensions when re-start Firefox.

See: https://support.mozilla.com/en-US/kb/Un ... sion-files

Also, the following extension, if you do not have it, will list each extension's name, GUID and other information about your extensions. I have it installed and it works great. It adds a "Dump List" option to the Add-ons display and the newest version adds "Dump List" to the "gear" drop-down in Firefox 4 and Firefox 5 in the Add-ons display.

See: https://addons.mozilla.org/en-US/firefo ... st-dumper/

Re: FEBE 7 beta releases

PostPosted: Fri Jun 24, 2011 4:47 pm
by bobprimak
ABOUT JAVA PLUGINS AND EXTENSIONS

I solved the vexation of Java in Firefox -- the plugins are not under the control of Firefox, and haven't been in a few Java Updates. They are under the
control of Java Runtime Environment (JRE). When you update Java JRE, you must go into an Administrator mode, open the Java Control
Panel>>Advanced, and expand the Java options which relate to the Browsers, any Plug-ins, and the Java QuickStarter. To play it safe, disable
(uncheck) all Mozilla or global items in these areas. Then update Firefox. Afterwards, if nothing goes wrong, you can re-enable the Java QuickStarter,
as this may affect more than just Firefox, and maybe let the other settings be checked (enabled), as this does no harm that I know of. With the Mozilla
Plug-in for the Java Console unchecked, Firefox shows (in my computer) no Java Extensions whatsoever except for Java QuickStarter. (And even
this one can be disabled as I have already shown.) The point is, Firefox does not control these Extensions -- Java Runtime controls them. And when
one version (say, Update 25) is removed, thereafter it will be impossible to remove the associated Java Extensions from Firefox without some major
Windows Registry hacking. (If even that would work.) Be proactive about this and you will not have the Firefox annoyance of multiple, inactive Java
Extensions again (with a bit of luck, eh?).

As noted frequently in this thread, these Java Extensions are really Plug-ins, and as such cannot be backed up nor restored with FEBE. And that's the way I like it. Add these to the FEBE Ignore List. I have MOVE Player from ABC-TV, and it's the same way.

Re: FEBE 7 beta releases

PostPosted: Fri Jun 24, 2011 8:26 pm
by tux.
FEBE 7 (latest beta), Firefox 5 Aurora:
The last open FEBE options' tab when closing FEBE will be empty after reopening it. Reproducible.

Re: FEBE 7 beta releases

PostPosted: Mon Jun 27, 2011 7:01 am
by modem
Hi Chuck,

I updated FEBE to beta 6 under FF5 and Windows XP. Did you change anything in the options window size? It is now really big, it takes all my vertical resolution (1440x900), the OK button is partially behind the toolbar. And I can't reduce it's size manualy, it seems the window in now not sizeable (it was before).

Regards.

Re: FEBE 7 beta releases

PostPosted: Mon Jun 27, 2011 7:12 am
by tomorrow
bobprimak wrote:ABOUT JAVA PLUGINS AND EXTENSIONS

Just delete the {CAFEEFAC-0015-0000-0006-ABCDEFFEDCBA} folder under Program Files/Mozilla Firefox/extensions
That gets rid of the annoying Java Console that can't be backed up.

Re: FEBE 7 beta releases

PostPosted: Wed Jun 29, 2011 3:56 pm
by cbaker_admin
AMG wrote:Here my .fbu file --->
HTTPSEverywhereUserRules{default}.zip
!!!

It looks like the reason the restore is not working is because of international characters in the filenae (i.e., "B├╝romarkt.xml").

I filed a Mozilla bug report three years ago, but it looks like they are in no hurry to fix it. :?

Re: FEBE 7 beta releases

PostPosted: Wed Jun 29, 2011 7:15 pm
by TXGuy
Chuck,

I had a problem this morning during backup (FEBE 7beta6, Firefox 5). I had one of those "no-restart" add-ons update (I manually do updates first thing every morning) and got an error message from FEBE during a scheduled backup about that add-on; I did not re-start Firefox 5 as that was not shown in the Add-ons display and I assumed everything would be OK. After restarting Firefox later, I got the reminder about it being more than one day since a backup, chose to let it proceed and everything backed up OK. Sorry I did not capture a copy of the "slide up" message nor did I get any Error Console information as I needed to leave quickly for an appointment.

If this happens again, what information would you like for me to post for your analysis?

All previous problems that I posted in this thread have been resolved with the newer beta versions.

Re: FEBE 7 beta releases

PostPosted: Wed Jul 06, 2011 7:32 am
by goldencomet
Hi, Chuck Baker.
Many thanks for your help.
Now my FEBE is running again !
The biggest good luck for you dear friend.
See you next time.

Re: FEBE 7 beta releases

PostPosted: Wed Jul 06, 2011 7:59 am
by tomorrow
TXGuy wrote:Chuck,

I had a problem this morning during backup (FEBE 7beta6, Firefox 5).

Beta 7 is available btw ;)

Re: FEBE 7 beta releases

PostPosted: Mon Aug 15, 2011 9:13 am
by vinograd
Chuck,

Need a new release that is compatible with FF 6.

Thanks,

Dave

Re: FEBE 7 beta releases

PostPosted: Mon Aug 15, 2011 1:52 pm
by TXGuy
FEBE 7.0.1 has been working well for me in the Firefox 6betas with Add-on Compatibility Reporter installed: https://addons.mozilla.org/en-US/firefo ... -reporter/

Re: FEBE 7 beta releases

PostPosted: Tue Aug 16, 2011 5:44 am
by Bench
Dear Chuck,

1/ Sorry for my english...I am French
2/ Your add-ons should be mandatory and added to Firefox core (yeah I know, I am a bit overzealous...)
3/ In order to have 7.0.1 fully compatible, you might want to change the lines <em:maxVersion>5.*</em:maxVersion> to <em:maxVersion>9.*</em:maxVersion> in the install.rdf file (carefull not to mistake it with the !install.rdf.

Phil