FEBE 7 beta releases

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

Re: FEBE 7 beta releases

Postby cbaker_admin » Thu Oct 14, 2010 9:08 am

@Gavin77 - This appears to be a *nix thing. Just tried a backup using my Ubuntu VM and experienced the same problem (Windows Vista works fine). I get a full profile backup along with individual items like bookmarks, cookies, etc., but no extensions/themes. Will start debugging it today.

@jlyst - Are you getting any FEBE related errors in the error console? Also, I have to wonder about the efficaciousness of restoring Fx 3.6 preferences into a Fx 4 installation. Is it wise? I don't know for sure, but I would imagine there are some tweaks that get changed during a major upgrade. Also, are you experiencing the same issues as Gavin77 in regards to backing up extensions/themes? I know that Mac and *nix are similar in many respects.
Chuck
cbaker_admin
Site Admin
 
Posts: 4571
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby streetwolf » Sun Oct 17, 2010 3:40 pm

Chuck... Still having the problem, using Selective backup, where my extensions are not being backed up but the other stuff is. Sometimes it works, sometimes it doesn't. I'm using the latest beta.

Also the 'verify backups' option is grayed out for me as are 'backup userchrome files' and 'backup usernames and passwords' . I also tried running a backup with no progress display and nothing was backed up.


Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101013 Firefox/4.0b8pre - Build ID: 20101013173441
streetwolf
 

Re: FEBE 7 beta releases

Postby kjdem » Wed Oct 27, 2010 9:51 am

Similar issues with latest build of FEBE. Windows x64 / FF4b6

I have a backup scheduled weekly. It should be backing up extensions

FEBEoptions.png
FEBEoptions.png (15.14 KiB) Viewed 15502 times


The backup seems to run but the results do not include any extensions.

FEBEresults.png
FEBEresults.png (64.22 KiB) Viewed 15502 times


I have tried clearing preferences, uninstalling and reinstalling - no change.
If I run a manual backup, result is the same.
If I run a quick backup, initially there is nothing listed - I select get list and select all (all extensions are then listed and selected) but when it runs I get the error:

FILE NOT FOUND
febeZip: Could not find C:\Users\[username]\AppData\Roaming\Mozilla\Firefox\Profiles\[profile]\extensions\testpilot@labs.mozilla.com. Backup aborted.

Nothing appears in the error console for any of these attempts. Anything else I should be trying?

KJ
kjdem
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Wed Oct 27, 2010 5:25 pm

Do you have the actual TestPilot extension installed? If you're using Fx 4.0 beta (which I'm sure you are), you don't need it installed. Try uninstalling it and see what happens.

When doing a quick backup, the screen is supposed to be blank until you click the "Get list" button. (It has to do with the new asynchronous threading in Fx 4).
Chuck
cbaker_admin
Site Admin
 
Posts: 4571
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby AMG » Thu Oct 28, 2010 6:02 am

Hello

I have FEBE7.0b201010121030.xpi on my FF 4.0b8pre 64 Bit and no correct working !!!
settings:
Bild 1.jpg
Bild 1.jpg (83.49 KiB) Viewed 15495 times


and result:
Bild 2.jpg
Bild 2.jpg (83.24 KiB) Viewed 15495 times


No Backups my Plugins Why ???
Bild 3.jpg
Bild 3.jpg (154.32 KiB) Viewed 15494 times


:( :( :(
AMG
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Thu Oct 28, 2010 6:14 pm

Does your backup destination directory contain any international characters? It doesn't appear to from looking at your results report, but I want to make sure. I don't know if this would cause any problems, but I want to make sure.

I've made a few minor changes to the backup routines in the version I'm currently working on. Right now it contains some unfinished functions for handling personas and box.net upload/downloads, but the extension/theme backup routines seem to be working for me. Try running this unreleased beta version to see if it makes any difference.
Chuck
cbaker_admin
Site Admin
 
Posts: 4571
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby AMG » Thu Oct 28, 2010 9:49 pm

Ok i waiting for next version i come from GERMANY DE !!! :D :D :D
I have new 7.0 unreleasedbeta installed see Video !!! :( :( :(
http://www.youtube.com/watch?v=V60rtHY0Zhs
AMG
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Fri Oct 29, 2010 6:50 am

Georg, I cannot read the error message in the video. Please use the "Copy to clipboard" button in that message window to paste the entire error message here.
Chuck
cbaker_admin
Site Admin
 
Posts: 4571
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby AMG » Fri Oct 29, 2010 7:45 am

Here is it !!! :D :D :D

Code: Select all
FILE NOT FOUND

febeZip: Could not find C:\Users\GEORG\AppData\Roaming\Mozilla\Firefox\Profiles\6hztvnzo.default\extensions\{F17C1572-C9EC-4e5c-A542-D05CBB5C5A08}.  Backup aborted.   
AMG
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Fri Oct 29, 2010 1:09 pm

The guid "{F17C1572-C9EC-4e5c-A542-D05CBB5C5A08}" seems to belong to the Download Accelerator Plus extension. I don't see it offered on AMO, though. Is it a valid extension?
Chuck
cbaker_admin
Site Admin
 
Posts: 4571
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby cbaker_admin » Fri Oct 29, 2010 5:21 pm

I just checked. The Download Accelerator Plus (DAP) extension does not install itself in the normal Fx extension directory. Instead, it is installed in C:\Program Files (Windows). There is no easy way FEBE can find extensions that are installed in some arbitrary folder.

I will be including a new "Ignore list" function in the next beta. Here you can checkbox any installed extension and have FEBE ignore it during backup.
Chuck
cbaker_admin
Site Admin
 
Posts: 4571
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby AMG » Fri Oct 29, 2010 11:00 pm

cbaker_admin wrote:I just checked. The Download Accelerator Plus (DAP) extension does not install itself in the normal Fx extension directory. Instead, it is installed in C:\Program Files (Windows). There is no easy way FEBE can find extensions that are installed in some arbitrary folder.

I will be including a new "Ignore list" function in the next beta. Here you can checkbox any installed extension and have FEBE ignore it during backup.


Yes i have DAP 9.5.0.3 Beta and see the FF folder is in my Installfolder:
Bild 3.jpg
Bild 3.jpg (39.57 KiB) Viewed 15472 times


I have testing and have the DAPFIREFOX all new ziped and rename to xpi and new installing and new starting FEBE and working perfect see:
Bild 5.jpg
Bild 5.jpg (226.4 KiB) Viewed 15470 times


and waiting for next Beta testing !!! :D :D :D
AMG
 

Re: FEBE 7 beta releases

Postby kjdem » Wed Nov 03, 2010 9:06 am

Sorry for the delay in response. Test pilot is not installed. I have also created a new profile with Febe as the only extension and got the same results.

KJ
kjdem
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Wed Nov 03, 2010 3:56 pm

kjdem, take a look in your profile/extensions folder and post a list of what resides there.
Chuck
cbaker_admin
Site Admin
 
Posts: 4571
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby kjdem » Sat Nov 06, 2010 8:53 am

This is the report from FEBE - it matches what is found in the profile/extension directory (except for the 2 Java entries which are in the default program files directory). The second, smaller group of addons are "incompatible with Firefox 4.0b6" but appear to be functioning correctly and have been disabled/removed while trying to resolve the FEBE issue.

checkplaces @ andyhalford.com CheckPlaces - OK
compatibility @ addons.mozilla.org Add-on Compatibility Reporter - OK
firebug @ software.joehewitt.com Firebug - OK
firefox @ ghostery.com Ghostery - OK
firefox @ red-cog.com Embedded Objects - OK
wappalyzer @ crunchlabz.com Wappalyzer - OK
{0538E3E3-7E9B-4d49-8831-A227C80A7AD3} Forecastfox Weather - OK
{0545b830-f0aa-4d7e-8820-50a4629a56fe} ColorfulTabs - OK
{1018e4d6-728f-4b20-ad56-37578a4de76b} Flagfox - OK
{3541c267-2580-4144-854e-2e05c8670121} Stay-Open Menu - OK
{37E4D8EA-8BDA-4831-8EA1-89053939A250} PDF Download - OK
{4BBDD651-70CF-4821-84F8-2B918CF89CA3} FEBE - OK
{6AC85730-7D0F-4de0-B3FA-21142DD85326} ColorZilla - OK
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} Adblock Plus - OK
{d40f5e7b-d2cf-4856-b441-cc613eeffbe3} BetterPrivacy - OK
{dc572301-7619-498c-a57d-39143191b318} Tab Mix Plus - OK
{CAFEEFAC-0016-0000-0021-ABCDEFFEDCBA} Java Console - OK
{CAFEEFAC-0016-0000-0022-ABCDEFFEDCBA} Java Console - OK

aardvark @ rob.brown Aardvark - OK
CopyPlainText - Mehtuus Edition - Reloaded - OK
{446c03e0-2c35-11db-a98b-0800200c9a67} Favicon Picker 3 - OK
{655397ca-4766-496b-b7a8-3a5b176ee4c2} Searchbar Autosizer - OK
viewabout @ rumblingedge.com ViewAbout - OK
kjdem
 

PreviousNext

Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 10 guests

cron