FEBE 7 beta releases

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

Re: FEBE 7 beta releases

Postby cbaker_admin » Sat Nov 06, 2010 12:09 pm

Those Java items bother me. If they don't reside in the profile/extensions directory, FEBE can't/won't back them up. The next release will have better error trapping and an "ignore" list to have FEBE skip problematic extensions. It should be ready in a few days.

I got your message about not receiving notification emails. This has been happening a lot lately (especially on new registrations) and I haven't figured out what's happening yet. I've been using the same forum software package forever but maybe the last update fubared the email functions.
Chuck
cbaker_admin
Site Admin
 
Posts: 4571
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby kjdem » Sun Nov 07, 2010 9:02 am

The java entries are for the java console (Java SDK) and are installed in Program Files (x86)/Mozilla/Firefox/extensions/.

There should only be one (the most recent release) but for some reason Java's update does not clear the older version. I manually deleted the older extension.

KJ
kjdem
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Sun Nov 07, 2010 9:39 am

Thanks for the update.

BTW, I've made a few tweaks to the forum email settings. Are you getting notifications of new posts (like this one)?
Chuck
cbaker_admin
Site Admin
 
Posts: 4571
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby streetwolf » Sun Nov 07, 2010 3:00 pm

Chuck.

I've been using the unreleased beta for awhile now and all the backups I've done are complete. But the big problem now is when I try to restore an extension I get a Fx message that the file might be corrupt and the restore ends. Actually I've had this problem from way back. Even manually trying to restore gives me this message.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101107 Firefox/4.0b8pre - Build ID: 20101107111356
streetwolf
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Sun Nov 07, 2010 8:33 pm

What is the exact message? Also, could you upload one of the problem extensions somewhere where I can test it on my side?
Chuck
cbaker_admin
Site Admin
 
Posts: 4571
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby streetwolf » Mon Nov 08, 2010 7:48 am

cbaker_admin wrote:What is the exact message? Also, could you upload one of the problem extensions somewhere where I can test it on my side?


Hmmm.... seems to be working at the moment. I'll keep trying.

On a similar topic when a restore is done via FEBE you don't have an opportunity to cancel the restore. The AOM has an 'Undo' button you can use to undo an install but doesn't work with an FEBE restore. Should there be a way to cancel an FEBE restore in case you chose the wrong extension for example?

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101108 Firefox/4.0b8pre - Build ID: 20101108043306
streetwolf
 

Re: FEBE 7 beta releases

Postby kjdem » Tue Nov 09, 2010 10:02 am

Hi Chuck

No, I did not receive notification of your reply - just saw it this morning.

KJ
kjdem
 

Re: FEBE 7 beta releases

Postby AMG » Tue Nov 16, 2010 5:06 am

Hi

The new Version FEBE7.0b201011150930 working perfect !!! :D :D :D
AMG
 

Re: FEBE 7 beta releases

Postby Gavin77 » Tue Nov 16, 2010 7:03 am

I just tried out the new beta version with the following results:

'Full Backup' worked fine.
'Selective Backup' backed up only 16 of 28 extensions and none of my 3 themes.

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
FEBE{7.0b201011150930}
Gavin77
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Tue Nov 16, 2010 5:42 pm

@Gavin77
Do all your installed extensions/themes appear in the Quick Backup list and/or FEBE Options > What to backup > Ignore list? Does a Quick Backup work? Do the missing extensions/themes appear in the Results Report (either as erroneously listed as backed up or as skipped due to an error)? Does running FEBE Options > Advanced > Verify extension directory generate any errors?

Could you give me a list of some of the extensions that are not backing up?
Chuck
cbaker_admin
Site Admin
 
Posts: 4571
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby Gavin77 » Wed Nov 17, 2010 1:16 am

@Gavin77
Do all your installed extensions/themes appear in the Quick Backup list and/or FEBE Options > What to backup > Ignore list? Does a Quick Backup work? Do the missing extensions/themes appear in the Results Report (either as erroneously listed as backed up or as skipped due to an error)? Does running FEBE Options > Advanced > Verify extension directory generate any errors?

Could you give me a list of some of the extensions that are not backing up?


My installed extensions:
Image

The only ones that backed up are:
Add-onCompatibilityReporter{0.7}.xpi
BarTab{2.0}.xpi
BetterPrivacy{1.48.4.dev}.xpi
CookieMonster{1.0.5}.xpi
FEBE{7.0b201011150930}.xpi
Ghostery{2.4.1}.xpi
HideMenubar{4.0.20101011}.xpi
LastPass{1.70.0}.xpi
Omnibar{0.7.2.20100912}.xpi
PersonalMenu{4.3.2}.xpi
SaveFileto{2.1a2}.xpi
SortPlaces{1.6.9}.xpi
Stylish{1.0.11}.xpi
TextLink{3.1.2009110201}.xpi
Xmarks{3.8.7}.xpi
gTranslate{0.8}.xpi

Verify extensions shows no errors.
Quick backup shows all extensions as does the ignore list (only default theme is checked).
Gavin77
 

Re: FEBE 7 beta releases

Postby streetwolf » Thu Nov 18, 2010 2:04 pm

Hi Chuck.

I am also having problems backing up my extensions. Was working fine until yesterday. Note that I am an hourly/nightly user of Minefield Fx4.

I was only backing up about 5 out of 13 extensions. I then noticed that there was a folder in the extensions folder called Trash. It contains copies of old extensions created when you install a newer version. On a hunch I deleted it and ran FEBE again and it backed everything up. Sadly, the second time it did not and the Trash folder was not present.

The number of extensions that get backed up vary from run to run. Wonder if the Trash folder is involved.
streetwolf
 

Re: FEBE 7 beta releases

Postby AMG » Sat Jan 15, 2011 5:20 am

Hi

I have a little problem foundet when i starting Firefox then see the FEBE button in the Add-on bar OK !!!
When i open new Firefox window then see NO it ???
Here is the snapshot:
Bild 1.jpg
Bild 1.jpg (27.76 KiB) Viewed 17089 times


:( :( :(
AMG
 

Re: FEBE 7 beta releases

Postby cbaker_admin » Sat Jan 15, 2011 7:12 am

The icon you see represents the FEBE backup scheduler. It only appears in the oldest window open. If you were to close the first window, the icon would appear in the second window.

This keeps the scheduler running in one window only. Otherwise if you had say five windows open, five backups would start when the scheduled time occurred.
Chuck
cbaker_admin
Site Admin
 
Posts: 4571
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE 7 beta releases

Postby AMG » Sat Jan 15, 2011 7:22 am

Ok thanks for info you are the best !!! :D :D :D
AMG
 

PreviousNext

Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 11 guests

cron