Setting backup destination directory permissions

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

Setting backup destination directory permissions

Postby cbaker_admin » Mon May 13, 2013 1:01 pm

Error message: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"
or "0x80004005 (NS_ERROR_FAILURE) [nsIFile.remove]"

It seems that Fx 20 changed the way permissions are applied when creating new directories. I am researching the problem but until I find a permanent solution you need to set the permissions manually.

Windows 7 (other Windows versions may differ slightly)

  • Using Windows Explorer, navigate to your FEBE backup destination folder (as listed in FEBE Options > Where to backup > Backup destination directory).
  • Right-click on the folder name and select Properties > Security. Under Group or usernames you should have at least four entries. The first one should be "Everyone".
  • Highlite that item and make sure "Full control" is checked. If not, click "Edit" and change it so it is checked. You may want to do this for each user (just in case).

Ubuntu and other *nix users (including Apple)
  • Open a shell prompt
  • cd to your backup destination folder (as listed in FEBE Options > Where to backup > Backup destination directory).
  • chmod 777 on that directory and any containing sub-directories. You may need to chmod the parent folder also.

This is something that should have to be done only once. If the problem continues, please let me know.

One quick way to ignore the problem is to set FEBE Options > Where to backup > Maximum backup directories to keep to zero. If you need the space later, you can just manually delete the older backup directories.
cbaker_admin
Site Admin
 
Posts: 4427
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 4 guests