Inconsistent extension backups

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

Inconsistent extension backups

Postby JBattin » Wed Nov 30, 2016 12:23 am

I have attached 2 different result files. The earliest happened with the schedule. The 2nd I ran manually because the first did not backup all of the extensions. This is not the first time this has occurred. Sometimes it works fine the 1st time, I just don't know why sometimes it works and sometimes it doesn't. I honestly don't know when this started or what versions I was on, but I noticed it in the last couple weeks. It happened when I was on 49.0.2 with the version prior to 8.9.3.1 of FEBE.

Any ideas?

Thanks.
Jan
Attachments
Results - FEBE 2016 11-30 00.50.18.zip
(303.29 KiB) Downloaded 21 times
Results - FEBE 2016 11-30 00.10.02.zip
(28.9 KiB) Downloaded 23 times
JBattin
 
Posts: 28
Joined: Tue Oct 04, 2011 10:09 am

Re: Inconsistent extension backups

Postby cbaker_admin » Wed Nov 30, 2016 1:36 pm

You'll notice on the first report there is a message near the top that says:
*** FEBE was unable to load the extension data in real-time before the backup. Instead, a stored version dated 11/29/2016, 4:00:23 PM was used. Any extensions or themes installed after that date may not appear in this backup. Note that this only affects extensions and themes. All other items should have been backed up normally.


When FEBE backs up extensions, it makes an asynchronous call to AMO to retrieve a list of your installed extensions. If it cannot do this (as in this case) it attempts to use the list from the last backup. Usually the reason FEBE cannot get the list is because you are offline when the backup starts. You can manually create the list in FEBE Options > Advanced > Attempt to load and save extension data.
Chuck
cbaker_admin
Site Admin
 
Posts: 4342
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Inconsistent extension backups

Postby JBattin » Wed Nov 30, 2016 2:13 pm

Thanks - I did what you said but I just want to let you know that this issue happens when I'm online and the computer is active.
JBattin
 
Posts: 28
Joined: Tue Oct 04, 2011 10:09 am

Re: Inconsistent extension backups

Postby cbaker_admin » Wed Nov 30, 2016 2:28 pm

There are many possible reasons FEBE may not be able to contact AMO. That's why FEBE tries to remember the list from the last backup. This only affects Selective Backups (extensions) so everything else should backup fine regardless of whether the contact succeeds or not.
Chuck
cbaker_admin
Site Admin
 
Posts: 4342
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA


Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 2 guests

cron