Incomplete or non-op execution

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

Incomplete or non-op execution

Postby wysocki » Sun Dec 25, 2016 12:40 pm

I have v8.9.3.1 on FF 50.1.0 and am trying to backup extensions and addons. After I configure folders, etc. If I schedule a run, nothing happens. Even if I set it for "run on shutdown". If I manually try to start TOOLS|FEBE|BACKUPNOW nothing happens. I CAN do a "delayed backup", but then it runs to about 90% "Preparing results page..." and that's it. I can browse to the results page and it looks like it ran, but I'm not sure. I'd like to install FF on a new computer and reinstate it but I'm afraid it would not run right. If I get the results page, did it complete the job?
wysocki
 
Posts: 2
Joined: Fri Nov 04, 2016 2:13 pm
Location: Los Angeles area

Re: Incomplete or non-op execution

Postby cbaker_admin » Sun Dec 25, 2016 5:20 pm

Are you getting any FEBE related errors in the error console (Tools > Web Developer > Browser Console)?

Also try running "Clear FEBE preferences", "Verify extension directory" and "Check AddonManager functionality" in FEBE Options > Advanced. (You will need to re-enter your FEBE backup destination directory and other backup options after clearing.)

If you are still experiencing problems, try this: Open and clear the Error console. Leave it open and perform a backup. Examine the error console for any FEBE related error messages (type febe in the "Search:" box). Copy/paste them here.
Chuck
cbaker_admin
Site Admin
 
Posts: 4384
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Incomplete or non-op execution

Postby wysocki » Tue Dec 27, 2016 6:33 pm

Did as you said, ran delayed backup, froze at about 2.1% with the following in the log:
NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIFile.initWithPath] febe.js:1955
FEBE.febeCopyFile chrome://febe/content/febe.js:1955:2
FEBE.febeBackupExtensions chrome://febe/content/febe.js:3975:5
FEBE.doBackup chrome://febe/content/febe.js:2680:7
FEBE.checkPermissions chrome://febe/content/febe.js:7531:2
FEBE.checkFFhistory/<.handleCompletion chrome://febe/content/febe.js:7506:5

Cleared all again, ran all the way through with a few warnings about not being able to find an addon, which I just OKd. Hoping that I have a good backup now - going to wipe out current installation and try to get back up again! Something is just really messed up in my current FF. Popup windows are empty, nothing prints right, I have to regularly "restore previous session" and other nasty things. Hopefully I'll be able to rebuild FF to a working version of the features I have and love now. If worst case happens, I have shadow copies of the whole drive I can restore from!
wysocki
 
Posts: 2
Joined: Fri Nov 04, 2016 2:13 pm
Location: Los Angeles area


Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 9 guests

cron