FEBE runs at random time after resume from hibernate

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

FEBE runs at random time after resume from hibernate

Postby broadstairs » Tue Mar 14, 2017 12:59 am

I am currently using the latest FEBE on FF 52 under Linux. I hibernate/resume this PC 99% of the time and find that FEBE will backup at a time which is NOT set as the time to run. I have it set to backup daily at 21:00 hrs but the backup seems to run at random times if the PC has been hibernated, however the first time after a re-boot it will run at the correct time. Is there any way to get it to check the PC time and only run at the stated time?

Stuart
broadstairs
 
Posts: 19
Joined: Sun Mar 16, 2014 3:31 am

Re: FEBE runs at random time after resume from hibernate

Postby cbaker_admin » Tue Mar 14, 2017 4:16 pm

The problem is when your pc hibernates, it suspends all JavaScript daemons - one of which is the countdown timer to start the backup. When your pc "wakes up", the timer is continued. This results in apparent random scheduled backups. Unfortunately, I know of no way to keep the daemon processes alive during hibernation. If your pc was just going into "sleep mode" and not hibernating, the backup process would start on schedule.
Chuck
cbaker_admin
Site Admin
 
Posts: 4389
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE runs at random time after resume from hibernate

Postby broadstairs » Wed Mar 15, 2017 12:37 pm

OK I guess I'm going to have to turn off auto backups as it is getting silly.

Stuart
broadstairs
 
Posts: 19
Joined: Sun Mar 16, 2014 3:31 am


Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 4 guests

cron