FEBE is excellent... BUT ... E10s it worketh not.

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

FEBE is excellent... BUT ... E10s it worketh not.

Postby CypherOz » Tue Jun 20, 2017 7:12 pm

G'Day from Australia

FEBE is excellent... BUT ... it E10s worketh not.

E10s will be forced on us in November 2017 and extensions that don't upgrade will die.

This is very sad.

Thanks!!
CypherOz
 
Posts: 2
Joined: Tue Jun 20, 2017 6:59 pm

Re: FEBE is excellent... BUT ... E10s it worketh not.

Postby cbaker_admin » Tue Jun 20, 2017 8:34 pm

It's unfortunate, but Fx v57 will sound the death knoll of many extensions - FEBE included. Most of the extensions I have written simply cannot be re-written using the WebExtensions platform. In particular, FEBE, CLEO, OPIE, JOE, and FECT require access to regions of the Fx browser internals that WebExtensions does not (and apparently will not ever) provide.

In the future, only Pale Moon (and other Fx forks that still use XPCOM and XUL) will be supported..

Honestly, I think Firefox itself is on the way out. It was apparent when Mozilla published their suicide note almost two years ago.
Chuck
cbaker_admin
Site Admin
 
Posts: 4430
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE is excellent... BUT ... E10s it worketh not.

Postby CypherOz » Thu Jun 22, 2017 8:51 pm

Thanks. So sad.
CypherOz
 
Posts: 2
Joined: Tue Jun 20, 2017 6:59 pm


Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 11 guests

cron