Page 1 of 1

Febe no longer completes

PostPosted: Wed Jun 21, 2017 12:30 am
by JBattin
I am on the latest stable version. About a couple of weeks ago something strange started happening when FEBE runs.

I always have many windows open, now shortly after FEBE starts, the windows start cycling - so it just pops up 1 window, then the next window, and on and on - and I can no longer get it to finish. Usually I have to finally kill Firefox to abort the process. Can you tell me what's going on, or do you know?

Thanks.
Jan

Re: Febe no longer completes

PostPosted: Wed Jun 21, 2017 11:21 am
by cbaker_admin
I can't be positive, but it probably has something to do with Mozilla'a e10s (multi-process) implementation (Electrolysis) they are pushing. FEBE has not been modified to run in multi-process mode and since FEBE will not be supported after Fx v57, I won't be making any more changes to the code.

Re: Febe no longer completes

PostPosted: Wed Jun 21, 2017 1:15 pm
by JBattin
are you going to create a similar product? Because if you're not - that just sucks!!

I don't have multi-process enabled because I knew most of my extensions are not updated for that.

Thanks.
Jan

Re: Febe no longer completes

PostPosted: Wed Jun 21, 2017 3:20 pm
by cbaker_admin
are you going to create a similar product?


Not for Firefox (nor Chrome). WebExtensions simply does not offer the tools I need to do it. It won't even allow an extension to write or read from a user's hard drive - and that is exactly what a backup and restore add-on has to to do! Even if I could read/write, the new Fx will not allow users to install add-ons locally. They have to be installed online (or in developer mode which is less secure). At least that how is is now with Chrome, and that seems to be the way Mozilla is going.

FEBE (and all of my other extensions) will continue to work with Fx forks like Pale Moon.