FBEE 8.9.3.1 hangs FF Nightly 56.0a1

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

FBEE 8.9.3.1 hangs FF Nightly 56.0a1

Postby ks234 » Wed Jun 28, 2017 2:33 am

Hi,

I'm using FEBE with FireFox Nightly since 2 or 3 years now (on Mac) and never had a problem. But with the upgrade to FF Nightly to version 56 FEBE hangs FF in such a way, that I need to "force kill" Nightly. I was not able to get any further information, as I found no possibility to do any real debugging of the issue. Only thing I found: Starting with a fresh Nightly w/o any Add-Ons, installing FEBE (but _not_ configure it!) and restarting Nightly gives no problems, no hang, nothing. As soon as I open the configuration box of FEBE and try to browse for a place to store backups, Nightly hangs, the Mac "rotating ball" appears and only "force kill" lets me stop Nightly.

A have'nt tried yet if the same happens on the Windows version of Nightly...

Anything I could to to help get FEBE working with Nightly again?

ks234
ks234
 
Posts: 2
Joined: Tue Jun 27, 2017 2:31 pm

Re: FBEE 8.9.3.1 hangs FF Nightly 56.0a1

Postby cbaker_admin » Wed Jun 28, 2017 9:29 am

It most likely has to do with the introduction of multi-process in Fx. Others have mentioned that this affects FEBE operation. You can disable multi-process with the instructions found here. Unfortunately, this is only a temporary solution as FEBE will no longer be supported after the release of Fx v57 this fall.
Chuck
cbaker_admin
Site Admin
 
Posts: 4523
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FBEE 8.9.3.1 hangs FF Nightly 56.0a1

Postby ks234 » Tue Jul 04, 2017 2:42 am

Hm, I tried with FF multiprocessing disabled - the problem persists.

Sad, that Mozillas "political" decisions make FEBE and a lot of other really usefull extensions go away. Time to look for another browser?(!)

ks234
ks234
 
Posts: 2
Joined: Tue Jun 27, 2017 2:31 pm

FBEE 8.9.3.1 hangs Waterfox 56.0.1 on Mac OS X

Postby grahamperrin » Tue Dec 26, 2017 2:10 pm

ks234 wrote:… Mac…


ks234 wrote:… multiprocessing disabled - the problem persists.


With Waterfox, without multiprocess, I get a hang by simply opening the FEBE Options window for the first time.

From https://pastebin.com/raw/2NczuYGy:

Code: Select all
Sampling process 1390 for 3 seconds with 1 millisecond of run time between samples
Sampling completed, processing symbols...
Analysis of sampling waterfox (pid 1390) every 1 millisecond
Process:         waterfox [1390]
Path:            /Applications/Waterfox.app/Contents/MacOS/waterfox
Load Address:    0x1046ab000
Identifier:      org.waterfoxproject.waterfox
Version:         56.0.1 (5617.12.12)
Code Type:       X86-64
Parent Process:  ??? [1]

Date/Time:       2017-12-26 20:44:04.430 +0000
OS Version:      Mac OS X 10.9.5 (13F1911)
Report Version:  7

Call graph:
    1593 Thread_20687   DispatchQueue_1: com.apple.main-thread  (serial)
    + 1593 start  (in waterfox) + 52  [0x1046abdb4]
    +   1593 ???  (in waterfox)  load address 0x1046ab000 + 0x1101  [0x1046ac101]
    +     1593 ???  (in XUL)  load address 0x104c5a000 + 0x2ea93a2  [0x107b033a2]
    +       1593 ???  (in XUL)  load address 0x104c5a000 + 0x2ea8e11  [0x107b02e11]
    +         1593 ???  (in XUL)  load address 0x104c5a000 + 0x2ea8627  [0x107b02627]
    +           1593 ???  (in XUL)  load address 0x104c5a000 + 0x2e20b5f  [0x107a7ab5f]
    +             1593 ???  (in XUL)  load address 0x104c5a000 + 0x1e097b6  [0x106a637b6]
    +               1593 -[NSApplication run]  (in AppKit) + 553  [0x7fff8bfb299c]
    +                 1593 ???  (in XUL)  load address 0x104c5a000 + 0x1e088a1  [0x106a628a1]
    +                   1593 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]  (in AppKit) + 122  [0x7fff8bfbe89b]
    +                     1593 _DPSNextEvent  (in AppKit) + 1434  [0x7fff8bfbf24e]
    +                       1593 _BlockUntilNextEventMatchingListInModeWithFilter  (in HIToolbox) + 65  [0x7fff8718f5bc]
    +                         1593 ReceiveNextEventCommon  (in HIToolbox) + 479  [0x7fff8718f7b7]
    +                           1593 RunCurrentEventLoopInMode  (in HIToolbox) + 226  [0x7fff8718fa0d]
    +                             1593 CFRunLoopRunSpecific  (in CoreFoundation) + 309  [0x7fff84d67e75]
    +                               1593 __CFRunLoopRun  (in CoreFoundation) + 831  [0x7fff84d683ef]
    +                                 1593 __CFRunLoopDoSources0  (in CoreFoundation) + 242  [0x7fff84d68c62]
    +                                   1593 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__  (in CoreFoundation) + 17  [0x7fff84d775b1]
    +                                     1593 ???  (in XUL)  load address 0x104c5a000 + 0x1e091d0  [0x106a631d0]
    +                                       1593 ???  (in XUL)  load address 0x104c5a000 + 0x1db3e20  [0x106a0de20]
    +                                         1593 ???  (in XUL)  load address 0x104c5a000 + 0xc97b7  [0x104d237b7]
    +                                           1593 ???  (in XUL)  load address 0x104c5a000 + 0xcb29e  [0x104d2529e]
    +                                             1593 ???  (in XUL)  load address 0x104c5a000 + 0x59cc2  [0x104cb3cc2]
    +                                               1593 ???  (in XUL)  load address 0x104c5a000 + 0x59b6c  [0x104cb3b6c]
    +                                                 1593 ???  (in XUL)  load address 0x104c5a000 + 0x596ca  [0x104cb36ca]
    +                                                   1593 ???  (in XUL)  load address 0x104c5a000 + 0x61315  [0x104cbb315]
    +                                                     1593 ???  (in XUL)  load address 0x104c5a000 + 0x84759a  [0x1054a159a]
    +                                                       1593 ???  (in XUL)  load address 0x104c5a000 + 0x8587df  [0x1054b27df]
    +                                                         1593 ???  (in XUL)  load address 0x104c5a000 + 0xc8c60  [0x104d22c60]
    +                                                           1593 ???  (in XUL)  load address 0x104c5a000 + 0xc8d39  [0x104d22d39]
    +                                                             1593 ???  (in XUL)  load address 0x104c5a000 + 0x8475b3  [0x1054a15b3]
    +                                                               1593 ???  (in XUL)  load address 0x104c5a000 + 0x847309  [0x1054a1309]
    +                                                                 1593 ???  (in XUL)  load address 0x104c5a000 + 0x84742a  [0x1054a142a]
    +                                                                   1593 ???  (in XUL)  load address 0x104c5a000 + 0x849233  [0x1054a3233]
    +                                                                     1593 ???  (in XUL)  load address 0x104c5a000 + 0xccc2f  [0x104d26c2f]
    +                                                                       1593 ???  (in XUL)  load address 0x104c5a000 + 0xcb2c9  [0x104d252c9]
    +                                                                         1593 ???  (in XUL)  load address 0x104c5a000 + 0xce92d  [0x104d2892d]
    +                                                                           1593 ???  (in XUL)  load address 0x104c5a000 + 0x84b8bb  [0x1054a58bb]
    +                                                                             1593 ???  (in XUL)  load address 0x104c5a000 + 0x85875b  [0x1054b275b]
    +                                                                               1593 mozilla::detail::MutexImpl::lock()  (in libmozglue.dylib) + 6  [0x1046bec46]
    +                                                                                 1593 _pthread_mutex_lock  (in libsystem_pthread.dylib) + 372  [0x7fff88910779]
    +                                                                                   1593 __psynch_mutexwait  (in libsystem_kernel.dylib) + 10  [0x7fff84a9e746]
    1593 Thread_20697   DispatchQueue_2: com.apple.libdispatch-manager  (serial)


– context: Waterfox 56.0 and FEBE : waterfox

Compare with: Firefox 56.0.2 on FreeBSD-CURRENT crashing at FEBE Options
grahamperrin
 
Posts: 36
Joined: Sun Nov 05, 2017 8:15 pm

FBEE 8.9.3.1 hangs Firefox 56.0 and Waterfox 56.0.1 on Linux

Postby grahamperrin » Wed Dec 27, 2017 2:37 am

Similarly on Kubuntu Linux: simply opening the FEBE Options window, for the first time, causes Waterfox 56.0.1 to hang, to stop responding.

It's necessary to terminate the application (comparable to the force quit that's necessary on Mac OS X).

Postscript: the same with Firefox 56.0 on Kubuntu,

2017-12-27 10.14 frame.png
grahamperrin
 
Posts: 36
Joined: Sun Nov 05, 2017 8:15 pm

FBEE with 56.x

Postby grahamperrin » Thu Mar 01, 2018 5:34 pm

With apologies for bumping … Chuck, please, did you make any progress with this?

Most remarkable is reproducibility of problems when FEBE is added to a new/clean profile.

Reproducible with FBEE 8.9.3.1 alone added to a new profile with release 56.0.2 of Firefox on build 16G1210 of Mac OS X 10.12.6. Simply opening the Options window of FEBE causes Firefox to stop responding.
grahamperrin
 
Posts: 36
Joined: Sun Nov 05, 2017 8:15 pm

Re: FBEE 8.9.3.1 hangs FF Nightly 56.0a1

Postby cbaker_admin » Fri Mar 02, 2018 5:08 pm

Please see this post.
Chuck
cbaker_admin
Site Admin
 
Posts: 4523
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA


Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 3 guests

cron