Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon)

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon)

Postby BackerUpper » Sat Jul 29, 2017 1:53 pm

After restoring a backed up permissions.json file (no error messages), there are no changes in about:permissions, nothing is restored even after a browser restart.
Windows 10 Pro x64 - Pale Moon browser
BackerUpper
 
Posts: 33
Joined: Sat Aug 16, 2014 10:59 am

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby cbaker_admin » Sat Jul 29, 2017 4:16 pm

At one time, Fx (and Pale Moon) stored the permissions in the file permissions.json. Apparently, this was changed to storing permissions in two files: content-prefs.sqlite and permissions.sqlite. The current FEBE for Fx does backup those files, but the Pale Moon version (FEBE 8.3.1) was not updated to do this.

This fall, I will be updating FEBE for Pale Moon and will fix it. In the meantime, you can setup a user-defined backup for those two files.
Chuck
cbaker_admin
Site Admin
 
Posts: 4412
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby BackerUpper » Sun Jul 30, 2017 3:23 am

Many thanks. :thumbup:
Windows 10 Pro x64 - Pale Moon browser
BackerUpper
 
Posts: 33
Joined: Sat Aug 16, 2014 10:59 am

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby BackerUpper » Mon Oct 30, 2017 3:56 am

Unfortunately this still doesn't work with FEBE 10.0. I'm verifying this by checking the Permissions Manager, where nothing seems restored (did both backup/restore with v.10).
Windows 10 Pro x64 - Pale Moon browser
BackerUpper
 
Posts: 33
Joined: Sat Aug 16, 2014 10:59 am

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby cbaker_admin » Mon Oct 30, 2017 4:31 pm

I'll look into it and upload to the Pale Moon repository when ready. Thanks for the heads up.
Chuck
cbaker_admin
Site Admin
 
Posts: 4412
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby cbaker_admin » Tue Nov 07, 2017 3:44 pm

Ok ... I'e got FEBE v10.1 that has the fixes to restoring extensions and backing up/restoring permissions. This is for PM v27.5.1and appears to work with PM v26.1.1 also (although I haven't tested it thoroughly yet).

Permissions backed up prior to this version will not restore, but going forward it should be fine. Full profile backups are now named profilePM* instead of profileFx*.

Would you mind testing it out to make sure it works as expected? I won't upload it to the PM repository until I hear from you. Thanks.

(See this thread for latest version)
Chuck
cbaker_admin
Site Admin
 
Posts: 4412
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby BackerUpper » Tue Nov 07, 2017 4:26 pm

Thanks for the update, did a few quick tests with PM 27.6.0. Permissions restore seems to work fine. I had problems with extensions restore.

1. Tried to restore 20-30 extensions at once: some kept endlessly opening tabs. They were extensions that did not require a restart and automatically open a new tab to alert the user to configure options etc. In this case, the same tabs kept opening continuously and I had to quit the browser.

2. Tried to restore only two extensions. See attached below.

Clipboard Image.jpg

3. Tried again to restore multiple extensions and got a similar result to FEBE 10.0 (nothing happens, restoring is stuck).
Windows 10 Pro x64 - Pale Moon browser
BackerUpper
 
Posts: 33
Joined: Sat Aug 16, 2014 10:59 am

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby cbaker_admin » Tue Nov 07, 2017 4:38 pm

I'm using PM v27.5.1. You're using v27.6.0? I didn't realize there was a newer release.

Also, you may want to try installing FEBE again. I noticed there was only one download performed (i.e., (1.31 MiB) Downloaded 1 time) and that was probably the time I downloaded it. I uploaded v10.1 at least three times with a few minutes between each and you may have downloaded one of the previous ones.
Chuck
cbaker_admin
Site Admin
 
Posts: 4412
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby BackerUpper » Tue Nov 07, 2017 4:41 pm

Ok, I'll try again and post back tomorrow. Yes, PM 27.6.0 was released yesterday/today.
Windows 10 Pro x64 - Pale Moon browser
BackerUpper
 
Posts: 33
Joined: Sat Aug 16, 2014 10:59 am

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby BackerUpper » Tue Nov 07, 2017 5:19 pm

No change unfortunately:

FEBE 10.1.jpg


If I only try to restore these 2 extensions, the tabs will not endlessly re-open. If I try to restore 20-30 extensions, these same tabs will endlessly re-open.

Perhaps the combination of extensions targetting both Pale Moon and Firefox (as in this case, note the blue/orange icons) can cause this?
Windows 10 Pro x64 - Pale Moon browser
BackerUpper
 
Posts: 33
Joined: Sat Aug 16, 2014 10:59 am

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby cbaker_admin » Thu Nov 09, 2017 3:47 pm

I've downloaded and installed Pale Moon x64 - 27.6.0 but cannot duplicate the problem. I am able to restore a single extension and 25 at a time with no problems. I installed the two extensions you mentioned (Decentraleyes v1.3.10 and Keyword Search v1.1.8.3 from AMO and they both backup and restore just fine.

I'm wondering if you might have an installed extension that is causing the issue. Could you post a multi-pack xpi with all your current extensions? (You can create one using FEBE's Quick Backup function - just specify a name for the pack and FEBE will create a single installable xpi file.) That way I can set up a test profile similar to yours to debug.
Chuck
cbaker_admin
Site Admin
 
Posts: 4412
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby BackerUpper » Thu Nov 09, 2017 4:18 pm

I've made these last tests with a clean profile (no other extensions installed) and I just reproduced it again, so perhaps there's a better way to identify this? Tried it again now:

Clipboard Image 1.jpg

Clipboard Image 2.jpg

Clipboard Image 3.jpg
Windows 10 Pro x64 - Pale Moon browser
BackerUpper
 
Posts: 33
Joined: Sat Aug 16, 2014 10:59 am

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby cbaker_admin » Thu Nov 09, 2017 4:44 pm

I've noticed that both those extensions (Decentraleyes and Keyword Search do not require a PM restart to finish the install. I, too, am now able to see those extensions listed twice in the addon-manager window - once as installed and the other as "Downloading". I also get the "Welcome" page for both those extensions before a restart.

It looks like the problem is with restoring "restartless" extensions. I'm going to have to look into it more.
Chuck
cbaker_admin
Site Admin
 
Posts: 4412
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby VLM » Thu Nov 16, 2017 8:39 am

cbaker_admin wrote:I'm using PM v27.5.1. You're using v27.6.0? I didn't realize there was a newer release.


Chuck, you might consider subscribing to the PM Announcements forum. Few notices, but then you'll always know whenever an upgrade/update is released.

Elchanan
VLM
 
Posts: 121
Joined: Sun Nov 29, 2009 3:44 pm

Re: Permissions restore doesn't work (FEBE 8.3.1 - Pale Moon

Postby cbaker_admin » Thu Nov 16, 2017 1:05 pm

Done ... Thanks for the info!
Chuck
cbaker_admin
Site Admin
 
Posts: 4412
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Next

Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 6 guests

cron