Page 1 of 1

FEBE 10 (Pale Moon) Extensions restore

PostPosted: Mon Oct 30, 2017 4:01 am
by BackerUpper
This particular operation does not work, nothing seems to happen. The Add-ons Manager will look like this:

FEBE issue.jpg

This also occurred with the previous FEBE version (8.3.1).

Re: FEBE 10 (Pale Moon) Extensions restore

PostPosted: Mon Oct 30, 2017 4:43 pm
by cbaker_admin
Interesting ... It was working when I first released FEBE 10.0, but doesn't seem to work now. I'm using Pale Moon v27.5.1. Was there a recent update I didn't know about?

Re: FEBE 10 (Pale Moon) Extensions restore

PostPosted: Mon Oct 30, 2017 4:46 pm
by BackerUpper
No, 27.5.1 is the current version. Perhaps this issue doesn't always occur or another extension interferes? I do remember seeing it though in previous versions (both FEBE and Pale Moon).

edit: I've tried this in a clean profile with only FEBE installed, so probably not related with other extensions.

Re: FEBE 10 (Pale Moon) Extensions restore

PostPosted: Mon Oct 30, 2017 4:59 pm
by cbaker_admin
I just hope it's not related to something Mozilla has done, like remove (or changed) any APIs for legacy extensions. FEBE uses several of them including the one that restores add-ons with the addons manager functions. In the meantime, extensions can still be restored by opening them through File > Open File ....

Re: FEBE 10 (Pale Moon) Extensions restore

PostPosted: Mon Oct 30, 2017 5:03 pm
by BackerUpper
Yes, using the Add-ons Manager also works normally ("Install Add-on From File...").

Re: FEBE 10 (Pale Moon) Extensions restore

PostPosted: Wed Nov 01, 2017 5:28 pm
by cbaker_admin
FEBE 10 restore extensions does work with PM v26.1.1, but not with v27.5.1. I'm looking into what has changed between the two versions.

Re: FEBE 10 (Pale Moon) Extensions restore

PostPosted: Mon Nov 20, 2017 5:16 pm
by cbaker_admin
The extension restore function should work now. Please install from here.