Waterfox crashing

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

Waterfox crashing

Postby UK_GB » Sun Dec 03, 2017 9:31 am

Hi Chuck,
I am having a problem with FEBE using Waterfox 56.0, whereby when FEBE attempts to backup my Waterfox files, I get a beach ball spinning followed by
the attached error message. Even when I attempt to set / change FEBE preferences, Waterfox crashes.
I set up a new Waterfox profile and added FEBE as the only add-on, yet the same problem occurs.
Hope you can help out with this, please.
My computer is running Mac High Sierra 10.13.1 / Waterfox 56.0
Attachments
Monosnap 2017-12-03 16-16-31.jpg
UK_GB
 
Posts: 7
Joined: Sun Nov 22, 2015 4:22 pm

Re: Waterfox crashing

Postby cbaker_admin » Mon Dec 04, 2017 1:38 pm

I can't get it to work either.

I installed High Sierra on a virtual machine then installed Firefox v56.0.2 and Waterfox 56. I added FEBE to both browsers and when trying to open FEBE options in either one, all I get is a spinning wheel (never got the error popup you got). I have to do a shutdown to clear it.

Since I know FEBE works with Firefox and Waterfox on Windows, I have to assume the issue is with High Sierra.
Chuck
cbaker_admin
Site Admin
 
Posts: 4523
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Waterfox crashing

Postby UK_GB » Mon Dec 04, 2017 4:57 pm

Hi Chuck,
Thank you for going to the trouble of installing High Sierra and checking FEBE.
Maybe it is a Waterfox 56 (Mac) problem. I say this because FEBE worked as it should in Waterfox 55 and, unlike your problem with Firefox 56, FEBE worked OK in that version for me, whilst running High Sierra.
Whatever is causing the crash, it's a shame, because FEBE was one of those -'must-have' extensions.
Thanks again for your time. Appreciated.

Doug.
UK_GB
 
Posts: 7
Joined: Sun Nov 22, 2015 4:22 pm

Re: Waterfox crashing

Postby grahamperrin » Sat Dec 23, 2017 11:46 pm

I have no experience of FEBE with Firefox 55 or less.

With Firefox 56.x and with Waterfox 56.0.1 on FreeBSD-CURRENT, a crash occurs towards the end (maybe ninety-something percent) of a selective backup.

With Waterfox started at the command line, here's the tail of the terminal output:

Code: Select all
mozilla::detail::MutexImpl::lock: pthread_mutex_lock failed: Resource deadlock avoided
Segmentation fault (core dumped)


Screen recording available on request.

Later today I might try a debug run …
grahamperrin
 
Posts: 36
Joined: Sun Nov 05, 2017 8:15 pm

Re: Waterfox crashing

Postby cbaker_admin » Sun Dec 24, 2017 1:31 pm

grahamperrin wrote:Later today I might try a debug run …

By that, do you mean FEBE Options > Advanced > Advanced preferences > FEBE debug mode? That should give you an indication of where its failing.

If you find anything, let me know and I will install FreeBSD in a virtual machine and try to duplicate it. Are you running FreeBSD v11.1?
Chuck
cbaker_admin
Site Admin
 
Posts: 4523
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

full backups are crash-free

Postby grahamperrin » Sun Dec 24, 2017 9:18 pm

Thanks. I'll do that.

Worth mentioning: I never had a problem with a full backup. For example:

Code: Select all
[grahamperrin@momh167-gjp4-hpelitebook8570p-freebsd] ~/Documents/IT/Mozilla/Firefox/FEBE/FEBE 2017 12-25 03.58.53% ls -hl
total 340669
-rw-r--r--  1 grahamperrin  grahamperrin   334M 25 Dec 04:00 profileFx56.0.1(FEBE8.9.3.1){default}.fbu
-rwxrwxrwx  1 grahamperrin  grahamperrin    33K 25 Dec 04:00 Results - FEBE 2017 12-25 03.58.53.html
[grahamperrin@momh167-gjp4-hpelitebook8570p-freebsd] ~/Documents/IT/Mozilla/Firefox/FEBE/FEBE 2017 12-25 03.58.53% ls -dl ..
drwxr-xr-x  5 grahamperrin  grahamperrin  15 25 Dec 03:58 ..
[grahamperrin@momh167-gjp4-hpelitebook8570p-freebsd] ~/Documents/IT/Mozilla/Firefox/FEBE/FEBE 2017 12-25 03.58.53% cd ..
[grahamperrin@momh167-gjp4-hpelitebook8570p-freebsd] ~/Documents/IT/Mozilla/Firefox/FEBE% uname -v
FreeBSD 12.0-CURRENT #0 r320869: Mon Jul 10 13:57:55 UTC 2017     root@releng3.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC
[grahamperrin@momh167-gjp4-hpelitebook8570p-freebsd] ~/Documents/IT/Mozilla/Firefox/FEBE%


(FreeBSD 12.0-CURRENT … significantly outdated (July), but I doubt that's a factor.)

From the report:

25/12/2017 03:58:53
Item count: 1 total backed up — 0 extensions, 0 themes, 1 additional items.
Backup type: Full profile, Manual, Mode: Synchronous
Backup location: /home/grahamperrin/Documents/IT/Mozilla/Firefox/FEBE/FEBE 2017 12-25 03.58.53
Total processing time: 105.785 seconds
grahamperrin
 
Posts: 36
Joined: Sun Nov 05, 2017 8:15 pm

Re: Waterfox crashing

Postby grahamperrin » Sun Dec 24, 2017 10:17 pm

Two frames from a screen recording: https://imgur.com/a/ijBaf (full recording available on request).

In this incident, what's visible in the console window might not be useful.

I see something history-related in the FEBE progress window/dialogue …
grahamperrin
 
Posts: 36
Joined: Sun Nov 05, 2017 8:15 pm

Re: Waterfox crashing

Postby cbaker_admin » Mon Dec 25, 2017 8:34 am

It does seem that FEBE is crashing during the backing up of the browser history. Try unchecking that item in FEBE Options > What to backup > Additional items and see if the backup will complete.
Chuck
cbaker_admin
Site Admin
 
Posts: 4523
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Waterfox crashing

Postby grahamperrin » Tue Dec 26, 2017 11:00 am

Strange. The screen recording reminds me that I clicked Deselect All for that column, so the attempt to backup history is unexpected.

Shifting focus: Firefox 56.0.2 on FreeBSD-CURRENT crashing at FEBE Options
grahamperrin
 
Posts: 36
Joined: Sun Nov 05, 2017 8:15 pm

Crashing Waterfox 56.0.4_4

Postby grahamperrin » Thu Mar 01, 2018 6:23 pm

Reproducible with FBEE 8.9.3.1 alone added to a new profile with Waterfox 56.0.4_4 on FreeBSD-CURRENT. Multi-process disabled. Simply opening the Options window of FEBE causes Waterfox to crash.
grahamperrin
 
Posts: 36
Joined: Sun Nov 05, 2017 8:15 pm

Re: Waterfox crashing

Postby cbaker_admin » Fri Mar 02, 2018 5:09 pm

Please see this post.
Chuck
cbaker_admin
Site Admin
 
Posts: 4523
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA


Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 6 guests

cron