[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4781: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4783: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4784: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4785: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
Chuck Baker's Firefox Extension Forum • View topic - Firefox 56.0.2 and Waterfox 56.* crashing at FEBE Options
Page 1 of 2

Firefox 56.0.2 and Waterfox 56.* crashing at FEBE Options

PostPosted: Tue Dec 26, 2017 10:54 am
by grahamperrin

Waterfox 56.0.s20171130 on FreeBSD-CURRENT crashing …

PostPosted: Tue Dec 26, 2017 11:28 am
by grahamperrin
Tested with as a VirtualBox guest machine, using the default Lumina desktop environment. UNSTABLE repo preferred.

Not reproducible with ; no crash.

Reproducible with , with a new profile; moments after first presentation of the FEBE Options window, Waterfox crashes.

Mutex_posix.cpp

PostPosted: Tue Dec 26, 2017 11:59 am
by grahamperrin
Reference:

https://dxr.mozilla.org/mozilla-central ... _posix.cpp

I see Mozilla bug but that was

> RESOLVED FIXED in Firefox 55

Re: Firefox 56.0.2 on FreeBSD-CURRENT crashing at FEBE Optio

PostPosted: Tue Dec 26, 2017 12:02 pm
by cbaker_admin
It's important to note that FEBE is not as it does not run correctly in a multi-process environment. The browser(s) should already know this and set the browser.tabs.remote.autostart preference (in about:config) to false.

Make sure this preference is set properly before attempting to open FEBE options.

Re: Firefox 56.0.2 on FreeBSD-CURRENT crashing at FEBE Optio

PostPosted: Tue Dec 26, 2017 1:04 pm
by grahamperrin

Re: Firefox 56.0.2 on FreeBSD-CURRENT crashing at FEBE Optio

PostPosted: Tue Dec 26, 2017 1:21 pm
by grahamperrin
Is output from of any use?

Context:

2017-12-26 20.06.35.png


Partial output: https://pastebin.com/KtLvjqTn

Re: Firefox 56.0.2 on FreeBSD-CURRENT crashing at FEBE Optio

PostPosted: Tue Dec 26, 2017 2:25 pm
by cbaker_admin

Re: Firefox 56.0.2 on FreeBSD-CURRENT crashing at FEBE Optio

PostPosted: Tue Dec 26, 2017 2:37 pm
by grahamperrin

Re: Firefox 56.0.2 on FreeBSD-CURRENT crashing at FEBE Optio

PostPosted: Tue Dec 26, 2017 5:56 pm
by cbaker_admin

Firefox 56.x not packaged: side notes

PostPosted: Wed Dec 27, 2017 2:16 am
by grahamperrin

Re: Firefox 56.0.2 on FreeBSD-CURRENT crashing at FEBE Optio

PostPosted: Sat Dec 30, 2017 9:33 am
by grahamperrin
As promised:

GhostBSD11.1-mate-amd64.iso from http://www.ghostbsd.org/download can run a live session in VirtualBox, and includes Firefox 56.0.2. Whilst a live session is good enough to reproduce the crashing, I have no idea whether it'll be good enough to debug.

(Beyond a live session: I had less success with an installation of GhostBSD in VirtualBox – no GUI, networking not working, and so on.)

Waterfox 56.0.3.65_1 crashing at FEBE options

PostPosted: Fri Mar 02, 2018 2:45 pm
by grahamperrin
Reproducible with Waterfox 56.0.3.65_1 on GhostBSD.

Chuck, if you'd like to verify the bug on GhostBSD in VirtualBox, I found a simple workaround to X not starting. The whole caboodle, to include installation of Waterfox:

at the login prompt, command line, log in as root
pkg install waterfox
pkg upgrade
cd /etc/X11/
cp xorg.conf.vbox xorg.conf
shutdown -r now

Hint: at about:preferences#general in 56.0.3.65_1 you'll need to manually disable multi-process.

Re: Firefox 56.0.2 on FreeBSD-CURRENT crashing at FEBE Optio

PostPosted: Fri Mar 02, 2018 5:06 pm
by cbaker_admin
As of now, I can verify that FEBE v8.9.3.1 works with both Firefox v56.0.2 and Waterfox v56.0.4 under Windows 10. And FEBE v10.2 works with Pale Moon v27.7.2 (Windows 10).

At one time, FEBE was working fine with Ubuntu but I've haven't tested it recently. I know it does not work with Waterfox under Linux Mint 18.3. I've had limited success with OS X but don't remember with which versions and/or browsers.

There are simply too many nuances with different browsers running under different OSes to test all combinations. And I don't want to have to maintain several different versions of FEBE for each combination.

FEBE for Fx will probably not have any more updates. I will, however, try to maintain the Pale Moon version as well as a version for Pale Moon's Basilisk. But the focus will be on the Windows versions.

Re: Firefox 56.0.2 on FreeBSD-CURRENT crashing at FEBE Optio

PostPosted: Fri Mar 02, 2018 7:55 pm
by grahamperrin

56.* Windows-only

PostPosted: Sat Mar 03, 2018 8:27 am
by grahamperrin