FEBE problem with Waterfox 56.2.2.

"Firefox Environment Backup Extension" and "Compact Library Extension Organizer" discussion and bug reporting.

FEBE problem with Waterfox 56.2.2.

Postby Bito » Sun Sep 09, 2018 12:48 pm

Hi Chuck,

somewhere in this forum I have read that FEBE 8.9.3.1 was compatible with browsers like Waterfox. Unfortunately, this is not the case with Waterfox 56.2.2 (running on Win 7 prof, 64 Bit): When I click "Check AddonManager functionality" in FEBE's "Advanced" menu, the window opens, but stays blank, and the only thing I can do is to "kill" the browser via "crtl-alt-del". On the other hand, clicking on "Verify extension directory" correctly shows "47 extensions/themes found", also "List installed addons" does what it intends to do. When I do a "selective" backup (only addons) with run asynchronously" unchecked, FEBE backs up the extensions (but working rather slowly).

Is there a possibility to make FEBE compatible to Waterfox?
Greetings from Germany
Bito
 
Posts: 12
Joined: Tue Jan 28, 2014 3:34 am

Re: FEBE problem with Waterfox 56.2.2.

Postby cbaker_admin » Sun Sep 09, 2018 3:08 pm

Are you getting any FEBE related errors in the error console (Tools > Web Developer > Browser Console, or CTRL-Shift-J)?

Try running "FEBE Options > Advanced > Tools > Clear FEBE preferences". (You will need to re-enter your FEBE backup destination directory and other backup options after clearing.)

If you are still experiencing problems, try this: Open and clear the Error console. Leave it open and perform a backup. Examine the error console for any FEBE related error messages (type febe in the "Search:" box). Copy/paste them here.
Chuck
cbaker_admin
Site Admin
 
Posts: 4548
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEBE problem with Waterfox 56.2.2.

Postby Bito » Mon Sep 10, 2018 4:23 am

Hi Chuck,

thank you for your quick response. As I told, FEBE does perform the backup normally (though a bit slow), but it freezes when I click "Check AddonManager functionality" within FEBE's "Tools" panel.

Here is what I did:
-- Clear FEBE preferences
-- Restart Waterfox
-- Open error Console
-- click FEBE/Perform backup ==> backup runs as normal (but a bit slower than it used to be with Firefox on the same laptop PC); no error message

-- open FEBE Options/Advanced/Tools
-- click "Set read/write permissions" => no error
-- click "Attempt to load and save extension data" ==> no error
-- click "Verify extension directory" ==> no error
-- click "List installed add-ons" ==> no error
-- click "Check AddonManager functionality" ==> blank window opens and FEBE/Waterfox seems to freeze; after 2 minutes or so the following message pops up:

FEBE Error1.png
Script not answering


-- click "Stop script" ==> The window shows detailed information about the addons. Unfortunately I was unable to copy the contents of that window, but it was a rather long list including informations about many language packs which seem to be integrated within Waterfox.

-- click on "Debug script" ==> the error console shows this:

FEBE Error2.png


To me it seems that this is a "Waterfox-specific" problem resulting from the fact that this browser obviously contains dozens of language packs (unlike Firefox where I use language specific installation files) that are treated by FEBE as normal "addons", thus soon being "overloaded" by the big amount of addon data. Eventually it would be reasonable if FEBE users could decide what kind of addons (i.e. "real" extensions, plugins, or language packs) FEBE should look for when they click on "Check AddonManager functionality".
Bito
 
Posts: 12
Joined: Tue Jan 28, 2014 3:34 am

Re: FEBE problem with Waterfox 56.2.2.

Postby cbaker_admin » Mon Sep 10, 2018 1:47 pm

I believe you are correct in identifying the issues as "Waterfox-specific".

When I try "Check AddonManager functionality", I do get a response, but only after several minutes. I also found that FEBE Options > What to backup > Ignore list > Get list does nothing even after waiting several minutes (also no error messages appear in the browser console).

Since I already have versions of FEBE for Firefox (which is static - there will be no further updates) and Pale Moon (which I will update as necessary) I am hesitant to have to create a separate fork for Waterfox or any other browser at this time. Unfortunately, I can only offer FEBE for Waterfox as-is. While most of the functionality is there (albeit slow), FEBE can still backup/restore Waterfox items.

As you may have heard, Mozilla will be dropping the 'legacy' extension repository. Since FEBE makes XPCOM calls to retrieve information about installed add-ons from this repository, FEBE may cease to work after the repository is gone. If that is the case, it will require quite a bit of re-coding (and losing most of the information contained in the FEBE results page) to get FEBE working again. This is another reason I would need to keep the number a FEBE forks to a minimum.
Chuck
cbaker_admin
Site Admin
 
Posts: 4548
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA


Return to FEBE/CLEO

Who is online

Users browsing this forum: No registered users and 14 guests

cron