[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4781: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4783: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4784: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4785: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
Chuck Baker's Firefox Extension Forum • View topic - Opie shut down- possibly due to 3.624

Opie shut down- possibly due to 3.624

"Ordered Preference Import/Export" discussion and bug reporting.

Opie shut down- possibly due to 3.624

Postby Apollo702 » Wed Dec 07, 2011 7:29 am

I have used Opie(3.0) multiple times in the past and it worked well. I can't isolate if it is FF3.6.24 that is the issue. Mozilla lists it as incompatible and when selecting options from the add-ons menu it gives a broken window saying "problem loa..." If I click directly on the toolbar icon the regular menu pops up but it is almost entirely broken. When clicking on the information icons they give a small broken menu. When clicking on any of the controls they simply fail to do anything.

I did a complete uninstall and re-install and nothing changed. Any ideas?
Apollo702
 
Posts: 41
Joined: Wed Dec 07, 2011 7:20 am

Re: Opie shut down- possibly due to 3.624

Postby cbaker_admin » Wed Dec 07, 2011 10:55 am

OPIE 3.x was never intended to work with Fx 3.x (although hacking the maxVersion may have made it work unreliably). You should be using OPIE v1.2.3 available from the .
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Opie shut down- possibly due to 3.6.24

Postby Apollo702 » Thu Dec 08, 2011 12:51 am

Thank you. I restored the correct version- but now it can't find the preferences. I have used it MANY times in the past and now I can't seem to get it to find the preferences. Do you have any more ideas?
Apollo702
 
Posts: 41
Joined: Wed Dec 07, 2011 7:20 am

Re: Opie shut down- possibly due to 3.624

Postby cbaker_admin » Thu Dec 08, 2011 4:27 pm

cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Opie shut down- possibly due to 3.624

Postby Apollo702 » Fri Dec 09, 2011 6:33 am

It is exactly the same if I access it that way. I played around with it and I noticed a few strange things:

1. The information popup for "export extension preferences" is totally dead.

2. Under "Configure" the "Opie" information window makes the sound- but fails to appear.

3. "Get Extension Info" and "Get List" are clickable- but nothing happens.

I suppose I could use it to restore old preferences- but that isn't what I am doing today. I want to create a backup of existing preferences. It seems to me that the profile database is rather fragile and I find it to be a lifesaver to back it up during the good times. That way when it inevitably goes haywire I have instant backups or I can easily export setups onto other computers. I have done it many times and this time I am scratching my head...
Apollo702
 
Posts: 41
Joined: Wed Dec 07, 2011 7:20 am

Re: Opie shut down- possibly due to 3.624

Postby cbaker_admin » Fri Dec 09, 2011 10:48 am

It would be a little bit of work, but you can manually export/import the preferences.

There is a file located at /prefs.js that contains all the Fx preferences for both the browser itself and all extensions. This is a plaintext file that you can edit with any text editor. You could make a copy of that file and remove all the non-extension preference lines. When you are ready to import (restore), you can copy the contents of the edited file into the prefs.js of the profile you are using.

Unfortunately, I don't know if you can copy them into the current file without first removing the existing extension preference lines. (In other words, I don't know how Fx would handle duplicates. Would preferences further down the list overwrite previous ones or just ignore them? It might take a little experimentation).
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA


Return to OPIE

Who is online

Users browsing this forum: No registered users and 1 guest

cron