[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4781: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4783: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4784: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4785: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
Chuck Baker's Firefox Extension Forum • View topic - FEEBE amnesia !!!

FEEBE amnesia !!!

Unpublished versions of my extensions for debug help.

FEEBE amnesia !!!

Postby iBenny » Wed Apr 01, 2015 8:40 am

Hi,

When I change the FEEBE backup timing from browser start to shutdown moment, it keeps in memory the other setting and fails to reconfigure itself to the new setting. Often, it performs both; despite that my new setting are checked.. Can you debug this please ?

FEEBE also fails to reconfigure itself to the new number of backup to perform ! It does 3 when I reset it to 5 (from 3) !

BTW: you have NO info about the usefulness of the backup "grace period" feature ! What do you mean by this ? Is it like a delay timing for FEEBE to start the backup ? If yes, that's undestandable when we chose the backup on browser start, but it seams meaningless on browser shutdown ! could you explain more ?

Best regards

Benoit
FF 36.04
FEEBE 8.6
iBenny
 
Posts: 6
Joined: Mon Apr 02, 2012 11:06 am

Re: FEEBE amnesia !!!

Postby cbaker_admin » Wed Apr 01, 2015 10:07 am

Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEEBE amnesia !!!

Postby FEBE-paradox » Thu Apr 02, 2015 10:17 am

I sseem to be having a similar issue on my system. After updating from FEBE 8.3 to 8.6, I cleared all preferences in FEBE and set all the preferences to what I normally use, including directory locations of the backup files, items to save/ignore, schedule, & where the Firefox executable is located. After clicking on the OK button, I went back into the FEBE options and none of what I just configured was saved. Everything was blank (directories, etc.) or unselected (checkboxes). I retried configuring several times, uninstalling & reinstalling FEBE, etc. I could not get FEBE to save any configuration data. I even went back to version 8.5.x to see if it was the lastest version, but 8.5.x also wouldn't save any config settings. I will try & go back to version 8.3, but I think that it may have something to do w/ FF. I did update FF to 36.04 recently before the FEBE update.

I normally schedule a FEBE run on the 1st of the month and the last good BU I have was 1 Mar 2015, so I know FEBE was configured & working before the FEBE & FF updates. I will go back to the previous versions of FF & FEBE and test them when I get some time to do so and will post here if I get any more info. If you have any info for me to try or if I'm missing something, let me know.

Ron
FF 36.04
FEBE 8.6 & 8.5.x
Win 8.1
FEBE-paradox
 
Posts: 8
Joined: Tue Mar 31, 2015 9:04 am

Re: FEEBE amnesia !!!

Postby cbaker_admin » Thu Apr 02, 2015 10:45 am

Let's see if there are any errors when trying to save the preferences.

Put FEBE in debug mode (FEBE Options > Advanced > Miscellaneous > Advanced Preferences). This should open the error console. If it doesn't, click the Toggle browser (error) console button.

Make sure the "JS" button in the console is on (click to turn on/off - dark is on, light is off). Open FEBE options, make some changes and close options. Examine the console for any FEBE related error messages (type febe in the "Search:" box). Copy/paste them here.

When done, you can hide the error console by unchecking the FEBE debug mode box in FEBE Options > Advanced > Miscellaneous > Advanced Preferences. Or (if you have the browser console open) click the "X" button in the console's upper-right corner.
Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEEBE amnesia !!!

Postby FEBE-paradox » Thu Apr 02, 2015 11:43 am

OK, I'll try it after lunch. One other thing I've noticed that's kinda wierd. When I select FEBE Options from FF Tools menu, there is a delay of about 4-5 seconds before the FEBE Options window appears. I've never seen such a delay for any Options window to appear for any other app/extension/addon. Just an FYI.
FEBE-paradox
 
Posts: 8
Joined: Tue Mar 31, 2015 9:04 am

Re: FEEBE amnesia !!!

Postby FEBE-paradox » Thu Apr 02, 2015 1:57 pm

OK, I think I turned debug mode on correctly. After turning on the debug mode, I closed the Options window, cleared the log on the console and re-opened the Options window. I selected the preferences/config settings that I normally used and clicked on the OK button. I copied what appeared in the debug console after searching for FEBE:

SyntaxError: test for equality (==) mistyped as assignment (=)? febe.js:1186:35
SyntaxError: in strict mode code, functions may be declared only at top level or immediately within another function febe.js:5304:11
SyntaxError: in strict mode code, functions may be declared only at top level or immediately within another function febe.js:5640:11
SyntaxError: in strict mode code, functions may be declared only at top level or immediately within another function febe.js:5764:11
TypeError: useless expression febe.js:5708:3
TypeError: useless expression febe.js:5824:3
ReferenceError: reference to undefined property this.febeIgnoreList[addon.id] febe.js:884:0

When I set the directory of where Firefox was located and pressed the SAVE/VERIFY button, I got a slider window that had the message "undefined"
FEBE-paradox
 
Posts: 8
Joined: Tue Mar 31, 2015 9:04 am

Re: FEEBE amnesia !!!

Postby cbaker_admin » Thu Apr 02, 2015 3:48 pm

Attachments
FEBE8.6.1debug2.xpi
(1.24 MiB) Downloaded 605 times
Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEEBE amnesia !!!

Postby FEBE-paradox » Fri Apr 03, 2015 11:05 am

Setting Firefox directory - I use the browse button & select the firefox.exe file to set the path.

I looked @ the about:config settings before bringing the FEBE Options window up & it looks like the settigs were saved, altho' I'm only guessing about them all. The one's that look like the settings I selected seem OK. For instance:

extensions.febe.buExtensions = true
extensions.febe.FxExecutablePath = E:\Program Files (x86)\Mozilla Firefox\firefox.exe

I assume that the 1st entry I listed means that the Backup Extensions button was checked and the second entry is the path of where the browser was defined in the FEB->Options->Advanced->Miscellaneous tab.

WHen I bring the Options window up, none of the buttons are checked or fields are filled in. When I checked/unchecked boxes in the What to backup->Backup items, the settings in about:config do change, so it looks like the settings are being written.

Also, the about:config settings seem to default to TRUE even though I need to select them under the Selective mode. When I uncheck the button, the about:config setting changes to "user set = false" Is this correct? It seems that it's backwards - checking the box should be "user set = true" Maybe the config file for FF is corrupt?

I am using the Backup type setting as Selective, if that makes a difference.

I'll download the debug xpi & try it later today.
FEBE-paradox
 
Posts: 8
Joined: Tue Mar 31, 2015 9:04 am

Re: FEEBE amnesia !!!

Postby FEBE-paradox » Fri Apr 03, 2015 5:06 pm

OK, I've installed the debug xpi & tried to set the preferences w/ the debug console turned off. Same thing happens. When I use the Clear FEBE Preferences button, I get a slider box that says:
FEBE Message
undefined
undefined

undefined (in red)

undefined

After I click OK, I get a Javascript Application message pop up box that says

undefined

I'll check to see if I have the latest java installed (it's set to auto update, but it's flaky sometimes).

Checking the about:config settings, the preferences are reset.

Next, I'll try saving prefes using the debug mode & copy the console output & paste it here:

SyntaxError: test for equality (==) mistyped as assignment (=)? febe.js:1186:35
ReferenceError: reference to undefined property FEBE.selectedItemsList.bookmarks febe.js:7164:3
TypeError: FEBE.selectedItemsList.bookmarks is undefined febe.js:7164:3
TypeError: FEBE.selectedItemsList.preferences is undefined febe.js:7170:3
TypeError: FEBE.febeProfDir.clone is not a function febe.js:7209:16
TypeError: FEBE.selectedItemsList.usernamePasswords is undefined febe.js:7223:3
TypeError: FEBE.febeProfDir.clone is not a function febe.js:7232:16
ReferenceError: assignment to undeclared variable stmt febe.js:7257:3
ReferenceError: reference to undefined property FEBE.selectedItemsList.formfillHistory febe.js:7274:6
TypeError: FEBE.selectedItemsList.formfillHistory is undefined febe.js:7274:6
ReferenceError: reference to undefined property FEBE.selectedItemsList.permissions febe.js:7308:6
TypeError: FEBE.selectedItemsList.permissions is undefined febe.js:7308:6
SyntaxError: test for equality (==) mistyped as assignment (=)? febe.js:1186:35
ReferenceError: reference to undefined property FEBE.febeMsg[5] febe.js:6264:1
SyntaxError: test for equality (==) mistyped as assignment (=)? febe.js:1186:35
SyntaxError: test for equality (==) mistyped as assignment (=)? febe.js:1186:35
ReferenceError: reference to undefined property this.febeIgnoreList[addon.id] febe.js:884:0
SyntaxError: test for equality (==) mistyped as assignment (=)? febe.js:1186:35
ReferenceError: reference to undefined property this.febeMsg[301] febe.js:7561:1
SyntaxError: test for equality (==) mistyped as assignment (=)? febe.js:1186:35
ReferenceError: reference to undefined property this.febeIgnoreList[addon.id] febe.js:884:0

The preferences seem to be saved since they appear in the about:config page, but of note is that the items I checked in the What to backup page are all marked as default = true, except for the "Backup userChrome files", which is saved as user set = true. In fact, a lot of the settings are set as default = true, even the items that I didn't select.

Also I just noticed that the "extensions.febe.buType = both, even though it's displayed as selective. When I change the selection in the Options page to Full Profile, the setting in about:config changes to profile. When I select Selective, it gets changed to selective in the about:config page.

Hope this debug helps. It seems the preferences are being saved, but it's inconsistent whether it's being read from the FF settings file.
FEBE-paradox
 
Posts: 8
Joined: Tue Mar 31, 2015 9:04 am

Re: FEEBE amnesia !!!

Postby iBenny » Sat Apr 04, 2015 8:07 am

iBenny
 
Posts: 6
Joined: Mon Apr 02, 2012 11:06 am

Re: FEEBE amnesia !!!

Postby cbaker_admin » Sat Apr 04, 2015 1:43 pm

Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: FEEBE amnesia !!!

Postby iBenny » Sun Apr 05, 2015 9:01 pm

Hi Chuck,

I appreciate the invitation to work in the translation team but I am buzy up to my ears these days. I'll keep the invitation at hand if I manage to have spare time one day.

There is a real bug that have to be adressed : when FEEBE perform a Backup that failed and has created an empty folder :oops: , those empty Bu folders should be deleted by FEEBE because when we have too many empty BU folders and we happened to have a crashed browser to restore, as had happened to me, we loose ability to fetch Bups in older Bu folders.

Best regrads,

iBenny
iBenny
 
Posts: 6
Joined: Mon Apr 02, 2012 11:06 am

Re: FEEBE amnesia !!!

Postby cbaker_admin » Wed Apr 15, 2015 4:15 pm

Discussion about FEBE preferences not being saved moved to .
Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA


Return to Special debug versions

Who is online

Users browsing this forum: No registered users and 1 guest

cron