[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4781: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4783: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4784: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4785: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
Chuck Baker's Firefox Extension Forum • View topic - Pale Moon 27.7.2 / FEBE 10.2 error report

Pale Moon 27.7.2 / FEBE 10.2 error report

My Firefox extensions that have been released for Pale Moon

Pale Moon 27.7.2 / FEBE 10.2 error report

Postby El Narizon » Fri Feb 09, 2018 12:06 pm

El Narizon
 
Posts: 9
Joined: Thu Feb 08, 2018 4:50 pm
Location: Hamburg, Germany

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby cbaker_admin » Fri Feb 09, 2018 3:46 pm

If you can get into FEBE Options, you can hide the error console by unchecking FEBE Options > Advanced > Miscellaneous > FEBE debug mode. But if you are having problems opening the options window (as in this case), you can set the extensions.febe.debugMode preference in about:config to false (then restart Pale Moon). There is also a button in the FEBE Options window to Toggle browser (error) console, but I just tried it and it didn't work for me ... I'll have to check that out. (In fact, the error console doesn't display anything in it for me ... must be a deeper problem. But the Browser Console will log the messages. You can open the Browser Console through Tools > Web Developer > Browser Console or with the keyboard shortcut Ctrl+Shift+J. BTW, you can copy all the messages at once by selecting any one of them then pressing Ctrl+A, Ctrl+C and pasting them into your response.)

I think the first thing we need to check is to see if there is an extension conflict. But before we try that, see if FEBE works correctly in a new Pale Moon profile with nothing but FEBE installed in it.
Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby El Narizon » Sat Feb 10, 2018 12:52 pm

El Narizon
 
Posts: 9
Joined: Thu Feb 08, 2018 4:50 pm
Location: Hamburg, Germany

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby cbaker_admin » Sat Feb 10, 2018 2:36 pm

Ok ... let's look for an extension conflict. The way this is normally done you enable/disable half your extensions at a time and see which extensions are disabled when FEBE starts working correctly. This is a cumbersome process but, fortunately, I have an extension for this. It's called "Extension Conflict Troubleshooter for Firefox" (or "FECT"). I haven't uploaded it to the Pale Moon repository yet, but it still works.

Please install it and give it a go. It there is a conflict, FECT should find it.

Once installed, put the icon on the toolbar for easy access (FECT is also available from the Tools menu). Click the FECT dropdown menu and select "Start a new session". Choose "FEBE" as the target extension.

More information can be found on the .


FECT10.0.xpi
Pale Moon version of FECT
(110.35 KiB) Downloaded 385 times
Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby El Narizon » Sat Feb 10, 2018 8:37 pm

I'm not sure how FECT should work, when I click on any entry a popup occurs telling me what I already know: the name of the extension I clicked on.
When I click 'Continue' here nothing happens:
Image
El Narizon
 
Posts: 9
Joined: Thu Feb 08, 2018 4:50 pm
Location: Hamburg, Germany

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby cbaker_admin » Sun Feb 11, 2018 12:57 pm

That window should close and another should open that looks something like this:
Image

I noticed that your "Cancel" button reads "Abbrechen". That is german, correct? Maybe the issue with FECT (and FEBE) has to do with the 'de' locale. FECT only has english locales and FEBE's de locale may not be complete.

Try temporarily changing the Pale Moon preference (in about:config) general.useragent.locale from whatever it is now (probably 'de') to 'en-US'. That way Pale Moon will use the english strings. After you are finished testing, you can change the preference back.
Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby El Narizon » Sun Feb 11, 2018 2:06 pm

That's not the reason.

I guess the incompatible addon is "such incompatible", that FEBE and FECT as well are conflicting from the scratch.

I never had issues like that with other addons, neither in Pale Moon nor in Firefox - since 2003.

Edit:

It seems that somehow the settings of FEBE are saved, but not shown when the options window is reopened...
I have just seen that FEBE created a scheduled backup ...
El Narizon
 
Posts: 9
Joined: Thu Feb 08, 2018 4:50 pm
Location: Hamburg, Germany

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby cbaker_admin » Sun Feb 11, 2018 2:38 pm

Well, we've already verified that FEBE works for you in a new, fresh profile. I would suggest that you try again with a different new profile with all of your current extensions installed (extensions only - no bookmarks, passwords, history, etc.). This way we can see if there is perhaps something inherent in your existing profile that may be causing the issue.

You can backup all of your current extensions at once with FEBE using Tools > FEBE > Quick backup and checking Create single xpi. This single xpi can be installed in the new profile using either FEBE's Tools > FEBE > Restore > Restore extensions or by simply opening the xpi with Pale Moon's File > Open file. If you cannot create a single xpi backup, you can still restore all the extensions from your previous scheduled backup. When using FEBE's extension restore, you may select multiple extensions using the Ctrl-Click and/or Shift-Click methods.

If both or either FEBE/FECT work in the new populated profile, we know it is probably not an extension conflict, but something else.
Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby El Narizon » Sun Feb 11, 2018 2:51 pm

Actually, after disabling one addon after the other, I likely found the culprit:
FRITZ!Box AddOn 2.0.4

It's not easy to find, but the update url embedded in the install.rdf is still pointing to a valid location:
em:updateURL="http://download.avm.de/fritz.box/tools/fritzbox_addon/addon4ff/update.rdf"

You can open a download location here:


Actually I'm re-enabling each disabled addon one by one, I already changed back to german localization and my preferred dark theme.

I attach the addon and its .oprefs to this post for further investigation:
FRITZBoxAddOn{2.0.4}.xpi
The problematic addon as it seems by now
(596.48 KiB) Downloaded 388 times

FRITZBoxAddOn{2.0.4}.oprefs.zip
The .oprefs of it - zipped because of forum restrictions
(458 Bytes) Downloaded 396 times



Edit:

As it seems ONLY the issue with FEBE is solved by disabling the Fritzbox Addon, but not the FECT issue ...

Edit 2:

Yes, all addons and themes and language settings set back to normal, but without Fritzbox Addon, FEBE works.

FECT shows the following weird behavior:
When I click on 'Continue' inside 'Start a new session', and then on 'Cancel' and then RESTART the browser, I can choose 'Continue with next iteration' ...

After each step done I have to restart the browser to continue... :crazy:
Last edited by El Narizon on Sun Feb 11, 2018 3:15 pm, edited 2 times in total.
El Narizon
 
Posts: 9
Joined: Thu Feb 08, 2018 4:50 pm
Location: Hamburg, Germany

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby cbaker_admin » Sun Feb 11, 2018 3:13 pm

It's been a long time since I last did any development with FECT, so I'm uploading the exact version I am currently using in my Pale Moon browser. It is probably the same as the one posted above, but it may be a little different. Just for the fun of it, you might try this version (which works for me).

ExtensionConflictTroubleshooter{10.0}.xpi
The FECT I'm using
(110.01 KiB) Downloaded 398 times
Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby cbaker_admin » Sun Feb 11, 2018 3:24 pm

I don't have a AVM FRITZ!Box, so I can't test the extension.
Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby El Narizon » Sun Feb 11, 2018 3:27 pm

I just recognized that I have to enter the master password of Pale Moon when I set up FEBE to include user names and passwords in exports.
That is a problem in scheduled backups as long I'm not sitting in front of the screen...

And the exported list is in clear text, no encryption inside.

Could you implement the encryption of the exported passwords like the addon Password Exporter does?
It "somehow" hash saltes the username and the password with the browser's master password.

You could implement a password feature inside the options that only needs the user to enter the master password when disabling / enabling the feature - which should be enabled by default.

Edit:

btw the attached FECT behaves the same for me...
El Narizon
 
Posts: 9
Joined: Thu Feb 08, 2018 4:50 pm
Location: Hamburg, Germany

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby El Narizon » Sun Feb 11, 2018 3:39 pm

Wow - now FEBE works as intended but the first bug I mentioned is back - the focus stealing issue ...

Edit:

After that happened and I restarted Pale Moon the options window resized to default which is the full screen height - I have to manually resize it to smaller to get the OK button in sight ...
El Narizon
 
Posts: 9
Joined: Thu Feb 08, 2018 4:50 pm
Location: Hamburg, Germany

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby cbaker_admin » Sun Feb 11, 2018 3:45 pm

Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Re: Pale Moon 27.7.2 / FEBE 10.2 error report

Postby cbaker_admin » Sun Feb 11, 2018 3:48 pm

Chuck
cbaker_admin
Site Admin
 
Posts: 4580
Joined: Sun Nov 27, 2005 10:51 pm
Location: Glendale, AZ USA

Next

Return to Pale Moon

Who is online

Users browsing this forum: No registered users and 1 guest

cron